[time-admin] Time cannot be set manually because it is reset

Bug #475754 reported by ooze
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
system-tools-backends (Ubuntu)
Fix Released
Undecided
Unassigned
Karmic
Fix Released
Undecided
Chris Coulson
Lucid
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Description: Ubuntu 9.10
Release: 9.10

gnome-system-tools:
  Installé : 2.28.1-0ubuntu2
  Candidat : 2.28.1-0ubuntu2
 Table de version :
 *** 2.28.1-0ubuntu2 0
        500 http://ca.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg status

I was trying to set the clock time manually since a firewall blocks the port for NTP. The clock was 4 hours late. I opened System -> Administration -> Date and Time, unlocked the configuration panel, and adjusted the hour.

I expected to time not to change in the configuration panel. I also expected the time to be set after I clock the Close button.

After a few seconds, the hour is reset to what it was before changing it. Clicking the Close button before it changes back does not set the time.

This is very similar to what was reported in a comment of bug #400130.

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

So here we are. I've found the problem, which is a wrong command passed to set the time. The delay before time is reset to its previous value is quite short, and should be raised I guess. But at least with the patch at [1], if you're relatively quick, the changes will be applied.

You can apply it if you like by downloading the patch and running:
sudo patch /usr/share/system-tools-backends-2.0/scripts/Time/TimeDate.pm < [PATH TO THE FILE]

I keep the bug open because of the delay issue.

1: http://git.gnome.org/cgit/system-tools-backends-clone/patch/?id=25f00b6ea6854602d988f2d387234ee370bf58e8

Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted system-tools-backends into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
affects: gnome-system-tools (Ubuntu) → system-tools-backends (Ubuntu)
Changed in system-tools-backends (Ubuntu Lucid):
status: Confirmed → Fix Committed
Changed in system-tools-backends (Ubuntu Karmic):
status: New → Fix Committed
assignee: nobody → Chris Coulson (chrisccoulson)
Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

I've opened bug 479617 for the delay issue, as the present report will be kept for the Stable Release Update that is going on.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-tools-backends - 2.8.2-1ubuntu1

---------------
system-tools-backends (2.8.2-1ubuntu1) karmic-proposed; urgency=low

  * debian/patches/10_unbreak_user_modification.patch,
    debian/patches/11_fix_password_change.patch:
    - Upstream changes from GIT to fix modifying passwords of
      existing users from users-admin (LP: #463353)
  * debian/patches/12_fix_date_setting.patch:
    - Upstream GIT change to make it possible to change the time and
      date settings from time-admin again (LP: #475754)
 -- Chris Coulson <email address hidden> Mon, 09 Nov 2009 02:09:00 +0000

Changed in system-tools-backends (Ubuntu Karmic):
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Copied karmic-proposed to lucid.

Changed in system-tools-backends (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in system-tools-backends (Ubuntu Karmic):
status: Fix Released → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

I confirm that with the karmic-proposed version, time-admin is able to set the system time.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-tools-backends - 2.8.2-1ubuntu1

---------------
system-tools-backends (2.8.2-1ubuntu1) karmic-proposed; urgency=low

  * debian/patches/10_unbreak_user_modification.patch,
    debian/patches/11_fix_password_change.patch:
    - Upstream changes from GIT to fix modifying passwords of
      existing users from users-admin (LP: #463353)
  * debian/patches/12_fix_date_setting.patch:
    - Upstream GIT change to make it possible to change the time and
      date settings from time-admin again (LP: #475754)
 -- Chris Coulson <email address hidden> Mon, 09 Nov 2009 02:09:00 +0000

Changed in system-tools-backends (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers