missing dependecies python-gtk2 python-glade2

Bug #594229 reported by Walter Franzini on 2010-06-14
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
system-config-samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: system-config-samba

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.04.4 LTS
Release: 8.04
Codename: hardy

$ apt-cache policy system-config-samba
system-config-samba:
  Installed: 1.2.50-0ubuntu2.2
  Candidate: 1.2.50-0ubuntu2.2
  Version table:
 *** 1.2.50-0ubuntu2.2 0
        100 /var/lib/dpkg/status

Running system-config-samba fail with the following error.
$ sudo system-config-samba
[sudo] password for ....
system-config-samba requires a currently running X server.
$

Installing the the python-gtk2 python-glade2 packages solve the problem.

papukaija (papukaija) on 2010-08-31
tags: added: hardy
richard kim (shop-rattaroaz) wrote :

I think this is a duplicate of #594229. in kubuntu 10.10, glade is still a missing dependency.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-samba (Ubuntu):
status: New → Confirmed
Matt Fischer (mfisch) wrote :

In oneiric you have to install python-glade2, python-gtk2 seems to already be installed. Here is what you get when you install it without the dependencies:

Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 44, in <module>
    import mainWindow
  File "/usr/share/system-config-samba/mainWindow.py", line 30, in <module>
    import gtk.glade
ImportError: No module named glade

Matt Fischer (mfisch) wrote :

Fixed in precise (12.04). It now installs and runs without requiring me to install any dependencies.

system-config-samba (1.2.63-0ubuntu5) precise; urgency=low

  * debian/control: add a dependency on python-glade2 (LP: #749748)

 -- Brian Murray <email address hidden> Thu, 02 Feb 2012 10:16:25 -0800

Changed in system-config-samba (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers