New upstream version: v.1.2.100 (system-config-samba in Ubuntu is 7 years old and buggy)

Bug #570120 reported by Mantas Kriaučiūnas on 2010-04-26
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Baltix
Medium
Mantas Kriaučiūnas
system-config-samba (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: system-config-samba

system-config-samba package in Ubuntu 13.x and 14.04 is very outdated (6 years old) and buggy - please update to newer upstream version from https://fedorahosted.org/released/system-config-samba/ (don't forget to update debian/copyright )

Currently (March 2014) latest version is 1.2.100 - this version should fix most bugs, reported at https://bugs.launchpad.net/ubuntu/+source/system-config-samba

Look at this page https://git.fedorahosted.org/cgit/system-config-samba.git/log/ for improvements since latest Ubuntu version 1.2.63 (released on April 2008)

Fabrice Coutadeur (fabricesp) wrote :

Hi,

Latest system-config-samba requires python-slip and python-slip-dbus, that are not in Ubuntu, so the first step would be to get them in Ubuntu.

Fabrice

papukaija (papukaija) on 2010-08-31
tags: added: upgrade
summary: - system-config-samba package in Ubuntu is buggy and 2 years old - please
- update to newer upstream version
+ New upstream version: v.1.2.89
Changed in system-config-samba (Ubuntu):
status: New → Confirmed

Hi,

I've built the latest release of system-config-samba (version 1.2.91) for Ubuntu Lucid, Maverick and Natty.
I found a python-slip in 'ppa:ubuntu-contribs/contrib' and updated it to current release 0.2.14.
Both you will find in my network ppa 'ppa:dnjl/network'.

dnjl

Jeremy Bicha (jbicha) on 2011-11-15
tags: added: upgrade-software-version
removed: upgrade

Up to rev 1.2.96 as of Feb 03, 2012

summary: - New upstream version: v.1.2.89
+ New upstream version: v.1.2.96
tags: added: trusty
Changed in system-config-samba (Ubuntu):
importance: Undecided → Medium
description: updated
summary: - New upstream version: v.1.2.96
+ New upstream version: v.1.2.100
Changed in baltix:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)

Btw, python-slip and python-slip-dbus are in Ubuntu since 13.04, so, please update 6-years old system-config-samba package to latest release 1.2.100

See https://launchpad.net/ubuntu/+source/python-slip

Fabrice Coutadeur (fabricesp) wrote on 2010-08-09:
> Latest system-config-samba requires python-slip and python-slip-dbus, that are not in Ubuntu,
> so the first step would be to get them in Ubuntu

summary: - New upstream version: v.1.2.100
+ New upstream version: v.1.2.100 (system-config-samba in Ubuntu is 7
+ years old and buggy)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers