system-config-samba.py crashed with ImportError in <module>()

Bug #280872 reported by Jean-Louis Dupond on 2008-10-09
196
This bug affects 2 people
Affects Status Importance Assigned to Milestone
system-config-samba (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: system-config-samba

Seems like something is missing ...

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/share/system-config-samba/system-config-samba.py
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: system-config-samba 1.2.63-0ubuntu3
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/sbin/system-config-samba
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=nl_BE.UTF-8
 LANGUAGE=nl_BE:nl
PythonArgs: ['/usr/sbin/system-config-samba']
SourcePackage: system-config-samba
Title: system-config-samba.py crashed with ImportError in <module>()
Uname: Linux 2.6.27-6-generic x86_64
UserGroups:

Jean-Louis Dupond (dupondje) wrote :
-Zeus- (matthew-momjian) wrote :

We're going to need a lot more info... Could you tell us what happened before the crash? Anything you know?

-Zeus- (matthew-momjian) wrote :

thanks for reporting the bug, by the way

Jean-Louis Dupond (dupondje) wrote :

# system-config-samba
Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 44, in <module>
    import mainWindow
  File "/usr/share/system-config-samba/mainWindow.py", line 23, in <module>
    import sambaBackend
  File "/usr/share/system-config-samba/sambaBackend.py", line 30, in <module>
    from rhpl.translate import _, N_
ImportError: No module named rhpl.translate

Chris Coulson (chrisccoulson) wrote :

Un-duplicating. It seems to have been spuriously marked as a duplicate of an un-related bug.

Changed in system-config-samba:
importance: Undecided → Medium
status: New → Confirmed
Lance Orner (lance-orner) wrote :

I'm having the exact issue, with the same trace stack. This occurs immediately when starting System->Admin->Samba.

Running this by hand:

lance@king:~$ sudo python /usr/sbin/system-config-samba
[sudo] password for lance:
Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 44, in <module>
    import mainWindow
  File "/usr/share/system-config-samba/mainWindow.py", line 23, in <module>
    import sambaBackend
  File "/usr/share/system-config-samba/sambaBackend.py", line 30, in <module>
    from rhpl.translate import _, N_
ImportError: No module named rhpl.translate

callMeTom (almighty-spork) wrote :

I'm having the exact same issue after the most recent round up updates (up to Oct. 10). I had SAMBA installed and working, after the updates the system-config-samba command will always crash. I tried uninstalling and reinstalling and it did not fix the issue. Also /etc/init.d/samba start always fails. I am also running AMD64 release of 8.10. Any further info you want from me, just ask.
-Tom

Manowar (talon7) wrote :

Getting the same errors as reported by Lance on my HP dv7 laptop running 8.10 AMD64 edition.

I did a clean install of 8.10 (format of the root partition without importing any home directories), just to be sure.

Customizations are minimal:
- all prompted updates
- a few applications all from the Add/Remove menu
- VMWare 2.0 (compiled fresh)
- a file in the /etc/pm/sleep.d directory to re-enable the keyboard and mouse after suspend (a fix needed in 8.04 which is still in 8.10)

If there is anything I can post that will help, please ask.

badwolf blaze (blaze-x) wrote :

If more reports will help any, I too cannot get Samba to load, after doing a set of updates 10/08/08 or there about. Samba was working perfectly until those updates. I am also running Ubuntu 8.10, one system is running an AMD, and my two other systems are running Intels. I ran more updates today, but still no Samba.

Manowar (talon7) wrote :

This may be a red herring, but I saw someone having a similar issue with Python scripts. I would have passed over this, becuase it was a different application, but he mentioned compiz and my system is also incapable of running comp. My my ATI graphics card does not have the proprietary driver working that was available and working in 8.04.

Anyone else seeing this problem also not able to use compiz?

bp (badpazzword) wrote :

Honestly, it just seems like a missing dependency to the rhpl.translate module.

Chris Coulson (chrisccoulson) wrote :

The Compiz thing is a red herring. The missing dependency isn't even in the Ubuntu repository.

Changed in system-config-samba:
status: Confirmed → Triaged
Manowar (talon7) wrote :

I've only got 2 weeks of Ubuntu experience.....apologies for the misdirection.

Does this mean there is a solution? How might one add the "missing dependency" into the repository?

Brian Murray (brian-murray) wrote :

It looks to me like a patch that was in 1.2.50-0ubuntu2, 02_get_rid_of_rhpl.dpatch, is no longer in the package anymore.

Chris Coulson (chrisccoulson) wrote :

Well spotted! I find it a bit strange that there is no mention in the changelog. I'll have a look at the old patch and see if it needs any work to port it to the newer version.

Changed in system-config-samba:
assignee: nobody → chrisccoulson
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :
Changed in system-config-samba:
status: In Progress → Triaged
Chris Coulson (chrisccoulson) wrote :

I've uploaded the package in to my PPA for those who are interested in testing it.

Just applied your patch. Works great. Cheers!

Jam Ward (homemadejam-1) wrote :

Sorry, I'm kinda new to Linux.. well, been using it for about a year but yeah.

How do I apply this patch?

Thanks in advice,
Jam

James Westby (james-w) wrote :

Hey Chris,

Thanks for looking at this.

I'll be happy to sponsor it, and it should be no trouble as it's just
resurrecting an old patch.

Two questions though. Firstly, do you think the patch being removed
was just a mistake? Secondly, the patch changes the imports such
that "N_" is no longer imported, is that not actually used anywhere?

Thanks,

James

Jam Ward (homemadejam-1) wrote :

Ahh, great. Thanks for that link Edward :)

Jam

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-samba - 1.2.63-0ubuntu4

---------------
system-config-samba (1.2.63-0ubuntu4) intrepid; urgency=low

  * debian/patches/02_get_rid_of_rhpl (LP: #280872)
    - Ported old patch to quilt and new source tarball (thanks
      to Brian Murray).

 -- Chris Coulson <email address hidden> Thu, 16 Oct 2008 21:45:53 +0100

Changed in system-config-samba:
status: Triaged → Fix Released
Daniel Semblano (dsemblano) wrote :

Even with package system-config-samba - 1.2.63-0ubuntu4, I attempt to open via KDE4, gives me nothing.

Open on Terminal, the following message:

daniel@daniel-casa:~$ gksu system-config-samba

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

(gksu:4241): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32
  File "/usr/sbin/system-config-samba", line 44, in <module>
    import mainWindow
  File "/usr/share/system-config-samba/mainWindow.py", line 30, in <module>
    import gtk.glade
ImportError: No module named glade

Daniel Semblano (dsemblano) wrote :

I did install Glade via Adept (and everything related to Glade) but didn't work. So I installed via apt-get and everything (the package Samba Server Configuration Tool 1.2.63) worked out.

apt-get install glade

Kern (kern.cz) wrote :

Kubuntu 8.10 fix is install package python-glade2, works well

Adam Taylor (tochinoki) wrote :

I'm having this error on Karmic 9.10 (and other issues with samba all of a sudden)

Vragec (vragec) wrote :

#25 works for me !

codywohlers (codywohlers) wrote :

#25 works for me too!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments