file missing for system-config-samba

Bug #225805 reported by sonal on 2008-05-02
20
Affects Status Importance Assigned to Milestone
system-config-samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: system-config-samba

Hello

I've been facing difficulties in setting up samba.

1. installation of system-config-samba
2. launching it via sudo system-config-samba
=>[code]Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 41, in <module>
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 118, in __init__
    self.basic_preferences_win = basicPreferencesWin.BasicPreferencesWin(self, self.xml, self.samba_data, self.samba_backend, self.main_window)
  File "/usr/share/system-config-samba/basicPreferencesWin.py", line 93, in __init__
    self.admin = libuser.admin()
SystemError: could not open configuration file `/etc/libuser.conf': Aucun fichier ou dossier de ce type[/code]
3. creating the file via : sudo touch /etc/libuser.conf
=> system-config-samba seems to work (i'll give further informations if not)

I think there must be a mistake and the solutions could be to suppose this file empty or create it if nonexistent

The release is an almost freshly installed Hardy + samba + system-config-samba

Please warn me if any information is missing

Sonal

Ricardo Pérez López (ricardo) wrote :

Confirmed. The workaround is to create an empty /etc/libuser.conf.

Changed in system-config-samba:
status: New → Confirmed
Anders J (josefsson) wrote :

Confirmed + removing a row in smb.conf " enable spoolss=yes "
System-config-samba reacted on that row when starting.

Sean (sdans563) wrote :

this is a duplicate of bug 185543
https://bugs.launchpad.net/ubuntu/+source/system-config-samba/+bug/185543
i cannot make a a duplicate due to the other dupe of this being private

Soren Hansen (soren) wrote :

Fixed by libuser 1:0.56.7-1ubuntu1

Changed in system-config-samba:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers