[SRU] system-config-samba.py crashed with OSError in onHelpClicked()

Bug #215571 reported by gbrehier23 on 2008-04-11
140
Affects Status Importance Assigned to Milestone
system-config-samba (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned
Intrepid
Medium
Unassigned

Bug Description

Binary package hint: system-config-samba

It just crashes when trying to view help by going to help and then contents
(sorry for my english)

ProblemType: Crash
Architecture: i386
Date: Fri Apr 11 11:18:09 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/share/system-config-samba/system-config-samba.py
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: fglrx
Package: system-config-samba 1.2.50-0ubuntu2
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/system-config-samba
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/sbin/system-config-samba']
SourcePackage: system-config-samba
Title: system-config-samba.py crashed with OSError in onHelpClicked()
Traceback:
 Traceback (most recent call last):
   File "/usr/share/system-config-samba/mainWindow.py", line 487, in onHelpClicked
     os.execv(path, [path, help_page])
 OSError: [Errno 2] Aucun fichier ou dossier de ce type
Uname: Linux 2.6.24-15-generic i686
UserGroups:

gbrehier23 (guillaume-brehier) wrote :
description: updated
Changed in system-config-samba:
importance: Undecided → Medium
status: New → Confirmed
Chuck Short (zulcss) wrote :

This is due to htmlview not being available. I have backported this fix to the current version in hardy.

TEST CASE:

1. Install system-config-samba
2. Click on the help button, you should see the crash happen.

I have attached the patch that fixes the issue

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in system-config-samba:
status: New → Fix Committed
Luca Falavigna (dktrkranz) wrote :

Crash still happens using version 1.2.50-0ubuntu2.1 from hardy-proposed.

Changed in system-config-samba:
importance: Undecided → Medium

Please don't forget to modify debian/paches/00list.

--- debian/patches/00list.orig 2008-06-08 00:19:50.000000000 +0900
+++ debian/patches/00list 2008-06-08 00:20:02.000000000 +0900
@@ -3,3 +3,4 @@
 03_sysvrc
 04_desktop
 05_fixperms
+06_fix_crash_onhelp.dpatch

Changed in system-config-samba:
status: Confirmed → Fix Released
ShadowMax (shadowmax76) wrote :

1.2.50-0ubuntu2.1 from hardy-proposed does not solve the problem for me too:

Traceback (most recent call last):
  File "/usr/share/system-config-samba/mainWindow.py", line 487, in onHelpClicked
    os.execv(path, [path, help_page])
OSError: [Errno 2] No such file or directory
python: ../../src/xcb_io.c:182: process_responses: Assertion `((int) (((dpy->last_request_read)) - ((dpy->request))) <= 0)' failed.
Aborted (core dumped)

Luca Falavigna (dktrkranz) wrote :

I uploaded version 1.2.50-0ubuntu2.2 which should fix this.

Changed in system-config-samba:
status: Fix Committed → Confirmed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in system-config-samba:
status: Confirmed → Fix Committed
ShadowMax (shadowmax76) wrote :

Verification done (x86):

Version 1.2.50-0ubuntu2.2 (hardy-proposed) fixed the problem.

Dave Stroud (bigdavesr) wrote :

im up to date and still getting a crash on this.

Nick Ellery (nick.ellery) wrote :

Verification confirmed in hardy-proposed.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in system-config-samba:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers