Launcher uses gksu which is now depreciated

Bug #1772127 reported by Tony Bronze on 2018-05-18
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
system-config-samba (Ubuntu)
High
Unassigned

Bug Description

Ubuntu 18.04
Package version 1.2.63-0ubuntu6

If it helps, I done the following to get it working:

Create executable:

/usr/bin/system-config-samba-pkexec

#!/bin/sh
pkexec "/usr/sbin/system-config-samba" "$@"

create:

/usr/share/polkit-1/actions/com.ubuntu.pkexec.system-config-samba.policy

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policyconfig PUBLIC
 "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
<policyconfig>

  <action id="com.ubuntu.pkexec.system-config-samba">
    <message>Authentication is required to run Samba Config</message>

    <icon_name>system-config-samba</icon_name>
    <defaults>
      <allow_any>auth_admin</allow_any>
      <allow_inactive>auth_admin</allow_inactive>
      <allow_active>auth_admin</allow_active>
    </defaults>
    <annotate key="org.freedesktop.policykit.exec.path">/usr/sbin/system-config-samba</annotate>
    <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
  </action>

</policyconfig>

change launcher from gksu system-config-samba to system-config-samba-pkexec

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-samba (Ubuntu):
status: New → Confirmed
David (dwoodcock1) wrote :

I have the same problem,

little planning or real QA control??

No advanced notice or workarounds

Who's in charge....May-be nobody..Back to 16.04

   I wish you all luck and hope things improve fpr you all

  David EE Gc

I can suggest a work around: are you interested in it? Let me know

Andrea

> Il giorno 25/mag/2018, alle ore 16:41, David <email address hidden> ha scritto:
>
> I have the same problem,
>
> little planning or real QA control??
>
> No advanced notice or workarounds
>
> Who's in charge....May-be nobody..Back to 16.04
>
> I wish you all luck and hope things improve fpr you all
>
> David EE Gc
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1771569).
> https://bugs.launchpad.net/bugs/1772127
>
> Title:
> Launcher uses gksu which is now depreciated
>
> Status in system-config-samba package in Ubuntu:
> Confirmed
>
> Bug description:
> Ubuntu 18.04
> Package version 1.2.63-0ubuntu6
>
> If it helps, I done the following to get it working:
>
> Create executable:
>
> /usr/bin/system-config-samba-pkexec
>
> #!/bin/sh
> pkexec "/usr/sbin/system-config-samba" "$@"
>
>
> create:
>
> /usr/share/polkit-1/actions/com.ubuntu.pkexec.system-config-
> samba.policy
>
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE policyconfig PUBLIC
> "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
> "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
> <policyconfig>
>
> <action id="com.ubuntu.pkexec.system-config-samba">
> <message>Authentication is required to run Samba Config</message>
>
> <icon_name>system-config-samba</icon_name>
> <defaults>
> <allow_any>auth_admin</allow_any>
> <allow_inactive>auth_admin</allow_inactive>
> <allow_active>auth_admin</allow_active>
> </defaults>
> <annotate key="org.freedesktop.policykit.exec.path">/usr/sbin/system-config-samba</annotate>
> <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
> </action>
>
> </policyconfig>
>
> change launcher from gksu system-config-samba to system-config-samba-
> pkexec
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/system-config-samba/+bug/1772127/+subscriptions

Tony Bronze (ttiger) wrote :

Uploaded a video showing how to set up pkexec instead of gksu at https://www.youtube.com/watch?v=8TGKoQrcahE

David (dwoodcock1) wrote :

This change has effected a lot of people that run free schools and other important humanitarian efforts please take some action
we will al be most grateful

Jeremy Bicha (jbicha) on 2018-10-31
Changed in system-config-samba (Ubuntu):
importance: Undecided → Critical
importance: Critical → High
status: Confirmed → Triaged
Eric H (erichg) wrote :

I recently installed Ubuntu for the first time. I am not good with programming or software in general

I can confirm this bug, or at least that the Program will not run after installing it from Ubuntu Software

I highly recommend that you all make a GUI for Samba. There is over 8 different guides, saying how to code it in to Ubuntu 18.10 or 18.04. People like me who don't know software, won't know which of these guides to follow. Even if the correct guide was known, people like me lack the necessary skills or knowledge to implement it

I think it will hurt Ubuntu in the long run if it is not dealt with. Ubuntu is suppose to be the new Linux user friendly distribution. While it is easy to use for basic things such as the browser.. It is not easy to use the LAN or OBS

Ubuntu has the best chance to be used by Streamers (out of all of the distributions). So please make it happen!

Piotr Loza (48-1istr-9a) on 2019-01-26
no longer affects: system-config-samba
David (dwoodcock1) wrote :

   Many of us dont't understand

     (no longer affects: system-config-samba )

    It appears to s6till not work???

  David

no longer affects: system-config-samba
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers