Unable to start "gksu system-config-samba"

Bug #1723450 reported by Richard Elkins on 2017-10-13
4
Affects Status Importance Assigned to Milestone
system-config-samba (Ubuntu)
Undecided
Unassigned

Bug Description

I installed the samba server packages plus system-config-samba. Next, I attempted to run the Samba configuration applet from the "System" section of the "Settings" menu item. The results is as follows:

Error
Unable to start "gksu system-config-samba"
Failed to execute child process “gksu” (No such file or directory)

When I run `sudo system-config-samba` in a terminal window, I see this:

Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 45, in <module>
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 121, in __init__
    self.basic_preferences_win = basicPreferencesWin.BasicPreferencesWin(self, self.xml, self.samba_data, self.samba_backend, self.main_window)
  File "/usr/share/system-config-samba/basicPreferencesWin.py", line 97, in __init__
    self.admin = libuser.admin()
SystemError: could not open configuration file `/etc/libuser.conf': No such file or directory

Next I tried `sudo touch /etc/libuser.conf` since I know that this was a work-around for the same symptoms in the past (Ubuntu 15.04, Bug #1453223). Now, I can successfully run `sudo system-config-samba` in a terminal window. However, the applet still fails with the same symptoms.

Please note that I am not stuck; my Samba server is working fine. My maintenance work-around is to edit /etc/samba/smb.conf by hand and then restart the smbd service manually - an oldie that still suffices.

Feel free to contact me if the automatically-attached evidence is not sufficient for investigation.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: system-config-samba 1.2.63-0ubuntu6
ProcVersionSignature: Ubuntu 4.13.0-15.16-generic 4.13.4
Uname: Linux 4.13.0-15-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Oct 13 09:23:53 2017
InstallationDate: Installed on 2017-10-13 (0 days ago)
InstallationMedia: Xubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
PackageArchitecture: all
SourcePackage: system-config-samba
UpgradeStatus: No upgrade log present (probably fresh install)

Richard Elkins (texadactyl) wrote :
Richard Elkins (texadactyl) wrote :

Yes, this was a fresh install of 17.10 Beta 2 followed by an apt upgrade of packages.

Richard Elkins (texadactyl) wrote :

Some system logs which might help are are inside the tar.gz file.

Norbert (nrbrtx) wrote :

Thanks for reporting. It's already known - see bug 1713311.
Please mark as duplicate (I got timeout issue).

Changed in system-config-samba (Ubuntu):
status: New → Confirmed
Richard Elkins (texadactyl) wrote :

Symptoms gone in 17.10.

Norbert (nrbrtx) wrote :

Bug is still actual for 17.10 with GNOME on Wayland.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers