There was an error during the CUPS operation: 'client-error-not-possible'

Bug #851189 reported by Christopher Barrington-Leigh on 2011-09-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Medium
Unassigned

Bug Description

I'm a dumb user.
I'm on the latest Ubuntu (Linux cpbl-thinkpad 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux)

I tried to add a printer (System->Admin->Printing->Add->Find NetworkPrinter

That searched. Up came a Xerox WC 5638 apparently hosted on a colleague's Macintosh. I click on that and get told it's a "Remote CUPS printer via DNS-SD".

I click Forward, am prompted for name, description, location. I fill those out and click Apply.

up pops:

CUPS server error: There was an error during the CUPS operation: 'client-error-not-possible'

This is repeatable.
Desperately,
c

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: cups 1.4.6-5ubuntu1.4
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
Architecture: amd64
Date: Thu Sep 15 14:50:52 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: LENOVO 2901CTO
Papersize: letter
PpdFiles:
 hp-LaserJet-1320-series: HP LaserJet 1320 series Postscript (recommended)
 /etc/cups/ppd/Dell-5310n-B+W-IHSP-2ndFlr.ppd:*NickName: "Dell Laser Printer 5310n (English)"
 /etc/cups/ppd/Dell-5110cn-COLOUR-IHSP-2ndFlr.ppd:*NickName: "Dell Laser Printer 5310n (English)"
 Brother-MFC-8840D: Brother MFC-8840D BR-Script3
 XeroxWorkCentre5638: Xerox WorkCentre 5638
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=7bcaa9ff-22c9-4574-b9f1-04b21eff087a ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/16/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6UET54WW (1.34 )
dmi.board.name: 2901CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6UET54WW(1.34):bd09/16/2010:svnLENOVO:pn2901CTO:pvrThinkPadT410s:rvnLENOVO:rn2901CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2901CTO
dmi.product.version: ThinkPad T410s
dmi.sys.vendor: LENOVO

Till Kamppeter (till-kamppeter) wrote :

Can you the following command in a terminal window:

system-config-printer --debug 2>&1 | tee log

This starts system-configprinter. Then do the same steps as you did in your bug description: Click "Add", then choose "Find Network Printer", then choose again the Xerox WC 5638 on your colleague's Macintosh, "Remote CUPS printer via DNS-SD", Forward, enter name, Apply.

After that, attach the file "log" to this bug report. Do not compress the file.

affects: cups (Ubuntu) → system-config-printer (Ubuntu)
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete

I followed your instructions (plus clickd "okay", and then repeated "apply" and "okay".
see attached.

Till Kamppeter (till-kamppeter) wrote :

I have found out what the problem is. system-config-printer tries to crate a print queue with an URI which contains double quotes. Same as if you try the following command in a terminal window:

lpadmin -p testprinter -E -v dnssd://Xerox%20WC%205638%20"CHARLESMEREDITHHOUSE_207"%20%40%20Arijit%20Nandi%E2%80%99s%20Mac._ipp._tcp.local/cups

CUPS complains with "Bad device-uri" and creates a queue pointing to /dev/null.

Changed in system-config-printer (Ubuntu):
status: Incomplete → Triaged
Till Kamppeter (till-kamppeter) wrote :

Fixed in system-config-printer 1.3.6 in Oneiric.

Changed in system-config-printer (Ubuntu):
status: Triaged → Fix Released
Till Kamppeter (till-kamppeter) wrote :

For Natty, you can create the desired queue on the command line via:

lpadmin -p testprinter -E -v dnssd://Xerox%20WC%205638%20%22CHARLESMEREDITHHOUSE_207%22%20%40%20Arijit%20Nandi%E2%80%99s%20Mac._ipp._tcp.local/cups

The dumb user / OP here. Thanks !!
Of course, I wouldn't be trying to use this other person's Mac (hm, his name is plastered all over an ubuntu forum, now...) to reach that printer if I could just print to the darned thing directly.
 Is there any chance this bug is also related to the fact that when I set it up via its IP address, selecting the right ppd file, etc, printing to it does not work (job sits forever in "processing")? Or should I bark up other bug/support trees for that?

yours,
the only person in my building who can't print to any of the 15 printers.

Till Kamppeter (till-kamppeter) wrote :

Direct access to the printer has nothing to do with the problem of the quotes. Please file a separate bug for that and follow the instructions on https://wiki.ubuntu.com/DebuggingPrintingProblems for that. Also try a live CD of Oneiric, perhaps the bug is fixed there.

Hi. 11.10 updates don't have this problem, which I think means your fix reached me. thanks.

((Moreover, it turns out that the printer was telling me the wrong IP address for itself. Using the right one made installing it directly on my machine easy.))

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers