system-config-printer crashes by trying to enter "usb:/dev/usblp0" as Device URI

Bug #81053 reported by nemesyz
2
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: system-config-printer

I tried to install a Samsung ML-1610 Printer via USB
(printer is not recognized automatically; USB cannot be choosen as Port in the configuration)

Tried to set the device URI manually to "usb:/dev/usblp0" --> programm crashes

ProblemType: Crash
CrashCounter: 1
Date: Tue Jan 23 00:32:10 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InterpreterPath: /usr/bin/python2.5
Package: system-config-printer 0.7.39-0ubuntu1
ProcCmdline: /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
ProcCwd: /home/nemesyz
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 PATH=/usr/local/linuxprinter/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bashSignal: 11
SourcePackage: system-config-printer
Uname: Linux wh6-405 2.6.20-5-generic #2 SMP Sat Jan 6 14:50:47 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

Revision history for this message
nemesyz (carsten-grimm) wrote : CoreDump.gz
Revision history for this message
nemesyz (carsten-grimm) wrote : Dependencies.txt
Revision history for this message
nemesyz (carsten-grimm) wrote : Disassembly.txt
Revision history for this message
nemesyz (carsten-grimm) wrote : ProcMaps.txt
Revision history for this message
nemesyz (carsten-grimm) wrote : ProcStatus.txt
Revision history for this message
nemesyz (carsten-grimm) wrote : Registers.txt
Revision history for this message
nemesyz (carsten-grimm) wrote : Stacktrace.txt
Revision history for this message
nemesyz (carsten-grimm) wrote : StacktraceTop.txt
Revision history for this message
nemesyz (carsten-grimm) wrote : ThreadStacktrace.txt
Revision history for this message
Jani Monoses (jani) wrote :

is this still the case with latest feisty?

Revision history for this message
nemesyz (carsten-grimm) wrote : Re: [Bug 81053] Re: system-config-printer crashes by trying to enter "usb:/dev/usblp0" as Device URI

Hi!

I cannot test this now as the printer is 300 km far away from my current
position, but that bug could be fixed with the following command:

sudo chmod a+rw /dev/usblp0

sry but I totally forgot to add that information :-(

On Mo, 2007-03-12 at 14:55 +0000, Jani Monoses wrote:
> is this still the case with latest feisty?
>

Revision history for this message
Tim Waugh (twaugh) wrote :

system-config-printer doesn't have anything to do with the actual device node -- it's an opaque URI as far as it is concerned -- so it's difficult to see why that would make a difference.

Revision history for this message
nemesyz (carsten-grimm) wrote :

Maybee its because it wasn't able to access the dev-file? I am sorry
that I cannot help you with this :-( ... cups didn't work either before
the "chmodding" was done ...

On Mo, 2007-03-12 at 17:17 +0000, Tim Waugh wrote:
> system-config-printer doesn't have anything to do with the actual device
> node -- it's an opaque URI as far as it is concerned -- so it's
> difficult to see why that would make a difference.
>

Revision history for this message
Jani Monoses (jani) wrote :

users of recent feisty are reporting this works now

Changed in system-config-printer:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers