2 problems finding SAMBA printer name with spaces inside

Bug #808137 reported by Andrea on 2011-07-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Medium
Unassigned

Bug Description

Date: 07 July 2011
Operating system: Ubuntu 11.04 [ I can't recover Ubuntu or cups exact version because I have no further access to the PC]

I installed a Windows shared printer [10.0.0.51/Samsung SCX4200] into an Ubuntu laptop.
I selected "Windows printer via SAMBA", then inserted the host address, then clicked on "find"
First problem noticed:
- when I inserted "smb://10.0.0.51" as host, Ubuntu doesn't find any printer
- when I inserted "smb://10.0.0.51/" as host, Ubuntu shows: "smb://10.0.0.51/Samsung SCX4200"

When I accepted the printer, the second problem appeared:
- the printer name was reported into the host address textbox as "smb://10.0.0.51/Samsung20SCX4200"
  instead of "smb://10.0.0.51/Samsung%20SCX4200"
- I was not able to manually insert the missing "%" by pressing shift+5
- I resolved opening a GEdit, copying a "%" into the clipboard and pasting it into the textbox

Hope that will be useful...

Regards,
Andrea

Till Kamppeter (till-kamppeter) wrote :

Tim, can you have a look into that? Thanks.

affects: cups (Ubuntu) → system-config-printer (Ubuntu)
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
Jiri Popelka (jpopelka) wrote :

The second problem seems like bug #747400

Tim Waugh (twaugh) wrote :

Should be fixed in 9008ff24c8dad20f49c41dd79cbc121bc4c0784f.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.3.3+20110712-0ubuntu1

---------------
system-config-printer (1.3.3+20110712-0ubuntu1) oneiric; urgency=low

  * New upstream release
     o GIT 1.3.x snapshot from 12 July 2011
     o URL-quote URIs when using "Find Network Printer" (LP: #808137).
     o Downloadable drivers: don't display printers for which there are no
       drivers (LP: #695199, Red Hat bug #668154).
     o Kerberos support for the SMB 'Verify' button.
     o Removed IPP/HTTP device screen in favour of "Enter URI" (Red Hat bug
       #685091).
 -- Till Kamppeter <email address hidden> Tue, 12 Jul 2011 17:24:12 +0200

Changed in system-config-printer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers