Server settings are untranslated

Bug #777188 reported by immortel on 2011-05-04
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
System Config Printer
Fix Released
Undecided
Unassigned
Ubuntu Translations
Low
Unassigned
system-config-printer (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: system-config-printer

The window showing the printers is in French but the server setting window is not translated at all.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: system-config-printer-gnome 1.3.1+20110222-0ubuntu16.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed May 4 11:26:51 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
Lpstat: device for E210: usb://Lexmark/E210
MachineType: Gateway DX4320
PackageArchitecture: all
Papersize: letter
PpdFiles: E210: Lexmark E210 Foomatic/gdi (recommended)
ProcEnviron:
 LANGUAGE=fr_CA:en
 LANG=fr_CA.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=12a3e76a-b2f6-47ee-8275-00d561a664c2 ro quiet splash vt.handoff=7
SourcePackage: system-config-printer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/10/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P01-A3
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: DX4320
dmi.board.vendor: Gateway
dmi.chassis.type: 3
dmi.chassis.vendor: Gateway
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP01-A3:bd08/10/2010:svnGateway:pnDX4320:pvr:rvnGateway:rnDX4320:rvr:cvnGateway:ct3:cvr:
dmi.product.name: DX4320
dmi.sys.vendor: Gateway

immortel (immortel32) wrote :
David Planella (dpm) on 2011-05-06
Changed in ubuntu-translations:
assignee: nobody → Ubuntu French Translators (ubuntu-l10n-fr)
Jiri Popelka (jpopelka) wrote :

David, this is not a problem in French translation but in system-config-printer (see also Bug #778180).
I've been trying to figure out what's wrong but with no success so far.

Gabor Kelemen (kelemeng) wrote :

This is the same problem that happened before in bug #557199 (see comment #20) - no translation domain specified to a function that expects one. This patch fixes it.

Changed in ubuntu-translations:
status: New → Triaged
Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Changed in ubuntu-translations:
importance: Undecided → Low
assignee: Ubuntu French Translators (ubuntu-l10n-fr) → nobody
Jiri Popelka (jpopelka) wrote :

Yes, that's it.
I just fixed it upstream (b479845f) and now I see you were faster :-) thanks

And I remember bug #557199 now.

AJenbo (ajenbo) on 2011-05-06
summary: - French translation for server settings is not done
+ Server settings are untranslated
Changed in system-config-printer (Ubuntu):
status: Confirmed → In Progress
Changed in system-config-printer (Ubuntu Natty):
status: New → In Progress
Changed in system-config-printer (Ubuntu):
status: In Progress → Fix Committed
Changed in system-config-printer (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.3.1+20110222-0ubuntu17

---------------
system-config-printer (1.3.1+20110222-0ubuntu17) oneiric; urgency=low

  * debian/patches/73_server-settings-set-translation-domain.patch: Server
    settings dialog did not appear translated (LP: #777188).
 -- Till Kamppeter <email address hidden> Fri, 6 May 2011 18:55:00 +0200

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Uploaded the fix also to natty-proposed for an SRU. The fix is simple (see attached debdiff) and it would be nice if Natty users get translated system settings.

tags: added: patch-accepted-upstream
Till Kamppeter (till-kamppeter) wrote :

Gabor, Jiri, thank you very much for your patches. I have uploaded fixed Ubuntu packages now.

Accepted system-config-printer into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
immortel (immortel32) wrote :

I just tested it and it is translated #1.

You can close this issue.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.3.1+20110222-0ubuntu16.3

---------------
system-config-printer (1.3.1+20110222-0ubuntu16.3) natty-proposed; urgency=low

  * debian/patches/73_server-settings-set-translation-domain.patch: Server
    settings dialog did not appear translated (LP: #777188).
 -- Till Kamppeter <email address hidden> Fri, 6 May 2011 18:55:00 +0200

Changed in system-config-printer (Ubuntu Natty):
status: Fix Committed → Fix Released
Gabor Kelemen (kelemeng) wrote :

Works for me too.
Martin, could you please move the package to -updates?

Gabor Kelemen (kelemeng) on 2011-07-21
Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in system-config-printer:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers