Applet wrongly replaces space in Samba share URI

Bug #747400 reported by Tomasz Magulski on 2011-04-01
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: system-config-printer

When I have printer available as a samba share, and the name of this printer has space (eg. "HP 1018"), after finding it in share browser, aplet wrongly replate space to "20" (instead to "%20" afaik), and printer is no accesible.

When I try to add % to uri by myself it's not possible using aplet, but when I have add this char directly in /etc/cups/printers.conf printer start to work.

package version: 1.3.1+20110222-0ubuntu12
Ubuntu version: 11.04

Hello,

I did the a bug report on the same bug as the reported here and Jiri Popelka said this bug is solved, but Synaptic did not showed up any updates to this package...

My duplicate of this bug is: https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/780115

Thanks for your help,

fsanchez (fransan-met) wrote :

I have a very similar bug, though not sure if it's the same, because I'm using KDE (Kubuntu Natty):

I can't configure a Samba printer with the printer applet because it has spaces. But it doesn't replace spaces with "%20", it just "eats" the spaces. example:

SMB printer.
smb://addc0/HPLaserJetProfessionalP1606dn

when it should be
smb://addc0/HP LaserJet Professional P1606dn

So it doesn't find any printer. (I have already been able to configure this printer in 2 machines with Kubuntu 10.04). As I said, there isn't any "%20"

If the problem I'm describing is different and I should creat a new report, please, just tell me.

Your problem is exactly equal to mine... I changed the printer sharing
name (removing all spaces in it's sharing name) in the Windows and, with
that, I could configure my Linux to access it via SAMBA...

In my opinion, this is a bug that should be fixed as soon as possible...
This can lead problem in corporative environments that have a lot of
printers shared in a network...

--
André Madureira

Fixed upstream in GIT rev. 8f2921595d (or release version 1.3.3).

Changed in system-config-printer (Ubuntu):
status: New → Triaged
Till Kamppeter (till-kamppeter) wrote :

The patch (attached) is trivial, so it is a candidate for an SRU for Natty. In Oneiric the problem will get fixed by updating to system-config-printer 1.3.3.

Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
Changed in system-config-printer (Ubuntu Natty):
status: New → Triaged
importance: Undecided → Medium
tags: added: patch-accepted-upstream
Till Kamppeter (till-kamppeter) wrote :

I have uploaded the fixed package for Natty into the -proposed queue for an SRU now. As soon as it gets approved (and an appropriate comment posted here) please test the package to see whether it solves your problem. A debdiff showing the changes compared to the current package is attached.

Changed in system-config-printer (Ubuntu Natty):
status: Triaged → Fix Committed
summary: - aplet wrongly replace space from samba share uri
+ Applet wrongly replaces space in Samba share URI
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package system-config-printer - 1.3.3+20110602-0ubuntu1

---------------
system-config-printer (1.3.3+20110602-0ubuntu1) oneiric; urgency=low

  * New upstream release
     o GIT 1.3.x snapshot from 2 June 2011
     o State of 1.3.3 release
     o Main application
        - Set translation domain for ServerSettingsDialog (LP: #777188).
        - scp-dbus-service: Ignore setlocale() errors (LP: #748964).
        - Allow % character in SMB URI (LP: #747400).
        - More error handling (LP: #744783).
        - Avoid traceback if printer duplication fails (Red Hat bug #694629).
        - Fixed off-by-one error in monitor.
        - Fixed printer renaming (LP: #726954).
        - Set connected state when connecting to server fails (Red Hat bug
   #685098).
        - Handle the situation where cupsd has died/restarted more gracefully.
     o Printer Properties dialog:
        - Added PrinterModified D-Bus signal to printer properties interface.
        - More robustness for printer properties dialog when printer removed
          (LP: #741987).
        - Just hide Printer Properties dialog on delete-event (LP: #729966).
        - Extra job options: print-quality, printer-resolution, output-bin.
        - Automatically show horizontal scrollbar in job options screen.
        - Ignore "output-mode-default" attribute as it is not settable.
        - Handle IPP_TAG_RESOLUTION types (requires pycups-1.9.55).
        - Don't traceback if option value cannot be handled.
        - Fixed traceback in options.py (Red Hat bug #679103).
     o New Printer dialog
        - Fixed PPDs loader when using CUPS remotely or when DBus not available
          (Red Hat bug #693515).
        - Handle failure to load PPDs more gracefully (LP: #742409).
        - Avoid traceback when cancelling New Printer dialog after failure.
        - Make sure everything is ready before handlers might be called (Red
   Hat bug #689336).
        - Handle URIs in Find Network Printer entry, and use 'Enter URI'
   instead of 'Other' (Red Hat bug #685091).
        - Use "Do It Later" instead of "Cancel" for adjust firewall dialog
   (Upstream bug #213).
        - Fixed an instance where NewPrinterGUI might not have self.printers
   set (Red Hat bug #680683).
        - IPPHostname can contain colon (to specify port).
        - Fixed automatic driver installation when changing the driver.
        - Removed stale code left over from conversion to gobjects.
        - Ensure all uses of ppdsloader supply the Device ID.
        - Fixed some small typos in newprinter --help output.
        - Prevent traceback after 2nd drivers search dialog is cancelled (Red
   Hat bug #680288).
     o Driver handling:
        - Activated and fixed testing mode for device ID/driver association
        - Match HP-Fax2/3/... PPDs, as well as Ubuntu/Debian hpijs-ppds
          packages.
        - preferreddrivers.xml: Identify hpcups and hpijs fax PPDs.
        - Match native hpijs driver (drv:///hp/hpijs.drv/...) as "hpijs".
        - Handle Ubuntu locations of hpcups.drv and hpijs.drv.
        - preferreddrivers.xml: match OpenPrinting gutenprint PPD names as
          gutenprint.
    ...

Read more...

Changed in system-config-printer (Ubuntu):
status: Triaged → Fix Released

Accepted system-config-printer into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Till Kamppeter (till-kamppeter) wrote :

<email address hidden>, can you please follow the instructions in comment #8 and test whether removing and creating your print queue again after updating system-config-printer gives you a working print queue? Thanks.

Sebastien Bacher (seb128) wrote :

could somebody try the sru and verify if it fixes the issue?

PhilippeDePass (depassp) wrote :

I tried to test this, but do not see the package available in natty-proposed

J B (scottie) wrote :

bug still present in kubuntu 12.04.1 with current updates installed.

only '20' denotes the space character.

same workaround: just add % before the 20's

Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in system-config-printer (Ubuntu Natty):
status: Fix Committed → Won't Fix
The Marauder (arn-epsilon) wrote :

Hello !
I can not believe that this bug still exists, after 7 years !

Here in mint sylvia (ubuntu xenial), i've the problem and i had to add %20 for each space.

For poeple doesn't know linux it's not very good ...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers