Replace standard printing applet with indicator

Bug #588200 reported by Dmitry Shachnev on 2010-06-01
106
This bug affects 18 people
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
High
Lars Karlitski
Natty
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Lars Karlitski
ubuntu-meta (Ubuntu)
High
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
High
Unassigned
unity (Ubuntu)
Natty
Wishlist
Unassigned
Oneiric
Wishlist
Unassigned
Precise
Wishlist
Unassigned

Bug Description

The standard coloured GNOME printing applet in Lucid is not integrated with the notification area (indicator-applet). It will be good if we had indicator-printing instead of it.

Update: In Ubuntu 11.04 the current printing applet *will not be visble at all*.

<https://wiki.ubuntu.com/Printing#menu>: "Whenever you have print jobs queued, in progress, or finished less than five seconds ago, a printing status menu should be present at the leading end of the system indicator area..."

(The artwork for the menu title is bug 840151.)

Dmitry Shachnev (mitya57) wrote :
Dmitry Shachnev (mitya57) wrote :

And please change importance to "wishlist".

Omer Akram (om26er) on 2010-06-01
affects: indicator-applet (Ubuntu) → cups (Ubuntu)
affects: indicator-applet → null
Changed in null:
status: New → Invalid
Till Kamppeter (till-kamppeter) wrote :

The applet is part of system-config-printer, not of CUPS.

affects: cups (Ubuntu) → system-config-printer (Ubuntu)
Dmitry Shachnev (mitya57) wrote :

Since Ubuntu Natty won't have standard notification area, it needs to be fixed.

Till Kamppeter (till-kamppeter) wrote :

Tim, any chance to add some indicator applet frontend to the system-config-printer-applet?

Tim Waugh (twaugh) wrote :

What needs changing here, just the artwork, or something more?

I know that GNOME will shortly be removing support for status icons -- is this to do with that?

Artwork is not the most important thing. Current Unity shell in 11.04
doesn't display GNOME2's notification area, and so user doesn't get
any information about is something printiing now or not.

Tim Waugh (twaugh) wrote :

Documentation pointer about what needs changing?

Dmitry Shachnev (mitya57) wrote :

https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationIndicators

2010/12/9, Tim Waugh <email address hidden>:
> Documentation pointer about what needs changing?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/588200
>
> Title:
> Replace standard printing applet with indicator
>
> Status in NULL Project:
> Invalid
> Status in “system-config-printer” package in Ubuntu:
> New
>
> Bug description:
> The standard coloured GNOME printing applet in Lucid is not integrated
> with the notification area (indicator-applet). It will be good if we had
> indicator-printing instead of it.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/null/+bug/588200/+subscribe
>

Tim Waugh (twaugh) wrote :

OK. I'm very unlikely to have time to do this I'm afraid. More useful would be to remove the necessity for the status icon and instead have e.g. "Cancel" action in a 'job queued/printing' notification.

Dmitry Shachnev (mitya57) wrote :

So, Unity needs to white-list Printing applet. (Now only Wine, Skype and Java apps are white-listed).

affects: null → unity
Changed in unity:
status: Invalid → New
description: updated
Alex Launi (alexlauni) on 2011-03-16
Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity:
status: New → Invalid
Felix (apoapo) wrote :

Which string has to be added to the whitelist? system-config-printer-applet , applet.py , python did not work.

I really have no idea. The running applet on a classic desktop shows in "ps" as follows:

till 2739 0.0 0.5 253112 21968 ? S Mar27 3:30 /usr/bin/python /usr/share/system-config-printer/applet.py

It is started via /etc/xdg/autostart/print-applet.desktop (translations removed):

----------
[Desktop Entry]
Encoding=UTF-8
Name=Print Queue Applet
Comment=System tray icon for managing print jobs
Exec=system-config-printer-applet
Terminal=false
Type=Application
Icon=printer
NotShowIn=KDE;LXDE;
StartupNotify=false
X-GNOME-Autostart-Delay=30
X-Ubuntu-Gettext-Domain=system-config-printer
X-Desktop-File-Install-Version=0.18
Categories=GTK;Monitor;System;
----------

I hope these hints help.

Jeremy Bicha (jbicha) wrote :

Add this to your whitelist
scp-dbus-service.py
and either log out and in or reset Unity for it to go into effect.

Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

I reported bug 771562 to get this whitelisted for 11.04. This bug should stay open so the printing applet can be replaced by an indicator for 11.10.

Can we whitelist the system-config-printer applet in Natty as an SRU?

Changed in system-config-printer (Ubuntu Natty):
status: Confirmed → Won't Fix
Changed in unity (Ubuntu Natty):
status: Invalid → Confirmed
Changed in system-config-printer (Ubuntu Oneiric):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

bug #771562 is about the sru whitelist

Changed in unity (Ubuntu Natty):
status: Confirmed → Invalid
importance: Undecided → Wishlist
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu Oneiric):
status: New → Invalid
importance: Undecided → Wishlist
Changed in system-config-printer (Ubuntu Oneiric):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Closing the unity bug since that's an issue in unity, closing the natty target since that will not be wiorked for natty out of the whitelist which has a new bug, confirming that we need to port the code in 11.10

Changed in system-config-printer (Ubuntu Oneiric):
importance: Low → High
Changed in system-config-printer (Ubuntu):
importance: Undecided → High
Changed in system-config-printer (Ubuntu Natty):
importance: Undecided → High
Dmitry Shachnev (mitya57) wrote :

Will system-config-printer be replaced with GNOME 3 Control Center applet in Oneiric (like it's done in Fedora AFAIK)?

Dmitry Shachnev, this still has to be decided, as system-config-printer contains 10 years of experience of Tim Waugh and me in configuring printers and simp[ly dropping it would be a major loss. A possible scenario is to use the applet of GNOME 3 but system-config-printer as printer setup tool.

Sebastien, can you post a link to the whitelist bug? Thanks.

Matthew Paul Thomas (mpt) wrote :

Marking as Incomplete because the replacement has not been designed yet. It might involve an indicator, or it might not.

Changed in system-config-printer (Ubuntu Oneiric):
assignee: nobody → Matthew Paul Thomas (mpt)
status: Confirmed → Incomplete
Dmitry Shachnev (mitya57) wrote :

Any update on this?

mpt, seb128, how will we proceed so that users get easy access to their print jobs on the Oneiric desktop?

tags: added: rls-mgr-o-tracking
markba (mark-baaijens) wrote :

I've tested this on a vanilla 11.10 and the printer status icon appears automatically, so the problem is functionally gone. Technically not of course, because all status icons should be indicators (by design).

Martin Pitt (pitti) wrote :

For oneiric the tray icon was whitelisted, so wontfix for oneiric.

Changed in system-config-printer (Ubuntu Oneiric):
status: Incomplete → Won't Fix
tags: removed: rls-mgr-o-tracking

Always won't fix this, won't fix that... so much for bug reports and system
support...

On Fri, Oct 7, 2011 at 2:16 AM, Martin Pitt <email address hidden> wrote:

> For oneiric the tray icon was whitelisted, so wontfix for oneiric.
>
> ** Changed in: system-config-printer (Ubuntu Oneiric)
> Status: Incomplete => Won't Fix
>
> ** Tags removed: rls-mgr-o-tracking
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (836878).
> https://bugs.launchpad.net/bugs/588200
>
> Title:
> Replace standard printing applet with indicator
>
> Status in Unity:
> Invalid
> Status in “system-config-printer” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Invalid
> Status in “system-config-printer” source package in Natty:
> Won't Fix
> Status in “unity” source package in Natty:
> Invalid
> Status in “system-config-printer” source package in Oneiric:
> Won't Fix
> Status in “unity” source package in Oneiric:
> Invalid
>
> Bug description:
> The standard coloured GNOME printing applet in Lucid is not integrated
> with the notification area (indicator-applet). It will be good if we
> had indicator-printing instead of it.
>
> Update: In Ubuntu 11.04 the current printing applet *will not be
> visble at all*.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/588200/+subscriptions
>

--
*TND*esigns | Graphic & Industrial Design Solutions Inc.

514 . 583 . 7386

Jeremy Bicha (jbicha) wrote :

Nathanel, I think you misunderstand. This bug is still open and it's high importance. It's just not going to get fixed before Oneiric is released.

I do understand... A few releases later... maybe...

I've been on ubuntu long enough to know.

On Fri, Oct 7, 2011 at 1:06 PM, Jeremy Bicha <email address hidden> wrote:

> Nathanel, I think you misunderstand. This bug is still open and it's
> high importance. It's just not going to get fixed before Oneiric is
> released.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (836878).
> https://bugs.launchpad.net/bugs/588200
>
> Title:
> Replace standard printing applet with indicator
>
> Status in Unity:
> Invalid
> Status in “system-config-printer” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Invalid
> Status in “system-config-printer” source package in Natty:
> Won't Fix
> Status in “unity” source package in Natty:
> Invalid
> Status in “system-config-printer” source package in Oneiric:
> Won't Fix
> Status in “unity” source package in Oneiric:
> Invalid
>
> Bug description:
> The standard coloured GNOME printing applet in Lucid is not integrated
> with the notification area (indicator-applet). It will be good if we
> had indicator-printing instead of it.
>
> Update: In Ubuntu 11.04 the current printing applet *will not be
> visble at all*.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/588200/+subscriptions
>

--
*TND*esigns | Graphic & Industrial Design Solutions Inc.

514 . 583 . 7386

Tom Slominski (tomslominski) wrote :

As you are "on ubuntu long enough to know.", I'd thought that you'd be familiar with the release cycle and understand that not everything can be fixed in the 6 month time frame. A small fix for this has been provided and a better fix will probably be provided in 12.04.

Yes, I am aware of that, yet the delay always implies "better things to
come" rather than make it work now.

I don't want to seem like I'm complaining more than anything, but its
attention to those small details and unification of the whole distribution
in terms of design and function that can promote the wow factor for Ubuntu.

Marking it as 'critical' doesn't do much on an end-user perspective except
for explaining an emergency status.

I do wish I knew how to write code and submit changes to make things go
faster; I'd be doing that around the clock..

Attention has been lacking in that field since the unity project started ...
that's all I have to say about it.
On Oct 7, 2011 1:40 PM, "Tom Slominski" <email address hidden> wrote:

> As you are "on ubuntu long enough to know.", I'd thought that you'd be
> familiar with the release cycle and understand that not everything can
> be fixed in the 6 month time frame. A small fix for this has been
> provided and a better fix will probably be provided in 12.04.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (836878).
> https://bugs.launchpad.net/bugs/588200
>
> Title:
> Replace standard printing applet with indicator
>
> Status in Unity:
> Invalid
> Status in “system-config-printer” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Invalid
> Status in “system-config-printer” source package in Natty:
> Won't Fix
> Status in “unity” source package in Natty:
> Invalid
> Status in “system-config-printer” source package in Oneiric:
> Won't Fix
> Status in “unity” source package in Oneiric:
> Invalid
>
> Bug description:
> The standard coloured GNOME printing applet in Lucid is not integrated
> with the notification area (indicator-applet). It will be good if we
> had indicator-printing instead of it.
>
> Update: In Ubuntu 11.04 the current printing applet *will not be
> visble at all*.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/588200/+subscriptions
>

Changed in system-config-printer (Ubuntu Precise):
assignee: nobody → Matthew Paul Thomas (mpt)
milestone: none → precise-alpha-1
Dave Walker (davewalker) on 2011-12-01
Changed in system-config-printer (Ubuntu):
milestone: precise-alpha-1 → precise-alpha-2
no longer affects: unity (Ubuntu)
no longer affects: unity
Changed in system-config-printer (Ubuntu Precise):
status: Confirmed → In Progress
Matthew Paul Thomas (mpt) wrote :

I've now written up a specification for showing printing progress in an indicator menu. <https://wiki.ubuntu.com/Printing?action=diff&rev2=5&rev1=3>

description: updated
Changed in system-config-printer (Ubuntu Precise):
status: In Progress → Triaged
assignee: Matthew Paul Thomas (mpt) → Lars Uebernickel (larsu)
Changed in system-config-printer (Ubuntu Oneiric):
assignee: Matthew Paul Thomas (mpt) → nobody
description: updated
tags: added: rls-mgr-p-tracking
Martin Pitt (pitti) on 2012-02-06
Changed in system-config-printer (Ubuntu):
milestone: precise-alpha-2 → ubuntu-12.04-beta-1
Jeremy Bicha (jbicha) wrote :

indicator-printers (0.1-0ubuntu1) precise; urgency=low

  * Sponsored to Ubuntu, thanks Lars!
  * debian/control:
    - recommends "unity | indicator-renderer", indicators are not that
      useful without a renderer
    - slightly improve the description
  * debian/copyright:
    - updated to the current format
  * debian/rules:
    - comment DEB_BUILDDIR to workaround a out of srcdir build issue

  [ Lars Uebernickel ]
  * Initial release.

Changed in system-config-printer (Ubuntu Precise):
status: Triaged → Fix Released
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

Something needs to pull it on the CD now (mir got approved today)

system-config-printer task done, thanks, Lars.

----------

system-config-printer (1.3.8+20120201-0ubuntu2) precise; urgency=low

  * debian/system-config-printer-gnome.install: Do not install applet.py.
  * debian/control: As we do not install the applet, do not mention it in
    the package descriptions.
  * debian/patches/80-add-show-jobs-cmdline-arg.patch: Add "--show-jobs
    <printer>" command line option to system-config-printer. This opens
    the job viewer for the specified print queue.

 -- Lars Uebernickel <email address hidden> Wed, 15 Feb 2012 19:42:31 +0100

Changed in system-config-printer (Ubuntu Precise):
status: Triaged → Fix Released
Changed in ubuntu-meta (Ubuntu Natty):
status: New → Invalid
Changed in ubuntu-meta (Ubuntu Oneiric):
status: New → Invalid
Changed in ubuntu-meta (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-1

seb128, I added a ubuntu-meta task for this now.

Martin Pitt (pitti) wrote :

unity already pulls in indicator-printers now.

Changed in ubuntu-meta (Ubuntu Precise):
milestone: ubuntu-12.04-beta-1 → none
status: Triaged → Invalid
Changed in unity (Ubuntu Precise):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers