system-config-printer: make driver installation optional

Bug #564633 reported by Michael Kofler on 2010-04-16
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
system-config-printer (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: system-config-printer

Configuring a new printer is awfully painful in Lucid :-(

(1) I just tried to configure my PostScript network printer (a Kyocera FS1800+, correctly identified in the first step of system-config-printer).

(2) In the next step, jockey-gtk starts to search for drivers. After quite a while, it offers a list of ca. 35 drivers (!?). Neither does jockey-gtk mark the relevant one (I have a Kyocera printer, remember?), nor does it even sort this list. OK, I painfully scroll through the list, hunting for the Kyocera driver and selecting it. Now I 'activate' the driver. Activating obviously means installing - so why don't name this button 'Install driver'?

Installing takes full 2 minutes (fast internet connection, 2,4 GHz Dual Core Desktop CPU, 6 GB RAM). (jockey-backend runs at 100 % CPU during the whole time, completly exhausting one of my two cores. What does it do, in gods name?)

(3) Next, I have to 'Close' the driver dialog. I don't want to close, I want to continue! Whatever.

Next, I get again (!) the choice to select a driver. Out of some 80 manufactures (my printer is still a Kyocera, remember?), out of hundreds of models. OK, I understand, previously I *installed* driver (though the dialog said I activated one), no I *select* one.

No Ubuntu beginner will ever understand what he/she had done now and why it was so complicated. Installing the same printer on Mac OS X (which also uses CUPS!) is done within 30 seconds and with a few mouse clicks.

PS: Now comes the fun part. On another Lucid test installation (I am book author and have been writing books on Ubuntu since 5.04) I choose *not* to install any driver, completely dropping step (2) from above. And guess what: The printer configuration still works. (I thought it would, I never had to install any drivers to use my printer.)

To get back to this bug report:

- please sort the drivers in jockey
- please make the driver installation optional and clearly say so

What happened to Ubuntu's printer configuration? This is a huge step back!

Lars Volker (lv) wrote :

I second that. Plus I'd like to _chose_, whether I want jockey to step in my way or whether I'd just like to select the driver from the list of installed ones. For a brother-printer which works after installing one single .deb (MFC 7820N, brother-cups-wrapper-laser), jockey installed 34 packages, just to import some rpm-based driver. What a nonsense.

(it installed html2text po-debconf debhelper librpmio0 rpm-common librpm0 librpmbuild0 rpm2cpio rpm alien libsys-hostname-long-perl libmail-sendmail-perl libqt3-mt libqt4-network libqt4-assistant libqt4-xml libqt4-dbus libqt4-script libqt4-designer libqt4-svg libqt4-opengl libqt4-gui libqt4-sql libqt4-sql-sqlite m4 ncurses-term pax lsb-core lsb-graphics lsb-cxx lsb-desktop lsb-printing lsb openprinting-ppds-postscript-brother)

I really appreciate the possibility to have jockey care for the whole driver installation, but I also would like to skip the step (which I did by pressing "Close" in Jockey) altogether.

Regards, Lars

Till Kamppeter (till-kamppeter) wrote :

Tim, why do you let Jockey get called everytimein 1.2.x? Before. it got only called if no local driver with exact make/model match was found.

Changed in system-config-printer (Ubuntu):
importance: Undecided → High
status: New → Triaged
Tim Waugh (twaugh) wrote :

Not intentional, tried to re-jig it for the new system and keep the same semantics but I don't run a Ubuntu system to try that out on. This sort of thing is why I maintain a stable branch... :-)

Till Kamppeter (till-kamppeter) wrote :

I have created a patch now which lets s-c-p check for local driver matches at first, before trying to find a driver on the internet. Will be made available as an SRU for Lucid.

Changed in system-config-printer (Ubuntu):
milestone: none → lucid-updates
status: Triaged → In Progress
Till Kamppeter (till-kamppeter) wrote :

Fix is uploaded into the -proposed queue. Will be available for testing soon.

Changed in system-config-printer (Ubuntu):
status: In Progress → Fix Committed

Accepted system-config-printer into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Michael Kofler (michael-kofler) wrote :

thanks a lot for your work, but unfortunately I can't see any changes; still searches for drivers and asks me to activate a manufacture-supplied PPD driver (out of a long, unsorted list) before I can select the driver I actually want to use

I have updated Lucid with proposed and did use system-config-printer-gnome 1.2.0+20100408-0ubuntu5.1

Till Kamppeter (till-kamppeter) wrote :

The long unsorted list is a Jockey problem, I get only one entry in Jockey and this is the printer driver package from OpenPrinting. Adding task ...

It seems that for your printer no locally installed driver was found and so system-config-printer searches on the internet.

To make sure that system-config-printer does the correct printer model matching, please run the following commands in a terminal window and post the output here:

/usr/lib/cups/backend/usb
/usr/lib/cups/backend/snmp
/usr/lib/cups/backend/dnssd

Michael Kofler (michael-kofler) wrote :

/usr/lib/cups/backend/usb
DEBUG: list_devices_libusb
DEBUG: usb_find_busses=2
DEBUG: usb_find_devices=2

root@ubuntu1004-test3:~# /usr/lib/cups/backend/snmp
network socket://10.0.0.57 "FS-1800+" "FS-1800+" "" ""

root@ubuntu1004-test3:~# /usr/lib/cups/backend/dnssd
(gives no results after 5 minutes)

Bob LaFond (b-lafond) wrote :

These buggy printer problems should have bee found during development of 10.04. It's hard to understand why it was not given the good performance of 9.04. There are enough folks in the community with different printers. n You have our configs from previous problems to launch a request for testing before release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.2.0+20100408-0ubuntu5.1

---------------
system-config-printer (1.2.0+20100408-0ubuntu5.1) lucid-proposed; urgency=low

  * debian/patches/96_new-printer-setup-check-for-local-drivers-first.patch:
    Let system-config-printer always first look for locally installed drivers
    before searching driver on the internet (LP: #564633).
 -- Till Kamppeter <email address hidden> Mon, 26 Apr 2010 18:51:50 +0200

Changed in system-config-printer (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
Changed in system-config-printer (Ubuntu Lucid):
status: Fix Released → Fix Committed

Michael Kofler, for your particular printer I have a second patch to make its locally installed driver being found. Please run the following command to apply it:

sudo patch -p0 < add-missing-make-name-kyocera-mita.patch

Now the locally installed driver for your printer should get found and so no internet search for driver should be done. Please tell whether this works for you.

New SRU with the patch of the last comment uploaded. Will appear in -proposed soon.

Thanks a lot! I guess this is the first time I got a patch prepared personally for me :-)

It works much better now. jockey presents only the Kyocera driver, so no more problems with sorting ... good!

After I activate this driver, it is automatically selected, thus skipping the dialogs for driver selection, also good.

It still is not clear that the installation of the PPD from openprinting.org is an optional step and I could also use the PostScript driver of CUPS, which is already available on the system. One could argue if there is a manufacture driver, just use it, as it may provide additional features, so I guess this is OK.

Again, thanks for your help.

I hope you have installed the system-config-printer package from -proposed and after that applied the patch for your test.

Can you make sure that openprinting-ppds is installed and openprinting-ppds-postscript-kyocera is not installed:

sudo apt-get install openprinting-ppds
sudo dpkg -P openprinting-ppds-postscript-kyocera

To check, run the command

lpinfo -m | grep '1800+'

and post the result here. There should be several entries for your printer.

Then run system-config-printer again and try to set up a queue for your printer. Do you get a driver from the local machine now or do you still get offered the Kyocera driver package from OpenPrinting.

Martin Pitt (pitti) wrote :

Accepted system-config-printer into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

it was an installation without proposed enabled, sorry; I will retest later on another installation

tested again on a clean Lucid installation plus all proposed updates plus patch from above; works perfectly now, better than before (Karmic): detects printer and automatically chooses the right available driver

thanks again!

Michael, thank you for testing. The fixed package will soon get added to the official updates for Lucid.

tags: added: verification-done
removed: verification-needed
Jiri Popelka (jpopelka) wrote :

Patch from comment #14 was commited upstream.
Thanks

Lars Volker (lv) wrote :

This still doesn't seem so work on a fresh lucid install for printer

Brother MFC 7820 N

After installing brother-cups-wrapper-laser the printer shows up in lpinfo -m but system-config-printer doesn't detect it.

Shall I reopen this report or create a new bug?

Lars Volker, and anyone else who observes a driver search on the internet when a local driver is available, in your case the problem is not the prioritization of locally installed drivers against drivers available on the Internet, but a problem of the fuzzy matching of the make/model information reported by the printer and the information supplied in the PPD files or drivers. Please report a new bug and report the bug number here. For the new bug report run the following commands in a terminal window and post all output here:

lpinfo -i -v

If the printer is a network printer (Ethernet connector or WLAN) connect it via network and run

/usr/lib/cups/backend/snmp
sudo /usr/lib/cups/backend/dnssd

If the printer has a USB connector, connect it via USB and run

sudo /usr/lib/cups/backend/usb
sudo usb_printerid /dev/usb/lp0
sudo usb_printerid /dev/usb/lp0
lsusb
ls -l /dev/usb/lp* /dev/bus/usb/*/*

Run also

lpinfo -l -m > list

and then attach the file "list". Do not compress it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.2.0+20100408-0ubuntu5.2

---------------
system-config-printer (1.2.0+20100408-0ubuntu5.2) lucid-proposed; urgency=low

  * debian/patches/97_add-missing-make-name-kyocera-mita.patch:
    Let system-config-printer add the manufacturer name "Kyocera Mita"
    if a detected Kyocera (Mita) printer only reports the model name
    (LP: #564633).

system-config-printer (1.2.0+20100408-0ubuntu5.1) lucid-proposed; urgency=low

  * debian/patches/96_new-printer-setup-check-for-local-drivers-first.patch:
    Let system-config-printer always first look for locally installed drivers
    before searching driver on the internet (LP: #564633).
 -- Till Kamppeter <email address hidden> Mon, 3 May 2010 12:48:50 +0200

Changed in system-config-printer (Ubuntu Lucid):
status: Fix Committed → Fix Released
dino99 (9d9) wrote :

Jockey has been superseded by software-properties, which now handles
third-party driver configuration.

Changed in jockey (Ubuntu Lucid):
status: New → Invalid
Changed in jockey (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers