[Lucid Beta2] [Regression] A lot of strings are still in english or are not translatable

Bug #557199 reported by Sergio Zanchetta on 2010-04-07
62
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
system-config-printer (Ubuntu)
High
Unassigned
Nominated for Lucid by Hendrik Knackstedt

Bug Description

Binary package hint: system-config-printer

Lucid Beta2.

Open system-config-printer from System->Administration->Printing
Some of the string in the menu and in the application itself are still in english or some are untranslatable and not present in the .po file. (They were present in the karmic .po)

In the server menu:
_Connect...
_Settings
_New

New submenu:
_Printer (present in the .po but still in english)
_Class

In the help menu:
_Troubleshoot

In the Troubleshoot wizard:
To start this tool, select System->Administration->Printing from the main menu. (present in the .po but still in english)

When adding a new printer: (they are present in the .po but still in english)
<span weight="bold" size="larger">Select Device</span>
<b>Enter device URI</b>
Windows Printer via SAMBA
Network printer
<b>Location of the network printer</b>
<b>Location of the LPD network printer</b>
Port number:
Queue:
Verify...

and a lots more.

This is a regression from Karmic.

Sergio Zanchetta (primes2h) wrote :

system-config-printer version 1.1.17+20100217-0ubuntu12

Sergio Zanchetta (primes2h) wrote :

== Regression details ==
Discovered in version: Lucid Lynx Beta2
Last known good version: Karmic Koala 9.10

tags: added: regression-potential
Changed in system-config-printer (Ubuntu):
importance: Undecided → High
Sergio Zanchetta (primes2h) wrote :

This bug also affect documentation, which deadline will be on April 15th. (NonLanguagePack Translation Deadline)

description: updated
description: updated
summary: - [Lucid Beta2] [Regression] Some menu strings are not translatable
+ [Lucid Beta2] [Regression] A lot of strings are not translatable
summary: - [Lucid Beta2] [Regression] A lot of strings are not translatable
+ [Lucid Beta2] [Regression] A lot of strings are still in english or are
+ not translatable
description: updated
Till Kamppeter (till-kamppeter) wrote :

Tim, did anything happen to s-c-p 1.1.17? Lots of translations are missing, looks like the .pot file is incomplete or translatable markings got lost in the source. Do you have some quick way to solve this?

Martin Pitt (pitti) wrote :

The menu entries aren't marked as translatable in the .glade.

Changed in system-config-printer (Ubuntu):
status: New → Triaged
Till Kamppeter (till-kamppeter) wrote :

Tim, it looks like that there are many 'translatable="yes"' marks dropped in the .glade files. Do you have a patch to fix that? Thanks.

Alberto Russo (valix) wrote :

I confirm this problem in Lucid upgraded today.

Changed in system-config-printer (Ubuntu):
status: Triaged → Confirmed
Sergio Zanchetta (primes2h) wrote :

There are also a lot of strings present in .pot file, translated long time ago (in old releases) but not used.
Some of them are mentioned in the bug description.

Tim Waugh (twaugh) wrote :

Are you looking at the right branch? I can see that something funny went on in the master branch, but not in 1.1.x. Here's

[twaugh@worm system-config-printer (1.1.17)]$ grep '"_[[:upper:]]' po/system-config-printer.pot | sort
msgid "_Add to Group"
msgid "_Advanced..."
msgid "_Authenticate"
msgid "_Class"
msgid "_Clear my personal default setting"
msgid "_Configure Printers"
msgid "_Connect..."
msgid "_Create class"
msgid "_Diagnose"
msgid "_Discovered Printers"
msgid "_File"
msgid "_Filter:"
msgid "_Group"
msgid "_Groups"
msgid "_Help"
msgid "_Hide"
msgid "_Hold"
msgid "_Install"
msgid "_Job"
msgid "_New"
msgid "_New Group"
msgid "_New Group from Selection"
msgid "_Printer"
msgid "_Publish shared printers connected to this system"
msgid "_Refresh"
msgid "_Release"
msgid "_Rename"
msgid "_Search"
msgid "_Server"
msgid "_Set Default"
msgid "_Settings..."
msgid "_Shared"
msgid "_Show printers shared by other systems"
msgid "_Troubleshoot"
msgid "_Use System Default"
msgid "_Verify..."
msgid "_View"

Hmm, po/system-config-printer.pot doesn't seem to be shipped in the tarballs, but here's e.g. en_GB.po:

[twaugh@worm system-config-printer-1.1.17]$ grep 'msgid "_[[:upper:]]' po/en_GB.po | sort
msgid "_Add to Group"
msgid "_Advanced..."
msgid "_Authenticate"
msgid "_Class"
msgid "_Clear my personal default setting"
msgid "_Configure Printers"
msgid "_Connect..."
msgid "_Create class"
msgid "_Diagnose"
#~ msgid "_Disable"
msgid "_Discovered Printers"
#~ msgid "_Do not apply"
#~ msgid "_Edit"
#~ msgid "_Enabled"
msgid "_File"
msgid "_Filter:"
msgid "_Group"
msgid "_Groups"
msgid "_Help"
msgid "_Hide"
msgid "_Hold"
msgid "_Install"
msgid "_Job"
msgid "_New"
msgid "_New Group"
msgid "_New Group from Selection"
msgid "_Printer"
msgid "_Publish shared printers connected to this system"
msgid "_Refresh"
msgid "_Release"
msgid "_Rename"
msgid "_Search"
msgid "_Server"
#~ msgid "_Server Settings..."
msgid "_Set Default"
msgid "_Settings..."
msgid "_Shared"
msgid "_Show printers shared by other systems"
msgid "_Troubleshoot"
msgid "_Use System Default"
msgid "_Verify..."
msgid "_View"

Sergio Zanchetta (primes2h) wrote :

I just compared the two .po files (Lucid and Karmic) in launchpad.
https://translations.edge.launchpad.net/ubuntu/lucid/+source/system-config-printer/
https://translations.edge.launchpad.net/ubuntu/karmic/+source/system-config-printer/

In the Lucid one
1) some string are missing (they were in Karmic)
2) some string are translated (as they were in Karmic too) but are shown in english.

Changed in ubuntu-translations:
importance: Undecided → High

Tim, I am using the 1.1.x branch. The version currently in use is 1.1.17, git snapshot from Feb 17 2010 (taken shortly before Lucid's Feature Freeze).

Tim, it seems that there are two problems:

1. Strings in glade are not marked with 'translatable="yes"'. These leads to case that the Ubuntu langpacks (the .po files) do not contain translations for these strings

2. Strings are translated in the .po files of the langpacks but the software displays them in English, like the strings of the troubleshooting wizard.

(1) can be fixed by adding the missing 'translatable="yes"' to the .glade files. Then our automatic langpack builder will include tyhe missing strings. About what causes (2) I have no idea.

Forgot to say about (2) that for (2) tthe strings are defined in the .py files, and they are correctly wrapped with '_("...")'.

Tim Waugh (twaugh) wrote :

Till, I don't know what to say. The glade files *do* have the translatable attribute in the 1.1.x branch -- if you can point me to a particular git tree which doesn't, I'll fix it. All the ones I'm looking at do.

The master branch *was* missing translatable attributes in the GtkBuilder files, and Jiri Popelka has fixed that today. But of course, you aren't shipping master, so...

As I demonstrated in comment #9, the 1.1.x branch has the strings both in the po template file and in the po files. I can tell you that on Fedora 12 with system-config-printer-1.1.18, "LC_ALL=fr_FR.UTF-8 system-config-printer" has the entire interface (including the troubleshooter) in French.

I have prepared a patch to fix (1) now. So after uploading the next system-config-printer package after the Beta-2 freeze the langpacks should get regenerated correctly.

Changed in system-config-printer (Ubuntu):
status: Confirmed → In Progress

Tim, I have checked again and I must have taken the master branch accidentally. What I am selling to Ubuntu users as version 1.1.17 plus a bit of GIT is in reality 1.1.91 plus a bit of GIT. Now I can explain why it had so many bugs. I am using a developemt version instead of a stable branch.

Tim, as I have a rather instable release (1.1.91) in Ubuntu now, I have two possibilities: Go to 1.1.18, the last stable 1.1.x release or advance to 1.2.0 or HEAD to catch all your fixes on 1.1.91. What is the least intrusive solution? If 1.1.91 --> 1.2.0 (or HEAD) is mainly bug fixes I would prefer this. If this transition is very risky, one could perhaps ship 1.1.18. WDYT?

Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package system-config-printer - 1.2.0+20100408-0ubuntu1

---------------
system-config-printer (1.2.0+20100408-0ubuntu1) lucid; urgency=low

  [ Till Kamppeter ]
  * New upstream release
     o GIT master snapshot from 08 April 2010
     o For the last update from upstream we accidentally downloaded the
       master branch from GIT and not 1.1.x, so that upstream version from
       Lucid Feature Freeze is 1.1.91 in reality and not 1.1.17 as advertized.
       To fix the bugs of 1.1.91 (an unstable test release) we go now forward
       to 1.2.0 + bug fixes + translation updates.
     o No feature additions expected.
     o This release fixes especially LP: #557199 and LP: #552398
     o Possibly more bugs fixed.
     o Translations updated.
  * debian/patches/53_fix-async-ipp-traceback.patch,
    debian/patches/70_more-async-traceback-fixes.patch,
    debian/patches/73_finally-fixed-race-condition-in-asyncipp.patch: Removed
    patches for upstream fixes.
  * debian/patches/10_menu_entries.patch,
    debian/patches/55_silence_printerdriversinstaller_errors.patch:
    Regenerated to work with new upstream code.
  * debian/system-config-printer-common.install: Added new check-device-ids.py
    file (debug tool, not used by the rest of system-config-printer).
  * debian/system-config-printer-gnome.install: Added man pages.
  * debian/local/testpage-a4.ps, debian/local/testpage-letter.ps: Replaced
    Ubuntu logo by the current one (LP: #542975).
  * debian/patches/84_cache-also-device-id-in-network-printer-search.patch:
    When doing a network printer search on a given IP, cache not only the
    make-and-model string but also the device ID for subsequent connection
    types.
  * debian/patches/86_fill-lpd-queue-list.patch: When probing an IP address
    whether it is an LPD printer and which the valid queue names are, the
    list of valid queue names did not get filled.
  * debian/patches/88_physicaldevice-get-make-model-also-from-makeandmodel.patch:
    Let make and model for a network device also be determined by the
    make-and-model string and not only the device ID (which is often missing
    for detected network printers).
  * debian/patches/90_physicaldevice-clean-socket-uris.patch: When several
    detected network printers are identified as one physical device, remove
    the default port 9100 from socket URIs, to avoid saving entries with
    duplicate URIs.
  * debian/patches/92_do-not-search-driver-for-remote-cups-queues-with-driver.patch:
    If a queue to be set up with "ipp://..." URI points to a remote CUPS queue
    which has already a PPD on the server, we do not need to (and should not)
    search for a PPD/driver to set up locally. Now really recognize such queues
    and suppress driver configuration.
  * debian/patches/57_backend-integration-dnssd-bluetooth.patch: Let Bluetooth
    printers get searched together with network printers, as the search takes
    longer. So USB and parallel printers and also network printer search
    methods appear nearly instantly. In the listing of network printers let
    not only IP addresses but also DNS-SD names appear.

  [ Julien Lavergne ]
  * debian/pat...

Read more...

Changed in system-config-printer (Ubuntu):
status: In Progress → Fix Released
David Planella (dpm) on 2010-04-12
Changed in ubuntu-translations:
status: New → Fix Released
Gabor Kelemen (kelemeng) wrote :

Reopening.
About half of the originally reported strings are now translated, but the New printer dialog still suffers, altough the strings are in the mo file. I suspect some bindtextdomain calls are missing, I'll try to investigate.

Changed in system-config-printer (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntu-translations:
status: Fix Released → Confirmed
Gabor Kelemen (kelemeng) wrote :

Um, which branch should I clone? This was touched too long ago:
https://code.launchpad.net/~ubuntu-branches/ubuntu/lucid/system-config-printer/lucid

Gabor Kelemen (kelemeng) wrote :

Okay, I found it.
It turned out, that the getWidgets method is used to create widgets from glade files. For this method, you have to specify explicitly the translation domain to see the widgets translated. There are two calls for this method, one of these lacked the domain specification. Attached patch fixes this.

There are still some untranslated strings, but I guess it's too late for them (like marking strings for translation in pysmb.py, between lines 95-115).

Changed in ubuntu-translations:
status: Confirmed → Triaged

Great job, Gabor!

Tim Waugh (twaugh) wrote :

Thanks Gabor, fixed upstream now.

Gabor Kelemen (kelemeng) wrote :

#23: this is (aside from the same as #19 :)) because the variable is exported as public in base.py. Looks like that _() does not run for varibles like this, so an explicit call is needed in the files which use it - this fixed it for me.

Gabor Kelemen (kelemeng) wrote :

If I'm at it, here is a patch for the missing strings of the Samba auth dialog I mentioned previously.

Gabor Kelemen (kelemeng) wrote :

There is also a little problem with the devices list when adding a new printer. In theory, these strings are translated, but in fact, they are not. I can't find the problem, so just leaving this picture here for further investigation :).

Tim Waugh (twaugh) wrote :

Gabor: thanks, added those two patches too.

The remaining strings listed in comment #26 come from various CUPS backends.

Gabor Kelemen (kelemeng) wrote :

Tim: I mean that these are already marked for translation here:

http://bazaar.launchpad.net/%7Evcs-imports/system-config-printer/master/annotate/head%3A/newprinter.py#L2151

and they are translated, for example the last one:

https://translations.launchpad.net/ubuntu/lucid/+source/system-config-printer/+pots/system-config-printer/hu/+translate?batch=10&show=all&search=Samba

so they *could* in theory show up translated (as users, we would expect this behavior, should they come from a backend or not).

Tim Waugh (twaugh) wrote :

Ah, yes, good idea. I've added that now in the git repository on all branches.

Changed in system-config-printer (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.2.3+20100713-0ubuntu1

---------------
system-config-printer (1.2.3+20100713-0ubuntu1) maverick; urgency=low

  * New upstream release
     o GIT 1.2.x snapshot from 13 July 2010
     o Version 1.2.3 plus some additional fixes and translations
     o Plug'n'Print also for Bluetooth printers now.
     o Do not automatically set up a print queue if a driver executable is
       missing.
     o Improvements on device ID handling: Discovery via SNMP, non-UTF-8
       environments, ignore the deprecated hal backend.
     o Avoid Yes/No buttons (Upstream bug #204).
     o Re-introduced and added keyboard accelerators for system-config-printer
       itself and for the job viewer.
     o New HIG-compliant job viewer UI. Thanks to Sergey Nizovtsev for the
       patch (LP: #555213, upstream bug #205).
     o Attempt to translate backend device-info strings and other fixes
       on the translation mechanism (LP: #557199).
     o Fixed markup in error pop-ups (LP: #567324).
     o Made width of "Verify" button in New Printer Wizard adapt to the length
       of the actual translation of "Verify" (LP: #575048).
     o Make Kyocera detected if it reports only the model name (Upstreamized
       LP: #564633).
     o Removed doubled-up 'translatable' attribute in UI file (LP: #571662).
     o Handle IPP failure fetching printer attrs for completed jobs
       (LP: #561082).
     o Many more bug fixes and UI improvements.
     o Translation updates.
  * debian/patches/57_backend-integration-dnssd-bluetooth.patch,
    debian/patches/67_udev_configure_printer_match_usblp_libusb_and_hplip_uris.patch,
    debian/patches/75_use-dnssd-uris-for-hplip.patch,
    debian/patches/94_cache-and-timeout-for-avahi-browse.patch
    debian/patches/96_new-printer-setup-check-for-local-drivers-first.patch:
    Regenerated to work with new upstream code.
  * debian/patches/97_add-missing-make-name-kyocera-mita.patch: Removed
    patches for upstream fixes.
  * debian/patches/57_backend-integration-dnssd-bluetooth.patch: To check for
    HP fax devices do not do an exact match of "Fax" with the model name but
    check whether the model name begins with "Fax".
  * debian/patches/44_no-runtime-error-on-missing-firewall.patch: Let the
    firewall functions exit silently if there is no firewall service on the
    D-Bus.
  * debian/patches/50_give-priority-to-hpcups.patch: Prioritize hpcups against
    HPIJS again. It should have matured enough now.
  * debian/system-config-printer-common.install: Added new dnssdresolve.py
    file.
  * debian/rules: Added directory settings for UDEV rules and scripts to the
    "make install" command line.
  * debian/control: Added libglib2.0-dev as build dependency, needed for the
    Bluetooth Plug'n'Print support.
 -- Till Kamppeter <email address hidden> Tue, 13 Jul 2010 13:21:33 +0200

Changed in system-config-printer (Ubuntu):
status: In Progress → Fix Released
David Planella (dpm) on 2010-08-02
Changed in ubuntu-translations:
status: Triaged → Fix Released
Gabor Kelemen (kelemeng) wrote :

David: this is not "Fix Released" in Lucid, only in upstream. Shouldn't this be backported? There is a really simple solution, and it STILL looks really ugly...

In Maverick this is fixed.

El dl 02 de 08 de 2010 a les 17:24 +0000, en/na Gabor Kelemen va
escriure:
> David: this is not "Fix Released" in Lucid, only in upstream. Shouldn't
> this be backported? There is a really simple solution, and it STILL
> looks really ugly...
>

Sorry for the confusion. I marked it as Fix Released after checking it
had been fixed in Maverick. To track the status in Lucid, and if someone
would like to work on requesting an SRU, the "Nominate for release" link
can be used as per [1].

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers