Ubuntu

Notification popup should display filename in header and job number in details rather than the other way around

Reported by Carey Underwood on 2009-07-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Karmic
Undecided
Unassigned
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

Currently, the notification bubble that displays when a print job completes is approximately the following:

**Job 163 has completed printing**
File "my recognizable filename"...
Date/time, etc

However, the print job number is only useful in some rare cases, whereas the filename that shows up is generally recognizable to the user ("Proposal.odt", for instance).

The name of the print job is far more useful to the user than the job number, and so it should be displayed in the most prominent location if any such information is to be included there:

**"my recognizable filename" has completed printing**
Print job 163
Date/time, etc

Florian Diesch (diesch) on 2009-07-24
Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Florian Diesch (diesch) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.
In addition this seems to be worth to submitted to the "One Hundred Paper Cuts" so I'm doing this.

Thanks for taking the time to make Ubuntu better!

Vish (vish) wrote :

This should be a fairly simple fix and can be squeezed into Karmic cycle.

Changed in hundredpapercuts:
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Tim, is this really simple to do?

Tim Waugh (twaugh) wrote :

Didn't I already fix this in commit 2864f60?

Till Kamppeter (till-kamppeter) wrote :

Tim, you have removed the job number drom the notification, but the commit 2864f60 document name was always there. Or did you introduce it in another commit after Jaunty.

As I have packaged and uploaded system-config-printer in the last days, the problem should be fixed in Karmic.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in system-config-printer (Ubuntu):
status: Confirmed → Fix Released

The job number is still useful though. I was suggesting that it
should merely be exchanged in prominence with the job title.

On Mon, Jul 27, 2009 at 9:50 AM, Till Kamppeter<email address hidden> wrote:
> Tim, you have removed the job number drom the notification, but the
> commit 2864f60 document name was always there. Or did you introduce it
> in another commit after Jaunty.
>
> As I have packaged and uploaded system-config-printer in the last days,
> the problem should be fixed in Karmic.
>
> ** Changed in: hundredpapercuts
>       Status: Confirmed => Fix Released
>
> ** Changed in: system-config-printer (Ubuntu)
>       Status: Confirmed => Fix Released
>
> --
> Notification popup should display filename in header and job number in details rather than the other way around
> https://bugs.launchpad.net/bugs/404330
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Tim Waugh (twaugh) wrote :

Unfortunately these notifications might have to be removed anyway:
  https://fedorahosted.org/system-config-printer/ticket/181

Changed in hundredpapercuts:
milestone: none → round-7
Milan Bouchet-Valat (nalimilan) wrote :

Losing the notifications is really sad... Why isn't detecting network printers enough?

Tim Waugh (twaugh) wrote :

The wording says the job has completed but we can't reliably know that. I've had a suggestion to just change it to '... has been sent to ... for printing.'

Tim Waugh <email address hidden> writes:

> The wording says the job has completed but we can't reliably know that.
> I've had a suggestion to just change it to '... has been sent to ... for
> printing.'

IMHO that's what you want for most home and small office users. For
environments where jobs get send to big print servers one may wish to
switch of the notifications. Is it documented somewhere how one can do that?

   Florian
--
<http://www.florian-diesch.de/software/pdfrecycle/>

Dirk Schedler (schedler-sscs) wrote :

I agree to post #8. Get no notification about your print jobs is also confusing as you don´t know if your print job even is on the way to the printer.
I would suggest to change the text for those printer where it is not possible to track if the print job is completed to: ..."print job" or "Document Name" has been send out...

and for the printer where it is possible to track keep the:
"..."print job" or "Document Name" has beend finished printing...

Removing all notifications about your print jobs is a step backwards.
Think about that even Windows notifies the User about print jobs.
Why should a Linux user get no message ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.