"New" printer button is not appropriate and it doesn't respect gender in Italian language.

Bug #394071 reported by Andreas Nilsson on 2009-06-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
System Config Printer
Confirmed
Unknown
Ubuntu Translations
Undecided
Unassigned
system-config-printer (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: system-config-printer

The icon for adding a new printer looks like the "create a new document" icon (gtk-file). This kind of gives a false illusion that new documents can be created here, or if this was Star Trek [1]; new printers (wouldn't that be cool? ;) )
My suggestion would be to use gtk-add instead here.

1. http://en.wikipedia.org/wiki/Replicator_(Star_Trek)

Sergio Zanchetta (primes2h) wrote :

I confirm it.
Moreover this bug even have an impact on Italian translation.

The currently used icon is gtk-new that is translated as "Nuovo", which is masculine genre, because it refers to "document", "file" etc. but "Printer" and "Class" are feminine genre, so it's wrong.
Using gtk-add we can fix it because it's a verb and it could better describe the "action" of adding a new printer or class.

I'm preparing a patch about this.

Changed in system-config-printer (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
summary: - new printer button looks like "create a new document"
+ "New" printer button is not appropriate and it doesn't respect genre.
tags: added: patch
summary: - "New" printer button is not appropriate and it doesn't respect genre.
+ "New" printer button is not appropriate and it doesn't respect genre in
+ Italian language.
Changed in system-config-printer (Ubuntu):
status: Confirmed → Triaged
Colin Watson (cjwatson) on 2010-02-09
summary: - "New" printer button is not appropriate and it doesn't respect genre in
+ "New" printer button is not appropriate and it doesn't respect gender in
Italian language.
Sergio Zanchetta (primes2h) wrote :

Ops...
s/genre/gender everywhere, sorry about that.

Changed in system-config-printer (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.1.16+git20100209-0ubuntu1

---------------
system-config-printer (1.1.16+git20100209-0ubuntu1) lucid; urgency=low

  * New upstream release
     o GIT 1.1.x snapshot from 09 February 2010
     o my-default-printer utility removed
     o Improved multi-threading
     o Removed loading of the proprietary plug-in for HPLIP
     o Tons of bug fixes
  * debian/patches/53_fix-model-list-sorting.patch,
    debian/patches/55_turboprint-with-cups-1.4.patch,
    debian/patches/60_conserve-device-id-for-search-and-queue-name.patch,
    debian/patches/63_use-make-model-when-device-id-missing.patch,
    debian/patches/65_separate-suffix-number-in-printer-name-with-dash.patch,
    debian/patches/70_dont-assume-stdout.patch,
    debian/patches/73_dont-display-properties-dialog-for-first-test-page.patch:
    Removed, applied upstream.
  * debian/patches/10_menu_entries.patch,
    debian/patches/57_backend-integration-dnssd-bluetooth.patch: Regenerated.
  * debian/patches/77_dont-crash-on-dns-sd-broadcasted-mac-os-x-queues-with-utf8-chatracters.patch:
    Merged into 57_backend-integration-dnssd-bluetooth.patch, as it patches
    only code added by this patch.
  * debian/patches/25_enable-hplip-plugin-support,
    debian/patches/35_udev-add-printer-support-hplip-plugin.patch:
    system-config-printer has dropped support for the proprietary driver
    plugins of HPLIP. To get an upstream-supported solution we remove these
    patches and move the functionality into the HPLIP package.
  * debian/patches/50_give-priority-to-hpcups.patch: Now the new hpcups driver
    of HPLIP is mature enough for daily use, give priority to it.
  * debian/patches/53_change-new-with-add-icon.patch: Change 'gtk-new' with
    'gtk-add' in MenuToolButton (LP: #394071). Thanks to Sergio Zanchetta
    (primes2h at ubuntu dot com) for the patch.
  * debian/system-config-printer-common.install,
    debian/system-config-printer-gnome.install,
    debian/system-config-printer-udev.install: Updated file lists to match
    the actual files of the current version.
 -- Till Kampeter <email address hidden> Tue, 09 Feb 2010 13:08:43 +0100

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
Changed in system-config-printer:
status: Unknown → Confirmed
Victor Vargas (kamus) wrote :

Since this package is not translated under LP and is not under main repositories I will mark Ubuntu Translations package as invalid. Thanks

Changed in ubuntu-translations:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.