Print errors are presented as alerts with redundant buttons

Bug #343904 reported by Till Kamppeter on 2009-03-16
4
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
High
Ken VanDine

Bug Description

Remove the paper from a local printer and print a job on it. You get a window in the middle of the screen telling "Printer XXX out of paper". It has an OK and a Cancel button. I do not see any difference for OK and Cancel. Independent what I click the window is closed and the job stays in the queue (or gets printed when I refill paper). So I expect only an OK (or a Close) button here.

Instead, the message should be converted to an alert box containing only an "OK" button. <https://wiki.ubuntu.com/NotifyOSD#system-config-printer>

Till Kamppeter (till-kamppeter) wrote :

Note that the notification clients (in the examples the system-config-printer applet and the Network Manager) send a command to the notification server (which is notify-osd in our case) to create a notification bubble with either action buttons (our Network Manager example, action button is "Do not show such notifications again") or with infinite timeout (our system-config-printer example, the out-of-paper notification was expected to be permanent, until the user clicks it to close). This is not supported by notify-osd, as clicks on the notification are required and those are not supported in notify-osd. So notify-osd falls back to alert windows.

Changed in notify-osd (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-9.04-beta
Matthew Paul Thomas (mpt) wrote :

Since you mention both system-config-printer and network-manager, I'm assuming this bug report is about the fallback alerts in general. Fixing the individual system-config-printer alert should be reported separately.

The reason fallback alerts have both "Cancel" and "OK" is that "Cancel" is equivalent to clicking the close button in a bubble, while "OK" is equivalent to clicking anywhere else in the bubble (the "default" action). Often these do the same thing (i.e. nothing), but sometimes they do different things. As I understand it, the protocol makes it impossible for Notify OSD to tell whether those callbacks do the same thing, so it has to provide buttons for both, just in case. If I'm wrong and Notify OSD could tell whether they are the same (David? Mirco?), that would be great -- the fallback alert could have just "OK" in that case.

Ken - I believe this bug is by design for notify-osd. However, before we close it, could you please confirm that the printer is behaving properly wrt notify-osd?

Changed in notify-osd (Ubuntu):
assignee: nobody → ken-vandine
Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

Unfortunately, notification-daemon returns a "default" action when the bubble is clicked, regardless of whether the application has registered it, and I'm told that some applications rely on this behavior. This means that Notify OSD's fallback alerts have to provide a way of triggering the "default" action, as well as a way of closing the alert without action. That is, they need to provide both an "OK" button and a "Cancel" button, even though these buttons will often do the same thing. I've updated the spec to mention this. <https://wiki.ubuntu.com/NotifyOSD?action=diff&rev2=119&rev1=118>

system.config.printer is using notify-osd properly, should not see the fallback dialogs.

Changed in system-config-printer (Ubuntu):
status: Incomplete → Invalid
Till Kamppeter (till-kamppeter) wrote :

I still get fallback dialogs. I got a "Printer may be not connected" message today which has both an OK and a Cancel button. On a completely up-to-date Jaunty.

Changed in system-config-printer (Ubuntu):
status: Invalid → New
description: updated
summary: - If bubble is replaced by alert window (infinite timeout, actions),
- window has unneeded OK/Cancel
+ Print errors are presented as alerts with redundant buttons
Ken VanDine (ken-vandine) wrote :

I will look at that one, perhaps one of the notifications were missed.

Ken VanDine (ken-vandine) wrote :

I can not reproduce this. I removed the paper and printed, I get a notification bubble that says I am out of paper and an error icon in the applet. No alert box. I have also reviewed the code, we seem to be handling all cases for notifications.

Changed in system-config-printer (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers