Clicking the "Additional Printer Settings…" button launches system-config-printer multiple times

Bug #1755514 reported by AsciiWolf on 2018-03-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Ken VanDine
Bionic
Medium
Ken VanDine
system-config-printer (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Clicking the "Additional Printer Settings…" button in GNOME Control Center launches multiple instances of system-config-printer instead of one instance in Ubuntu 18.04.

AsciiWolf (asciiwolf) wrote :

It looks like it's 7 instances every time.

Jeremy Bicha (jbicha) on 2018-03-23
tags: added: rls-bb-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

that's not important enough to be a milestoned -> rls-bb-notfixing

still worth looking at/fixing though, Till can you have a look?

tags: added: rls-bb-notfixing
removed: rls-bb-incoming
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Till Kamppeter (till-kamppeter)
importance: Undecided → Low
Iain Lane (laney) wrote :

sorry we changed our minds, this should be worked on please

tags: removed: rls-bb-notfixing
Changed in gnome-control-center (Ubuntu Bionic):
status: Confirmed → Triaged
importance: Low → Medium
Till Kamppeter (till-kamppeter) wrote :

For me it looks like a bug in gnome-control-center.

When clicking the button, it should be checked whether there is already a system-config-printer process running. If so, the window of it should be pulled to the front, if not, s-c-p should get started.

In addition, it must be made sure that the button action happens only once when one clicks the button once, and not repeatedly as long as the button is held down. The reports of some users that they get 7 instances of s-c-p with a single click on the button looks like that in the few milliseconds while they have the left mouse button down the action of starting s-c-p is repeated in quick frequence.

So these issues need to get fixed in g-c-c.

Changed in gnome-control-center (Ubuntu):
assignee: Till Kamppeter (till-kamppeter) → nobody
Changed in gnome-control-center (Ubuntu Bionic):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in system-config-printer (Ubuntu):
status: Confirmed → Invalid
Jeremy Bicha (jbicha) wrote :

Till, is there any good reason a user would need to have multiple system-config-printer windows open. If not, I think you should leave the system-config-printer task open because the app should be converted to single-instance.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.0-0ubuntu4

---------------
gnome-control-center (1:3.28.0-0ubuntu4) bionic; urgency=medium

  * debian/patches/ubuntu-printer-support.patch
    - Connect to the system-config-printer-button{1,2} clicked signals
      during init rather than in update_sensitivity. This prevents us
      from connecting to the signal multiple times. (LP: #1755514)

 -- Ken VanDine <email address hidden> Tue, 27 Mar 2018 14:59:55 -0400

Changed in gnome-control-center (Ubuntu Bionic):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2018-03-28
Changed in gnome-control-center (Ubuntu Bionic):
status: Fix Released → Triaged
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers