system-config-printer won't accept password

Bug #152504 reported by Jonathan Musther on 2007-10-14
12
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Medium
Pascal De Vuyst

Bug Description

Binary package hint: system-config-printer

When I make changes to a printer through system-config-printer as an admin user, I am asked for my password when I try to apply the changes. When I enter my password, I'm quickly prompted again as if the password was incorrect, and have to eventually hit cancel.

I suspect the problem is because I have a very secure password which is 16 characters and includes symbols, I believe that the problem is probably with one or more of the symbols. My password includes some of the following (don't know which are causing the problem):

!@#$%^&*(),.'";:

It also contains numbers and upper and lower case letters.

One fix would simply be to call system-config-printer via gksu which neatly bypasses this problem (although of course requiring root password to even view).

system-config-printer version 0.7.75+svn1653-0ubuntu2

Martin (martin10) wrote :

I can confirm this bug on my machine.

However, my password (for that user) contains only lowercase letters, so it must be caused by something else.

Thank you for the tip , gksudo /usr/bin/system-config-printer really works.

Martin (martin10) wrote :

by the way, I have got the same version as you

Martin (martin10) wrote :

by the way, I have the same version as you

I can confirm that this problem happens whatever the password is. I really can't believe we're the only two people having this problem, it seems to happen on Gutsy on any machine.

Reg (regoake) wrote :

Not just two people. I have just attempted to add a networked Brother HL-2070N. I first attempted this with a secure password (similar to the one described in the original post) and was repeatedly prompted for my password until I got a message indicating that my password might be incorrect (very odd -- might be incorrect). I switched to a simpler password and had the same issue.

The command "gksudo /usr/bin/system-config-printer" worked for me as well.

I've tested on a number of machines, and virtual machines, same problem every time. It's amazing to me that this hasn't been reported more.

Till Kamppeter (till-kamppeter) wrote :

When and why do you get asked for a password?

Did you use the "Goto Server" which opens a dialog asking for a remote server and login? Then login and password (will be asked for in a later step) must be either of "root" on the server or of a user who is in the "lpadmin" group on the server.

If you set up a local print queue (you did not use "Goto Server") and you are a user in the "lpadmin" group, you will never get asked for a password, also not for the "Server Settings". Can you check whether you are actually in the "lpadmin" group in /etc/group (and add yourself if needed)? Do you get asked for only the password or for login and password? In the latter case enter the login and password of a user in the "lpadmin" group. If you are asked only for the password, you must start system-config-printer as a user in the "lpadmin" group.

Changed in system-config-printer:
importance: Undecided → Medium
status: New → Incomplete

I'm away from home for about a month now, the laptop doesn't have any printers set up on it so I can't test anything. If I can get hold of a printer I'll try it though. From what I recall I was asked for a password every time I tried to change any global settings, changing printer drivers, default media, access times etc.

Simon Pascal Klein (klepas) wrote :

I can confirm this bug to. It looks like since the app is launched by a regular user, when they try to perform a system-wide action that normally requires root user access the password dialog prompts for the user password for localhost, which even if the user has administrative permissions nothing will work and the user is forced to cancel.

The only way I managed to get my printers configured is by rummaging through alacarte (the menu editor) to find the command this gui app uses (system-config-printer) and then run it from the command line with gksu. This should not be happening!

Simon Pascal Klein (klepas) wrote :

For referencing, this password dialog appeared at the end of the 'adding a printer' process, after confirming the model and driver and descriptive details.

cbudden (chrisbudden) wrote :

I have recently upgraded to hardy, using system-config-printer 0.7.81+svn1976 and I can confirm, when I get asked for a password it does not get accepted. Using gksudo works.

Tom Harris (tom-harris) wrote :

I have the same problem in gutsy. I tried to make a printer the default printer, and get asked for my password which doesn't get accepted. Can't we just fix this by changing the launcher to gksudo system-config-printer?

Zach (uid000) wrote :

I have been having this problem as well. I just checked my groups and for some reason I was not part of the lpadmin group. Once I added myself to that group I can add printers with no problem (and no password required either).

Andrew Keyes (akeyes) wrote :

Noting the above comment by Zach, this should be told to the user instead of continually asking for their password.

Jonathan Musther,
Did you still have this problem after adding your username to the lpadmin group?
If yes please provide the output of the following command:
$ id
Are you the primary (first) user on your system or did you create an extra account with gnome users-admin?

Changed in system-config-printer:
assignee: nobody → pascal-devuyst
Jordan Erickson (lns) wrote :

I can confirm this behavior in Hardy 8.04.1, on 9 different servers that I administrate.

I can confirm the workaround of adding the user to the "lpadmin" group to bypass the prompt for a password and add a printer, whereas before it would continually ask for a password, even when entering it correctly.

This issue probably affects anyone trying to add a printer that isn't part of the "lpadmin" group. Yikes.

Patrick Welche (pwelche) wrote :

I am in the (ldap) group lp_admin (not lpadmin, as that group is defined locally, and its numerical value can differ from computer to computer), and the computer's /etc/cups/cupsd.conf file has

SytemGroup lp_admin

Yet, I too have this infinite what is your password @localhost loop. (8.04.2)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions