Ubuntu

Wrong driver selected for my Canon iP3000

Reported by Patrice Vetsel on 2007-10-05
4
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Medium
Till Kamppeter

Bug Description

Binary package hint: hal-cups-utils

s-c-p -> 0.7.75+svn1653-0ubuntu1
hal-cups-utils -> 0.6.13+svn83-0ubuntu1

Plugin and power on my Canon iP3000, hal-cups-utils add it with a wrong driver : "Generic text-only printer"
The right driver exist for this printer in cups printers list.

+=============+

kagou@agape:~$ lpinfo -m | grep -i ip3000
gutenprint.5.0://bjc-PIXMA-iP3000/expert/C Canon PIXMA iP3000 - CUPS+Gutenprint v5.0.1
gutenprint.5.0://bjc-PIXMA-iP3000/simple/C Canon PIXMA iP3000 - CUPS+Gutenprint v5.0.1 Simplified
kagou@agape:~$

+=============+

kagou@agape:~$ /usr/sbin/lpinfo -l -v
Matériel : URI = socket
          classe = network
            info = AppSocket/HP JetDirect
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = beh
          classe = network
            info = Backend Error Handler
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = hal:///org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial_printer_noserial
          classe = direct
            info = Canon iP3000
   marque/modèle = Canon iP3000
     ID matériel = MFG:Canon;MDL:iP3000;CLS:PRINTER;
Matériel : URI = usb://Canon/iP3000
          classe = direct
            info = Canon iP3000 USB #1
   marque/modèle = Canon iP3000
     ID matériel = MFG:Canon;CMD:BJL,BJRaster3,BSCCe;SOJ:TXT01;MDL:iP3000;CLS:PRINTER;DES:Canon iP3000;VER:1.09;STA:10;FSI:03;
Matériel : URI = canon:/dev/lp0
          classe = direct
            info = Gutenprint Parallel Port #1
   marque/modèle = CANON
     ID matériel =
Matériel : URI = epson:/dev/lp0
          classe = direct
            info = Gutenprint Parallel Port #1
   marque/modèle = EPSON
     ID matériel =
Matériel : URI = canon:/dev/usb/lp0
          classe = direct
            info = Gutenprint USB Printer #1
   marque/modèle = Canon iP3000
     ID matériel =
Matériel : URI = hpfax
          classe = direct
            info = HP Fax (HPLIP)
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = hp
          classe = direct
            info = HP Printer (HPLIP)
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = http
          classe = network
            info = Internet Printing Protocol (http)
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = ipp
          classe = network
            info = Internet Printing Protocol (ipp)
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = lpd
          classe = network
            info = LPD/LPR Host or Printer
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = parallel:/dev/lp0
          classe = direct
            info = LPT #1
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = cups-pdf:/
          classe = file
            info = Print into PDF file
   marque/modèle = Generic PDF file generator
     ID matériel = MFG:Generic;MDL:PDF file generator;DES:Generic PDF file generator;CLS:PRINTER;CMD:POSTSCRIPT;
Matériel : URI = scsi
          classe = direct
            info = SCSI Printer
   marque/modèle = Unknown
     ID matériel =
Matériel : URI = smb
          classe = network
            info = Windows Printer via SAMBA
   marque/modèle = Unknown
     ID matériel =
kagou@agape:~$

Patrice Vetsel (vetsel-patrice) wrote :

kagou@agape:/usr/share/system-config-printer$ python -c 'import cups, ppds;ppds.debugging=True;c=cups.Connection();a=c.getPPDs();p=ppds.PPDs(a);print p.getPPDNameFromDeviceID("Canon","iP3000","Canon iP3000",uri="foo")'

description: updated
Patrice Vetsel (vetsel-patrice) wrote :

How works the algorithm for finding driver ?
Is it the same under hal-cups-utils and system-config-printer ?

Till Kamppeter (till-kamppeter) wrote :

The algorithms for manual installation with systemconfig-printer and automatic setup with hal-cups-utils are not 100% the same. Does it work correctly for you when using system-config-printer?

Tim Waugh (twaugh) wrote :

Regression since revision 1574.

Changed in hal-cups-utils:
assignee: nobody → till-kamppeter
importance: Undecided → Medium
status: New → In Progress
Till Kamppeter (till-kamppeter) wrote :

Fixed system-config-printer package for testing on (package on the way to Gutsy)

http://www.linux-foundation.org/~till/tmp/ubuntu/gutsy/system-config-printer/

Note that the auto printer setup of hal-cups-utils uses parts of system-config-printer, therefore the fix in system-config-printer.

Fixed also upstream (SVN rev 1660).

Tim, make sure every text matching for finding PPDs/drivers for given printers is case-insensitive.

Changed in system-config-printer:
status: In Progress → Fix Committed
Tim Waugh (twaugh) wrote :

It was in 1574, it got broken in 1575. I've committed a small efficiency fix, and re-instated correct ordering for performing the model sort.

Tim Waugh (twaugh) wrote :

(By the way: thanks for the fix!)

Till Kamppeter (till-kamppeter) wrote :

While repackaging system-config-printer to fix bug 149529 I have included the full fix from upstream (SVN rev 1662) which improves the performance somewhat. Test packages (on the way to Gutsy) at the same place:

http://www.linux-foundation.org/~till/tmp/ubuntu/gutsy/system-config-printer/

Till Kamppeter (till-kamppeter) wrote :

Tim, thanks for the quick upload of the improvements for the matching process.

Anyone in the Ubuntu Upload Sponsors team for Main, can you upload the new package in

http://www.linux-foundation.org/~till/tmp/ubuntu/gutsy/system-config-printer/

Steve Langasek told that it is OK with the release freeze.

Thanks in advance.

@Till : I confirm that your package works.

system-config-printer (0.7.75+svn1653-0ubuntu2) gutsy; urgency=low

  * debian/patches/10_menu_entries.patch: Let menu entry for displaying
    queued jobs appear in the "Accessories" menu and not under "Systemn
    Tools". "Systemn Tools" is KDE-specific (LP: #149529).
  * debian/patches/20_match_more_printers.patch: Do best match by
    "most important word" case-insensitive. This matches especially
    the Canon printers correctly with the Gutenprint PPDs (LP: #149264).

 -- Till Kamppeter <email address hidden> Fri, 5 Oct 2007 18:46:02 +0100

Changed in system-config-printer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments