Current version system-config-printer in trusty-proposed has unsatisfiable dependency on cups-filters-ippusbxd

Bug #1409263 reported by John Gilbertson on 2015-01-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned

Bug Description

The version of system-config-printer-udev in trusty-proposed (1.4.3+20140219-0ubuntu2.4) contains an unsatisfiable dependency on cups-filters-ippusbxd, which is currently not available in the Trusty repositories.

Changed in system-config-printer (Ubuntu):
importance: Undecided → High
Changed in system-config-printer (Ubuntu Trusty):
status: New → In Progress
Changed in system-config-printer (Ubuntu):
status: New → Invalid
importance: High → Undecided
Changed in system-config-printer (Ubuntu Trusty):
importance: Undecided → High
Till Kamppeter (till-kamppeter) wrote :

Uploaded system-config-printer_1.4.3+20140219-0ubuntu2.5 to trusty-proposed. As soon as the package gets approved testing instructions will be posted here. Please test and report back here then, so that we can make this package be an official update for Trusty. Thanks.

tags: added: package-from-proposed regression-proposed trusty
removed: cups-filters system-config-printer

Hello John, or anyone else affected,

Accepted system-config-printer into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/system-config-printer/1.4.3+20140219-0ubuntu2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in system-config-printer (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Till Kamppeter (till-kamppeter) wrote :

I have updated my Trusty system and the -0ubuntu2.5 package got installed by that, and it worked without having cups-filters-ippusbxd installed. So the bug is fixed with this package.

tags: added: verification-done
removed: verification-needed
Till Kamppeter (till-kamppeter) wrote :

I have verified now that the new package (-0ubuntu2.5) also fixes all the bugs for which the original package (-0ubuntu2.4) was intended for: bug 1394244, bug 1398444, bug 1400232, and bug 1401835.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.4.3+20140219-0ubuntu2.5

---------------
system-config-printer (1.4.3+20140219-0ubuntu2.5) trusty-proposed; urgency=medium

  * debian/patches/35_ipp-over-usb-support.patch: Removed, IPP-over-USB support
    was not yet intended with this SRU.
  * debian/control: Removed dependency on cups-filters-ippusbxd package
    (LP: #1409263).
 -- Till Kamppeter <email address hidden> Sat, 10 Jan 2014 17:19:26 +0100

Changed in system-config-printer (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for system-config-printer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers