Missing dependency on gir1.2-gtk-3.0

Bug #1398444 reported by Siep Kroonenberg
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Fix Released
Undecided
Unassigned
Trusty
Fix Released
Undecided
Unassigned

Bug Description

When trying to start system-config-printer from the command-line, I get an error

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 32, in <module>
    from gi.repository import Gdk
ImportError: cannot import name Gdk

After installing gir1.2-gtk-3.0 the error disappears.

[Impact]

The gir1.2-gtk-3.0 can be uninstalled or system-config-printer can be installed on a system with no gir1.2-gtk-3.0, leading to a non-working system-config-printer.

[Test Case]

Try to uninstall gir1.2-gtk-3.0 on a Trusty system with system-config-printer installed. It will work or if not, the dependencies shown will not include system-config-printer-gnome.

With the proposed package system-config-printer-gnome depends on gir1.2-gtk-3.0.

[Regression Potential]

No regression potential at all as there is no code change.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Which version of Ubuntu and of system-config-printer are you using? I have checked and both the versions of system-config-printer currently used by Utopic (14.10) and Vivid (15.04) depend on gir1.2-gtk-3.0.

Is it possible that when you installed gir1.2-gtk-3.0 that an older version of gir1.2-gtk-3.0 got replaced by a newer one? If yes, which was your old version and which the new version of gir1.2-gtk-3.0?

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Revision history for this message
Siep Kroonenberg (siepo) wrote : Re: [Bug 1398444] Re: Missing dependency on gir1.2-gtk-3.0

On Fri, Dec 05, 2014 at 01:24:12PM -0000, Till Kamppeter wrote:
> Which version of Ubuntu and of system-config-printer are you using? I
> have checked and both the versions of system-config-printer currently
> used by Utopic (14.10) and Vivid (15.04) depend on gir1.2-gtk-3.0.

Trusty (14.04)

> Is it possible that when you installed gir1.2-gtk-3.0 that an older
> version of gir1.2-gtk-3.0 got replaced by a newer one? If yes, which was
> your old version and which the new version of gir1.2-gtk-3.0?

I had no old version installed; I just installed it in an effort to
get system-config-printer working. The currently-installed version
is 3.10.8-0ubuntu1.2

--
Siep Kroonenberg

Revision history for this message
Siep Kroonenberg (siepo) wrote :

On Fri, Dec 05, 2014 at 04:19:02PM +0100, Siep Kroonenberg wrote:
> On Fri, Dec 05, 2014 at 01:24:12PM -0000, Till Kamppeter wrote:
> > Which version of Ubuntu and of system-config-printer are you using? I
> > have checked and both the versions of system-config-printer currently
> > used by Utopic (14.10) and Vivid (15.04) depend on gir1.2-gtk-3.0.
>
> Trusty (14.04)

and system-config-printer-[common|gnome] 1.4.3+20140219-0ubuntu2.2

> > Is it possible that when you installed gir1.2-gtk-3.0 that an older
> > version of gir1.2-gtk-3.0 got replaced by a newer one? If yes, which was
> > your old version and which the new version of gir1.2-gtk-3.0?
>
> I had no old version installed; I just installed it in an effort to
> get system-config-printer working. The currently-installed version
> is 3.10.8-0ubuntu1.2

i.e. gir1.2-gtk-3.0 3.10.8-0ubuntu1.2

--
Siep Kroonenberg

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

The dependency is present in the packages in Utopic and Vivid, but in Trusty it is indeed missing.

Changed in system-config-printer (Ubuntu):
status: Incomplete → Fix Released
Changed in system-config-printer (Ubuntu Trusty):
status: New → Triaged
description: updated
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Uploaded a package fixing bug 1398444, bug 1400232, and bug 1401835 to trusty-proposed. As soon as the package is approved it will be available for download and testing and instructions will get posted here. Please test the package and give your feedback here, otherwise it will not get available as official update.

Changed in system-config-printer (Ubuntu Trusty):
status: Triaged → In Progress
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Siep, or anyone else affected,

Accepted system-config-printer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/system-config-printer/1.4.3+20140219-0ubuntu2.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in system-config-printer (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Siep Kroonenberg (siepo) wrote :

On my system, version 1.4.3+20140219-0ubuntu2.4 of system-config-printer-gnome depended on gir1.2-gtk-3.0: installing system-config-printer-gnome/trusty-proposed pulled in gir1.2-gtk-3.0, and uninstalling gir1.2-gtk-3.0 caused the removal of system-config-printer-gnome.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Thank you, now all is working as it should be.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

The proposed system-config-printer package for Trusty got a dependency on cups-filters-ippusbxd accidentally (binary package system-config-printer-udev). Therefore please reject the package in trusty-proposed. I will upload a corrected -0ubuntu2.5 immediately then.

Changed in system-config-printer (Ubuntu Trusty):
status: Fix Committed → In Progress
tags: added: verification-failed
removed: verification-done
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Uploaded system-config-printer_1.4.3+20140219-0ubuntu2.5 to trusty-proposed with the dependency on cups-filters-ippusbxd removed. See bug 1409263.

Mathew Hodson (mhodson)
tags: added: trusty
Changed in system-config-printer (Ubuntu Trusty):
status: In Progress → Fix Committed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Checked the new package from trusty-proposed (-0ubuntu2.5) and here the dependency on gir1.2-gtk-3.0 is also present.

tags: added: verification-done
removed: verification-failed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.4.3+20140219-0ubuntu2.5

---------------
system-config-printer (1.4.3+20140219-0ubuntu2.5) trusty-proposed; urgency=medium

  * debian/patches/35_ipp-over-usb-support.patch: Removed, IPP-over-USB support
    was not yet intended with this SRU.
  * debian/control: Removed dependency on cups-filters-ippusbxd package
    (LP: #1409263).
 -- Till Kamppeter <email address hidden> Sat, 10 Jan 2014 17:19:26 +0100

Changed in system-config-printer (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers