not possible to move a print task from one printer queue to another printer queue

Bug #1388601 reported by Sasa Paporovic
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

I have by accident choosen a not connected printer for a print task out of thunderbird. I tried to move the print job from the queue of the not connected printer to the connected printer. That failes.

Reproducing procedure:
1. Make sure to reproduce on a system whith at minimum 2 printers are installed.
2. Disconnect Printer1. Make sure Printer2 is connected.
3. Open up thunderbird and choose a mail.
4. Use within thunderbird menue -> file -> print and send the printjob to the disconnected printer1.
5. Click on the printer1 queue indicator(right upper corner) and see the print queue window popping up.
6. Click on the print job with the right mouse button and choose the move to dropdown menu point -> Choose the connected printer2.
7. See that moving operation fails and the printjob is not done on printer2.

Expected: It would be helpfull if the moving printing job option would work.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: system-config-printer-gnome 1.4.3+20140219-0ubuntu2.2
ProcVersionSignature: Ubuntu 3.13.0-39.66-generic 3.13.11.8
Uname: Linux 3.13.0-39-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CupsErrorLog:

CurrentDesktop: Unity
Date: Sun Nov 2 18:27:01 2014
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InstallationDate: Installed on 2013-05-03 (548 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
InterpreterPath: /usr/bin/python2.7
Lpstat:
 device for HP-Officejet-Pro-8100: hp:/net/Officejet_Pro_8100?zc=HPA0D3C1D42F73
 device for Officejet_Pro_8000_A809: hp:/usb/Officejet_Pro_8000_A809?serial=CN0462M1ZG
MachineType: To be filled by O.E.M. To be filled by O.E.M.
PackageArchitecture: all
Papersize: a4
PpdFiles:
 HP-Officejet-Pro-8100: HP Officejet Pro 8100, hpcups 3.14.3
 Officejet_Pro_8000_A809: HP Officejet Pro 8000 a809, hpcups 3.14.3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-39-generic root=UUID=082543fa-3c13-4bae-acc6-16c56e7177d3 ro quiet splash vt.handoff=7
SourcePackage: system-config-printer
UpgradeStatus: Upgraded to trusty on 2014-07-14 (111 days ago)
dmi.bios.date: 11/15/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1302
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: M5A97 LE R2.0
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1302:bd11/15/2012:svnTobefilledbyO.E.M.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnASUSTeKCOMPUTERINC.:rnM5A97LER2.0:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: To be filled by O.E.M.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :
Revision history for this message
Tim Waugh (twaugh) wrote :

The signal handler never seems to be called. Not sure why not.

Revision history for this message
Tim Waugh (twaugh) wrote :

Seems like a GTK+ bug. Should be worked around in current 1.4.x (the relevant commits are 8cdc6a7, 0f83c0a, b6fd62a).

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Tim, are these fixes already applied in 1.5.x? In which version exactly? I need this to know whether Utopic and Vivid are already fixed.

Revision history for this message
Tim Waugh (twaugh) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.5.4+20141212-0ubuntu1

---------------
system-config-printer (1.5.4+20141212-0ubuntu1) vivid; urgency=medium

  * New upstream release
     o GIT 1.5.x snapshot from 12 December 2014
     o Fixed all problems which prevented the automatic download of printer
       driver packages (LP: #1401835).
     o Handle non-UTF8 PPD files (LP: #1400232).
     o Use 'with' when dealing with temporary files.
     o troubleshoot: get logs from cups.service, not just cupsd
     o Avoid traceback (Red Hat bug #1171469).
     o Fixed 'Search' button icon.
     o Debug output showing DBus exception message.
     o Fixed display of downloadable drivers (Red Hat bug #1167978).
     o Prevent backtrace (Red Hat bug #1167978).
     o Refresh job-printer-uri in update_job
     o Consider version suffixes in Nickname for PPDs from Canon drivers
       (fedorahosted.org bug #235).
     o Extract hostname from hp:/net/...?hostname= URIs when grouping by
       physical device (Red Hat bug #1154686).
     o Codec fix for AuthDialog.get_auth_info (Red Hat bug #1060453).
     o Catch IPPError when writing server settings (Red Hat bug #1159584).
     o OpenPrintingRequest lock handling fixes
     o Never set SMB Verify button sensitive without checking pysmb is
       available
     o PackageKit-based installation of smb backend on demand is now fixed
     o Ubuntu fix for on demand installation of libsane-hpaio
     o HP MFP devices that cannot scan are now properly detected
     o ppdcache: handle errors more gracefully
     o Don't try to remove gobject sources that are already removed
     o A Python 3 fix when dealing with HPLIP fax devices
     o Fixed physical device grouping by using the cupshelpers.ppds
       'normalize' function for comparisons
     o Cancel deferred timer on quit (possible fix for Red Hat bug #1145388)
     o Don't use deprecated GTK+ widgets and properties
     o React to button-press-event for Move To submenu in jobviewer
       (LP: #1388601)
  * debian/patches/35_package-download-fixes.patch: Removed, included upstream.
 -- Till Kamppeter <email address hidden> Fri, 12 Dec 2014 19:41:08 +0100

Changed in system-config-printer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers