system-config-printer.py crashed with TypeError in probe_queue(): 'str' does not support the buffer interface

Bug #1372213 reported by Andrew Austin
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Steps to Reproduce:
1. Add a Printer in System Settings
2. Select Network Printer
3. Selected LPD/LPR Host or Printer
4. Enter IP 192.168.1.100
5. Click Probe

Crashes every time.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: system-config-printer-gnome 1.5.1+20140911-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-16.22-generic 3.16.2
Uname: Linux 3.16.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CupsErrorLog:

CurrentDesktop: Unity
Date: Sun Sep 21 20:49:23 2014
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InstallationDate: Installed on 2014-09-21 (0 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140919)
InterpreterPath: /usr/bin/python3.4
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: Gigabyte Technology Co., Ltd. GA-880GMA-UD2H
PackageArchitecture: all
Papersize: letter
ProcCmdline: /usr/bin/python3 /usr/share/system-config-printer/system-config-printer.py
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-16-generic root=UUID=5e6ccdb1-444a-4fe4-a73e-a9ebc02ac771 ro quiet splash
PythonArgs: ['/usr/share/system-config-printer/system-config-printer.py']
SourcePackage: system-config-printer
Title: system-config-printer.py crashed with TypeError in probe_queue(): 'str' does not support the buffer interface
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 09/30/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F5
dmi.board.name: GA-880GMA-UD2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF5:bd09/30/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-880GMA-UD2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-880GMA-UD2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-880GMA-UD2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Revision history for this message
Andrew Austin (andrewaclt) wrote :
Revision history for this message
Andrew Austin (andrewaclt) wrote :

This bug was marked private by default. I've moved it to public because at quick glance I don't see any personal information in the files or logs uploaded. Please let me know if this is not the case and it really should be private. =)

information type: Private → Public
tags: removed: need-duplicate-check
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Jiri Popelka (jpopelka) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.5.1+20141010-0ubuntu1

---------------
system-config-printer (1.5.1+20141010-0ubuntu1) utopic; urgency=medium

  * New upstream release
     o GIT 1.5.x snapshot from 10 October 2014
     o Don't try nested classes, as CUPS forbids it (Red Hat bug #1140627).
     o Fixed LPD/LPR Probe (LP: #1372213).
     o Improve some Gtk+ 3 stuff.
     o Python 3 has removed message attribute from built-in exceptions.
 -- Till Kamppeter <email address hidden> Fri, 10 Oct 2014 17:25:36 +0200

Changed in system-config-printer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers