system-config-printer.py crashed with TypeError in __init__(): Type str doesn't support the buffer API

Bug #1367368 reported by Henry E Wyatt Jr
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Fix Released
Medium
Till Kamppeter

Bug Description

Can't install printer.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: system-config-printer-gnome 1.5.1+20140906-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
Uname: Linux 3.16.0-14-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CupsErrorLog:

CurrentDesktop: Unity
Date: Tue Sep 9 12:41:48 2014
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InstallationDate: Installed on 2014-09-09 (0 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140905)
InterpreterPath: /usr/bin/python3.4
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: Hewlett-Packard HP ENVY m6 Notebook PC
PackageArchitecture: all
Papersize: letter
ProcCmdline: /usr/bin/python3 /usr/share/system-config-printer/system-config-printer.py
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-14-generic.efi.signed root=UUID=4765aaff-e3b5-4471-adb5-686080400813 ro quiet splash vt.handoff=7
PythonArgs: ['/usr/share/system-config-printer/system-config-printer.py']
SourcePackage: system-config-printer
Title: system-config-printer.py crashed with TypeError in __init__(): Type str doesn't support the buffer API
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 01/21/2013
dmi.bios.vendor: Insyde
dmi.bios.version: F.25
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 18A4
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 73.50
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.25:bd01/21/2013:svnHewlett-Packard:pnHPENVYm6NotebookPC:pvr0881120000305B10000620100:rvnHewlett-Packard:rn18A4:rvr73.50:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP ENVY m6 Notebook PC
dmi.product.version: 0881120000305B10000620100
dmi.sys.vendor: Hewlett-Packard

Revision history for this message
Henry E Wyatt Jr (hewjr100) wrote :
tags: removed: need-duplicate-check
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Changed in system-config-printer (Ubuntu):
assignee: nobody → Till Kamppeter (till-kamppeter)
status: Confirmed → New
Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Tim, it seemsthat something in the Python3 transition has torn down the handling of thediscovered printers completely, at least in Ubuntu. Perhaps some basic concepts of Python have changed or data types are distinguished more strictly.

I can reproduce the problem by staring s-c-p from a terminal, clicking "Add printer" and then choosing one of the discovered printers (in my caseit was a network printer). Instead of geting the connection types for the printer in the lower right of thedialog, I get traceback with said message in the terminal window.

Revision history for this message
Tim Waugh (twaugh) wrote :

Try the current git HEAD.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Tim, thank you very much. It works perfectly now.

Changed in system-config-printer (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.5.1+20140911-0ubuntu1

---------------
system-config-printer (1.5.1+20140911-0ubuntu1) utopic; urgency=medium

  * New upstream release
     o GIT 1.5.x snapshot from 11 September 2014
     o More Python 3 fixes (LP: #1367368).
  * debian/control: Added dependency on python3-cairo (LP: #1353880).
 -- Till Kamppeter <email address hidden> Thu, 11 Sep 2014 17:02:50 +0200

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers