Cannot run system-config-printer as notmal user after upgrading to 14.04

Bug #1366727 reported by Roberto on 2014-09-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I have issues after upgrading from 12.04 to 14.04. I can run

system-config-printer

as root but not as a normal user. I get the error

There was an error during the CUPS operation: 'Bad Request'.

If I run

system-config-printer --debug

I get the following output:

OpenPrinting: Init ('en_US', 'UTF-8') 1 0
+<NewPrinterGUI object at 0x7ff964028460 (newprinter+NewPrinterGUI at 0xea5ba0)>
Connected as user roberto
+<PrinterPropertiesDialog object at 0x7ff964041dc0 (printerproperties+PrinterPropertiesDialog at 0xf0b3a0)>
<authconn.Connection instance at 0x7ff964033830>: Operation += obtaining queue details
Authentication pass: 1
Authentication: password callback set
1024: u'Bad Request'

If I instead run the command with sudo I can access the dialog and set the printers, but then the applications that do not run as root cannot see the printers set by root.

The variable

CUPS_SERVER

is set and exported both by the .profile in my home directory and in /etc/profile. I would also exclude a rights problem as (i) the command was workin gbefore the upgrade, and (ii) my user's groups include

sys adm lp dialout lpadmin admin

Please provide your cups error log, activate debugging as described here: https://wiki.ubuntu.com/DebuggingPrintingProblems#CUPS_error_log

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Roberto (grace-malibran) wrote :

I tried to run

cupsctl LogLevel=debug

but I am requested a password. My password to all other services in the network is rejected. However, unsurprisingly given my earlier report, the command

cupsctl LogLevel=debug

execute without complaining. It seems that my user is misconfigured, which is wierd for because the upgrade it worked.

Roberto (grace-malibran) wrote :

ERRATA CORRIGE

The second command, which ran, is

sudo cupsctl LogLevel=debug

Launchpad Janitor (janitor) wrote :

[Expired for system-config-printer (Ubuntu) because there has been no activity for 60 days.]

Changed in system-config-printer (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions