Unity add printer dialog is frozen after upgrade

Bug #1313157 reported by Huck-bernhard on 2014-04-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

after upgrade Ubuntu from 13.10 to 14.04
Add Printer Dialog is frozen, can not add a new Printer in system-config-printer.

Steps:

1. Click Add Printer in system-config-printer
2. Wait until your network printer is showing
3. Klick the Printer Name in the Devices list.
4. Now Window "New Printer" is frozen.

On a new installation of Ubuntu 14.04 (32 Bit) is it working.

------------- Workaround ------------------------------------

1. Start GNOME 3 Desktop.
2. Add Printer in gnome-control-center.
3. Go back to Unity Desktop.
4. Now can you use the added Printer. (but add printer in Unity is still not working.)

[Impact]

For certain non-HP printer models it is impossible to set up the printer with system-config-printer.

[Test Case]

Have a non-HP network printer available on which the command

hp-makeuri -c [IP of the printer]

hangs (does not exit, requies Ctrl+C to get back to the prompt).

Set up as described above under "Steps". Current version of system-config-printer freezes, the proposed fix allows setting up the printer.

[Regression Potential]

Very low. It is possible that a printer does not provide make/model info and there hp-makeuri gets called anyway.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: system-config-printer-gnome 1.4.3+20140219-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Apr 26 19:34:57 2014
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InstallationDate: Installed on 2013-10-18 (189 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
InterpreterPath: /usr/bin/python2.7
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: MSI MS-7816
PackageArchitecture: all
Papersize: a4
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=cbbc403b-0919-4944-b634-d6fd84c4c34f ro quiet splash
SourcePackage: system-config-printer
UpgradeStatus: Upgraded to trusty on 2014-04-26 (0 days ago)
dmi.bios.date: 06/06/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.3
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z87-G43 (MS-7816)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.3:bd06/06/2013:svnMSI:pnMS-7816:pvr1.0:rvnMSI:rnZ87-G43(MS-7816):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7816
dmi.product.version: 1.0
dmi.sys.vendor: MSI

Huck-bernhard (huck-bernhard) wrote :
description: updated
summary: - add printer dialog is frozen
+ Unity add printer dialog is frozen
description: updated
summary: - Unity add printer dialog is frozen
+ Unity add printer dialog is frozen after upgrade
Till Kamppeter (till-kamppeter) wrote :

There is no "Unity add printer dialog". Where exactly did you click on "Add printer"?

I assume that you are using system-config-printer, the default printer setup tool. To get more debug information, open a terminal window and run the command

system-config-printer --debug 2>&1 | tee log.txt

go the steps until getting the frozen dialog, the press Ctrl+C in the terminal window (or run "xkill" in a new tab of the terminal window and click the frozen dialog). After that attach log.txt to this bug report.

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Huck-bernhard (huck-bernhard) wrote :

There is the log.txt
yes you are right, i mean the system-config-printer
I did make the steps untill the frozen Window.

Changed in system-config-printer (Ubuntu):
status: Incomplete → New
description: updated
description: updated
Till Kamppeter (till-kamppeter) wrote :

The last sign of life in the log.txt is that a part of HPLIP is trying to investigate your Epson printer. The command

hp-makeuri -c EPSON61D4D8

is run.

EPSON61D4D8 is the host name of your printer. Its IP is 192.168.0.105.

In a terminal window, try the following command:

hp-makeuri -c EPSON61D4D8

Does this command exit? Or do you need to stop it with Ctrl+C? Can you post the output of this command?

What is the output of the commands

host EPSON61D4D8
host 192.168.0.105
hp-makeuri -c 192.168.0.105

What do you get with the following URLs in a browser:

http://EPSON61D4D8/
http://192.168.0.105/

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Huck-bernhard (huck-bernhard) wrote :

hp-makeuri -c EPSON61D4D8

yes i can exit the command without Ctrl-C to stop. In the hp-makeuri.log is the output.

bernhard@bernhard-MS-7816:~$ host EPSON61D4D8
Host EPSON61D4D8 not found: 3(NXDOMAIN)

bernhard@bernhard-MS-7816:~$ host 192.168.0.105
Host 105.0.168.192.in-addr.arpa. not found: 3(NXDOMAIN)

http://EPSON61D4D8/

Server not found

Firefox can't find the server at www.epson61d4d8.com.

http://192.168.0.105/

Epson Stylus Office BX630FW Start seite ..............

Changed in system-config-printer (Ubuntu):
status: Incomplete → New
Huck-bernhard (huck-bernhard) wrote :
Till Kamppeter (till-kamppeter) wrote :

As usual I am scrambling up the things. Try also the following commands:

host 192.168.0.105
hp-makeuri -c 192.168.0.105

Try also

host EPSON61D4D8.local
hp-makeuri -c EPSON61D4D8.local

Please post the output of all these commands here and tell me also whether you always get back to the command prompt automatically or whether you have to stop a command with Ctrl+C.

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

Thank you very much.

So we need to assure that hp-makeuri is not called on non-HP printers because it can hang on some.

Changed in system-config-printer (Ubuntu):
status: Incomplete → Triaged
Huck-bernhard (huck-bernhard) wrote :

 host EPSON61D4D8.local
Host EPSON61D4D8.local not found: 3(NXDOMAIN)
bernhard@bernhard-MS-7816:~$

@ hp-makeuri -c 192.168.0.105
and hp-makeuri -c EPSON61D4D8.local
there is no command prompt automatically.
And Ctrl+C is not getting a command prompt

Changed in system-config-printer (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed

I have uploaded a system-config-printer package with a fix now. Please try it as soon as you get it with the updates (version is 1.4.3+20140219-0ubuntu3) and tell whether it solves your problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.4.3+20140219-0ubuntu3

---------------
system-config-printer (1.4.3+20140219-0ubuntu3) utopic; urgency=low

  * debian/patches/33_dont-use-hp-makeuri-with-non-hp-printers.patch:
    Before calling "hp-makeuri" to determine whether a network printer is
    supported by HPLIP and to get its HPLIP URI if so, check whether the
    printer is actually an HP printer before, as hp-makeuri can hang on
    non-HP printers (LP: #1313157).
 -- Till Kamppeter <email address hidden> Mon, 28 Apr 2014 23:21:52 +0200

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released

Sorry, my package upload went to the new version under development (14.10, Utopic). For you to test I have attached a patch now. Please download it, open a terminal window, and run the following commands:

cd /usr/share/system-config-printer/
sudo patch -p0 < ~/dont-use-hp-makeuri-with-non-hp-printers.patch

Enter your password if asked for.

After that close all windows of system-config-printer, start it again and try set up your printer again. Does it work now?

Huck-bernhard (huck-bernhard) wrote :

Many Thanks for your quick help, i could install the patch.
Yahoo, the frozen Window is gone.
Adding Printer in system-config-printer is now working again.
Hope this patch will also find the way to Version 14.04

Uploaded a proposed fix to trusty-proposed. As soon as this package gets approved instructions will be posted here how to install it. Please install it and test whether it fixes the problem. Your feadback is required for the fixed package to get an official update.

description: updated
Changed in system-config-printer (Ubuntu Trusty):
status: New → Fix Committed
milestone: none → trusty-updates

Hello Huck-bernhard, or anyone else affected,

Accepted system-config-printer into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/system-config-printer/1.4.3+20140219-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Huck-bernhard (huck-bernhard) wrote :

TEST CASE:
1. update -proposed packade "system-config-printer 1.4.3+20140219-0ubuntu2.1"
2. Click Add Printer in system-config-printe
3. Wait until your network printer is showing
4. Klick the Printer Name in the Devices (EPSON Epson Stylus Office BX630FW) list.
5. Kick Forwaard to add the Printer.

VERIFICATION DONE
Frozen printer dialog is gone, add printer is working again

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.4.3+20140219-0ubuntu2.1

---------------
system-config-printer (1.4.3+20140219-0ubuntu2.1) trusty-proposed; urgency=low

  * debian/patches/33_dont-use-hp-makeuri-with-non-hp-printers.patch:
    Before calling "hp-makeuri" to determine whether a network printer is
    supported by HPLIP and to get its HPLIP URI if so, check whether the
    printer is actually an HP printer before, as hp-makeuri can hang on
    non-HP printers (LP: #1313157).
 -- Till Kamppeter <email address hidden> Mon, 28 Apr 2014 23:21:52 +0200

Changed in system-config-printer (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for system-config-printer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in system-config-printer (Ubuntu):
importance: Undecided → High
Changed in system-config-printer (Ubuntu Trusty):
importance: Undecided → High
To post a comment you must log in.