system-config-printer does not save options into .cups/lpoptions for unprivileged users

Bug #127071 reported by Till Kamppeter on 2007-07-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: system-config-printer

If I run system-config-printer as a privileged user (first user set up by Ubuntu, member of "lpadmin" group) all works as I expect it: PPD option settings are saved in the "*Default..." lines of the queue's PPD file (/etc/cups/ppd/<queue>.ppd and CUPS-specific in /etc/cups/printers.conf.

If I run it as unprivileged user I would like that it saves the settings in the user's ~/.cups/lpoptions file.

Or even better: For a privileged user ask whether the settings should be applied system-wide or personally (when clicking on "Apply").

Changed in system-config-printer:
importance: Undecided → Medium
status: New → Confirmed
Tim Waugh (twaugh) wrote :

I think it would be quite difficult to make an easy-to-understand UI for that.

A much better idea would be for the GTK+ print dialog to handle user defaults.

Changed in system-config-printer:
importance: Medium → Wishlist
Hagen (crater) wrote :

Mmh, there's really no way to change it's personal printer settings, without interfering the system-wide ones? As far as I can remember this was once possible (using gnome-cups-manager).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers