Printer driver installation freezes

Bug #1253361 reported by Francesco Tarantini on 2013-11-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

I tried to add my printer to Ubuntu 13.10 via system settings > printers. After the scan, I was presented with gutenprint as the only choice. I gave the OK, typed my password when prompted and the installation started, but then it freezed at about 50%. I closed system-config-printer.py from the system monitor, then rebooted and tried again, but the second time the progress bar didn't even reach 1%. It just says "installing drivers" but nothing happens.
Printer: Canon MP600
I added the same printer on the same computer effortlessly with Ubuntu 13.04.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: system-config-printer-gnome 1.4.2+20130920-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic i686
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
CupsErrorLog:

Date: Wed Nov 20 21:34:30 2013
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InstallationDate: Installed on 2013-10-26 (25 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
InterpreterPath: /usr/bin/python2.7
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: Acer, inc. Aspire 5670
MarkForUpload: True
PackageArchitecture: all
Papersize: a4
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-13-generic root=UUID=b112c2d9-565a-4ca8-b99c-d65bc6c79897 ro quiet splash vt.handoff=7
SourcePackage: system-config-printer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/24/06
dmi.bios.vendor: Acer
dmi.bios.version: v1.3221
dmi.board.name: Bodensee
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3221:bd02/24/06:svnAcer,inc.:pnAspire5670:pvrNotApplicable:rvnAcer,Inc.:rnBodensee:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 5670
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.

Francesco Tarantini (fraxav88) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-printer (Ubuntu):
status: New → Confirmed
Download full text (5.1 KiB)

I have the same problem with my Canon Pixma MP450 and Ubuntu 13.10 !

System-config-printer try to install gutenprint, but is gutenprint already installed ?!!! (it's one of the default packages)

And it sits right there for all eternity. I think I could wait 2 years it will still not time out or something ...

I rebooted, I tried on a fresh install, I tried to use the second option "Local Driver" and it's even worst ! "Forward" doesn't do anything !

The only way to make this printer install, is to click on gutenprint, then, you cancel very fast the gutenprint installation, then you have the traditional list of printers ! And now it's working ?!? (yes it does work !)

Please fix your sh*t ubuntu devs ! Please make your modifications less random and untested. How in the world, is an option to bypass something (local driver) not even tested in real life ?! You are embarrassing everybody !

This printer should not even ask for a driver install, as it works perfectly with what is already there !

And why asking to install "openprinting-gutenprint" when gutenprint is already installed ?! What is the difference ?

Please explain yourself ! Remove this "anti-feature" ... Because right there, it's not a feature, it's a bug, and a big one indeed !

It feels like somebody had a good idea but never had a canon printer handy to test with, or even to know if it worked. Man, it's tiring sometime to see all theses untested features ...

I think the idea is for users with canon printer requiring proprietary drivers. And for that, it's good and neat. But if your only choice is gutenprint, ... to download and install gutenprint a second time, in case having one copy of gutenprint wasn't enough, it's bullsh*t !!! This choice shouldn't be there. Even if it worked properly !

It should be said, man, give a little more effort in your code ubuntu team, make it more error resilient, everything you do should be bypassed. It's a printer install wizard, why is this so badly butchered !

And it's not the first time we have something like that in Ubuntu, in fact, it's every time something new is coming from the ubuntu internal devs. Don't rely that much on the users to test things ! You are tiring them. If it's impossible to keep updating everything every 6 month, just stop this nonsense ! I'm using Ubuntu from 6.06, so I'm not a "quitter", but I know why one would want to stop caring about such a distribution and start searching somewhere else. Ubuntu should really start to "Eat is own dog food". That means, if you make a change, make it such that yourself or another developer can test it in real life with real hardware on the development release so most of the bugs are seen and fixed by someone that may know better.
It's faster and way more reliable than making a modification in the dark, waiting for a user that had enough to shout his anger to you all, don't know what really appended that made this mess, and having to spend the time to read, understand and decrypt what the problem is.

The fact is, despite the popularity of canon printers, I'm only the second one reporting that bug, nobody takes time nowadays to make a bug report if their is a workaround (in this cas...

Read more...

Robert Borter (robert-borter) wrote :

Had the same probem trying to install a Canno MP-510. Just hangs... Let me know when a fix is ready. Thanks to all.

--Robert

mike copley (oldtorana) wrote :

Exactly the same on a brand new HP XP-410 under 13.10

Installation appeared to be working, although slow. The status reached 50% and stalled. Tried again, and got to around 1%.

Tried the local driver, and it didn't work at all! not even to the point of putting in my password.

Downloaded the .deb 32bit pkg, and tried installing through Software Centre, to which it also failed at 50% saying it was an Update with the .deb package waiting.

No good at all.

Till Kamppeter (till-kamppeter) wrote :

Please have a look at my comment #32 of bug 1248303:

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1248303/comments/32

Does it work for you on 14.04?

Please reply and continue discussion on bug 1248303, as this one is a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers