system-config-printer adds menu item the same as gnome-cups-manager's menu item

Bug #107766 reported by Alex Smith on 2007-04-19
40
Affects Status Importance Assigned to Milestone
system-config-printer (Baltix)
Undecided
Unassigned
system-config-printer (Ubuntu)
Medium
Martin Pitt
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: system-config-printer

The system-config-printer tool (installable from Add/Remove Programs) installs a menu item in System -> Administration with the same title as the menu item provided by gnome-cups-manager. This is confusing, since you can't see which one is which.

Jani Monoses (jani) on 2007-04-19
Changed in system-config-printer:
status: Unconfirmed → Confirmed
Elliot Hughes (elliot-hughes) wrote :

Thanks for the time you took to report this bug. It is now confirmed and will probably be fixed in due course.

I haven't explicitly installed any system-config-printer (to my knowledge)
Yet I also find both items in the System -> Admin menu.

This is extra confusing because they are both different interfaces to the same thing.

About the old-style administration (like it was in previous versions of Ubuntu)
1) it now takes like half a minute or more to show the properties of a printer.
2) locally connected printer is now seen as a remote printer with usb://Samsung/ML-2010 as url

About the new-style administration (with the tree on the left)
1) it has better organized printer properties
2) it feels a bit more complex about sharing and stuff
3) it remembers and uses my options about economy mode, etc. (it didn't in the past)

About plug & play
1) It actually added the printer the moment I connected it. It didn't do this in the past.
2) I got a notification message with a big 'configure' button. This launched the new-style-admin.

There is now a default printer entry at System -> Preferences.

I think only one of the administrations should be installed by default.
Considering how much better the new administration works, I would vote for that.

Another thing: The test-page of the new-style-admin is not ubuntu-specific. It shows a lot of cups yibberish. Not a good idea (tm)

The print-test-page-button on the old-style-admin still prints an ubuntu-specific page.

Martin Pitt (pitti) wrote :

We do not install gnome-cups-manager by default any more, but I do see that this creates confusion on upgrades. We shuold probably make g-c-m and s-c-p conflict to each other, so that you can only have one of them installed. This would both solve this bug and also do the right thing on upgrades.

What do you think?

I would vote for Martin' solution.
Just giving them different names doesn't really solve the issue.

I did do a fresh install of Tribe 2, but have been updating ever since. When we update from Feisty, we will also have two different administration programs. It's not just that their name is equal. It's just confusing to have two printer adminstration capplets installed by default.

PS. Should I file a separate bug reports about the test-page of the new admin not being Ubuntu-specific?

Martin Pitt (pitti) on 2007-08-15
Changed in system-config-printer:
assignee: nobody → pitti
importance: Undecided → Medium
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Ralf, if you want to file a separate bug, that's fine. However, I'll fix the issue now, so it's not really necessary.

Till Kamppeter (till-kamppeter) wrote :

I think the conflict is a good idea, as having two tray icons for printing is really irritating.

But we must take care that an automatic update (where s-c-p is simply pulled by a dependency in ubuntu-desktop) goes smoothly, which means that g-c-m gets automatically uninstalled.

Martin Pitt (pitti) wrote :

system-config-printer (0.7.71+-svn1399-0ubuntu2) gutsy; urgency=low

  * Resurrect debian/patches/20_support_cups_nonroot.patch: It is still useful
    for talking to remote cups servers without starting s-c-p as root.
  * Add debian/patches/04_custom_test_pages.patch: Read the paper size from
    current PPD and if there is a file /usr/share/s-c-p/testpage-<papersize.ps>,
    use that as a test page. Otherwise fall back to cups' default one.
  * Add debian/local/testpage-{a4,letter}.ps: Ubuntu specific test pages
    (taken from gnome-cups-manager). Fixed the A4 version to actually be A4.
  * Add debian/system-config-printer.install: Install the test pages.
  * debian/control: Conflicts:/Replaces: to gnome-cups-manager, so that we do
    not end up with two configuration UIs on upgrades. This is harsh and
    blunt, but *shrug*. (LP: #107766)

 -- Martin Pitt <email address hidden> Wed, 15 Aug 2007 16:30:31 +0200

Changed in system-config-printer:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

The Conflicts/Replaces was good as a hack within gutsy to get apt-get dist-upgrades right, but for the final version it would be better if update-manager would handle this. I. e. it should uninstall gnome-cups-manager when system-config-printer is installed.

gnome-cups-manager is in universe now, so maybe the automatic cleanup will already cope with this (if it actually works now)?

Changed in update-manager:
assignee: nobody → mvo
status: New → Triaged

I've upgraded from Feisty to Gutsy, and the new system-config-printer doesn't allowed me to make any change or new configuration. I've tried with my username and no password, my username and my password, root... and I always get the same error when trying to apply any change: "Failed to set settings".

Searching in /var/log/cups/error_log I found this:

E [22/Aug/2007:14:10:21 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:21 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:21 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:21 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:22 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:22 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:22 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:22 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:22 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:22 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:32 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:33 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:33 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:33 +0200] CUPS-Set-Default: Unauthorized
E [22/Aug/2007:14:10:33 +0200] CUPS-Set-Default: Unauthorized

Somebody have any idea?
When starts system-config-printer doesn't require administrative password like many other admin. apps.

Best regards,
neuromancer

I've solved the issue. After upgrading to Gutsy, my user isn't in the lpadmin group, then I added my user to this group and all is OK now.

Best regards,
neuromancer

This needs to be part of the upgrade script obviously!

Michael Vogt (mvo) wrote :

I added support to the release-upgrader to remove gnome-cups-manager on ubuntu systems.

Cheers,
 Michael

Changed in update-manager:
importance: Undecided → Medium
status: Triaged → Fix Committed
Michael Vogt (mvo) wrote :

update-manager (1:0.70) gutsy; urgency=low

  [ Jonathan Riddell ]
  * DistUpgrade/DistUpgradeViewKDE.py
    - Use apport for crashes
    - Don't use dcop, it doesn't work with kdesudo
    - Fix UI layout

  [ Michael Vogt ]
  * DistUpgrade/DistUpgradeControler.py:
    - show human readable size when displaying "not enough free space"
      error
    - when rewriting sources.list, transition the commercial
      package archive to the new location and "partner" name
  * DistUpgrade/DistUpgradeCache.py:
    - fix bogus log messages about missing "required" priority packages
  * DistUpgrade/DistUpgradeViewGtk.py:
    - remove debug messages
  * DistUpgrade/DistUpgrade.cfg:
    - remove gnome-cups-manager on upgrade, system-config-printer
      replaces it (LP: #107766)
    - set cursor to the start of the details list (LP: #134873)
    - added ubuntustudio-desktop, ichthux-desktop to valid metapackages
      (LP: #131936)
  * DistUpgrade/dist-upgrade.py, DistUpgrade/DistUpgradeViewText.py,
    DistUpgrade/DistUpgradeViewKDE.py, DistUpgrade/DistUpgradeViewGtk.py:
    - make logdir a config option too
  * UpdateManager/UpdateManager.py, UpdateManager/Common/utils.py:
    - move inhibit_sleep(), allow_sleep() into common code and call
      the freedesktop dbus interface instead of the deprecated gnome
      interface (LP: #136617)
  * tests/test_sources_list.py, tests/data-sources-list-test:
    - added tests for sources.list rewriting

 -- Michael Vogt <email address hidden> Mon, 27 Aug 2007 16:39:10 +0200

Changed in update-manager:
status: Fix Committed → Fix Released

Since update-manager now takes care of removing gnome-cups-manager on a distribution upgrade, the Conflicts/Replaces gnome-cups-manager should be removed again from system-config-printer. This would also close bug #137899.

Changed in system-config-printer:
status: Fix Released → New
Martin Pitt (pitti) wrote :

Indeed. Uploaded.

Changed in system-config-printer:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

system-config-printer (0.7.73+svn1429-0ubuntu2) gutsy; urgency=low

  * debian/control: Remove Conflicts/Replaces to gnome-cups-manager again.
    update-manager now takes care of this, and the Conflicts: leads to
    upgrading troubles (removing ubuntu-desktop). (LP: #107766)

 -- Martin Pitt <email address hidden> Mon, 10 Sep 2007 07:36:55 +0200

Changed in system-config-printer:
status: Fix Committed → Fix Released

Just to let you know, I still have this problem (two admin-menu items labeled "Printing") on a fully updated gutsy, Sept 25, 2007.

According to Raffi and John Pye (duplicate bug #188485) the bug still occurs in gutsy, therefore reopening.

Changed in update-manager:
status: Fix Released → Confirmed
Gabor Kelemen (kelemeng) wrote :

Gnome-cups-manager was dropped after Hardy, it's safe to assume that this wont be a problem anymore.

Changed in update-manager:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers