system-config-kickstart not starting

Bug #59820 reported by LABOUEBE Michael on 2006-09-10
2
Affects Status Importance Assigned to Milestone
system-config-kickstart (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: system-config-kickstart

I've recently dist-upgrade from dapper to edgy and now system-config-kickstart is not starting anymore.

$ system-config-kickstart
Could not open display because no X server is running.
Try running 'system-config-kickstart --help' for a list of options.
Traceback (most recent call last):
File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 76, in ?
import kickstartGui
File "/usr/share/system-config-kickstart/kickstartGui.py", line 29, in ?
import basic
File "/usr/share/system-config-kickstart/basic.py", line 32, in ?
from hardwareLists import langDict
File "/usr/share/system-config-kickstart/hardwareLists.py", line 30, in ?
lines = open("/usr/share/localechooser/SUPPORTED-short", "r").readlines()
IOError: [Errno 2] Aucun fichier ou répertoire de ce type: '/usr/share/localechooser/SUPPORTED-short'

Sorry output in french : it means : /usr/share/localechooser/SUPPORTED-short is missing

So I've found a little workaround :

/usr/share/localechooser $ ls -l
total 24
-rw-r--r-- 1 root root 960 2005-12-23 18:28 default-country
-rw-r--r-- 1 root root 4824 2006-08-03 04:44 languagelist
-rw-r--r-- 1 root root 4126 2005-12-23 18:28 regionmap
-rw-r--r-- 1 root root 66 2006-08-22 18:53 shortlists

So /usr/share/localechooser/SUPPORTED-short seems to be shortlists in edgy ?

A symlink /usr/share/localechooser/SUPPORTED-short to /usr/share/localechooser/shortlists output this error :

...
File "/usr/share/system-config-kickstart/hardwareLists.py", line 45, in ?
(lang, country) = langBase.split('_')
ValueError: need more than 1 value to unpack

The format of shortlists seems to have change too and is now like this :

en
fr

So, i ended to create a SUPPORTED-short file in /usr/share/localechooser/ filled with :

en_US
fr_FR

and now all works fine.

Does anyone have the same issue on running system-config-kickstart ?
I think the package should be rebuild to handle /usr/share/localechooser/shortlists.

Changed in system-config-kickstart:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

It's a bit more complicated than that - it should change to handle /usr/share/i18n/SUPPORTED instead, but at the same time I'd also like to fix it to handle console-setup. I'll work on this.

Changed in system-config-kickstart:
assignee: nobody → kamion
importance: Undecided → High
Colin Watson (cjwatson) wrote :

system-config-kickstart (2.5.20-0ubuntu14) edgy; urgency=low

  * Adjust to new localechooser-data, which has languagelist format changes
    and doesn't ship /usr/share/localechooser/SUPPORTED-short; use
    /usr/share/i18n/SUPPORTED instead (closes: Malone #59820).
  * Use keyboard lists from console-setup.
  * Convert to new Python policy, using python-support.

 -- Colin Watson <email address hidden> Wed, 11 Oct 2006 17:44:40 +0100

Changed in system-config-kickstart:
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

Make that this instead (there was already a 2.5.20-0ubuntu14 in the archive):

system-config-kickstart (2.5.20-0ubuntu15) edgy; urgency=low

  * Adjust to new localechooser-data, which has languagelist format changes
    and doesn't ship /usr/share/localechooser/SUPPORTED-short; use
    /usr/share/i18n/SUPPORTED instead (closes: Malone #59820).
  * Use keyboard lists from console-setup.
  * Convert to new Python policy, using python-support.

 -- Colin Watson <email address hidden> Wed, 11 Oct 2006 22:39:07 +0100

LABOUEBE Michael (gfarmerfr) wrote :

Thanks for the fix : works well on both my x86 and my ppc :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers