apt_pkg.ParseTagFile has been replaced by apt_pkg.TagFile, breaks system-config-kickstart

Bug #1236315 reported by Hadmut Danisch
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
system-config-kickstart (Ubuntu)
Medium
Brian Murray

Bug Description

$ system-config-kickstart

(system-config-kickstart.py:13520): libglade-WARNING **: Could not load support for `gnome': libgnome.so: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 92, in <module>
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 135, in __init__
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 107, in __init__
    import packageGroupList
  File "/usr/share/system-config-kickstart/packageGroupList.py", line 69, in <module>
    comps_file = apt_comps()
  File "/usr/share/system-config-kickstart/packageGroupList.py", line 46, in __init__
    availparse = apt_pkg.ParseTagFile(availfile)
AttributeError: 'module' object has no attribute 'ParseTagFile'

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: system-config-kickstart 2.5.20-0ubuntu22
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Mon Oct 7 13:36:11 2013
InstallationDate: Installed on 2013-05-22 (137 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: system-config-kickstart
UpgradeStatus: Upgraded to saucy on 2013-10-01 (6 days ago)

Revision history for this message
Hadmut Danisch (hadmut) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-kickstart (Ubuntu):
status: New → Confirmed
Revision history for this message
Surfraz Ahmed (surfraz) wrote :

The following change worked for me:-

--- /usr/share/system-config-kickstart/packageGroupList.py.old 2010-10-16 01:19:34.000000000 +0100
+++ /usr/share/system-config-kickstart/packageGroupList.py 2013-11-08 22:28:35.205372755 +0000
@@ -43,10 +43,10 @@
             os.execlp("apt-cache", "apt-cache", "dumpavail")
         os.waitpid(pid, 0)
         availfile.seek(0)
- availparse = apt_pkg.ParseTagFile(availfile)
- while availparse.Step() == 1:
- if availparse.Section.has_key("Task"):
- task = availparse.Section["Task"]
+ availparse = apt_pkg.TagFile(availfile)
+ while availparse.step() == 1:
+ if availparse.section.has_key("Task"):
+ task = availparse.section["Task"]
                 if not self.groups.has_key(task):
                     if apt_group_names.has_key(task):
                         taskname = apt_group_names[task]

summary: - Missing libgnome.so library / package dependency
+ apt_pkg.ParseTagFile has been replaced by apt_pkg.TagFile, breaks
+ system-config-kickstart
Revision history for this message
polikarpa (polikarpaxxxx) wrote :

I have the same problem in Kubuntu 13.10.
I don't uderstand how to enter the proposed solution...

Revision history for this message
PC_THE_GREAT (pcthegreat) wrote :

polikarpa, download the attached patch and do the following

sudo patch -b -p1 <sck_pkgGL_Patch

When asked for file to patch give this:
File to patch: /usr/share/system-config-kickstart/packageGroupList.py

This fix has been found by Surfraz Ahmed (surfraz), in no way am I taking credits for this, i created a patch file so as others can understand how to patch this.

+selven

Changed in system-config-kickstart (Ubuntu):
assignee: nobody → PC_THE_GREAT (pcthegreat)
assignee: PC_THE_GREAT (pcthegreat) → nobody
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "sck_pkgGL_Patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in system-config-kickstart (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-kickstart - 2.5.20-0ubuntu23

---------------
system-config-kickstart (2.5.20-0ubuntu23) trusty; urgency=low

  * packageGroupList.py: update for changes in ParseTagFile of apt_pkg.
    Thanks to Surfraz Ahmed for the patch. (LP: #1236315)
 -- Brian Murray <email address hidden> Wed, 11 Dec 2013 15:31:52 -0800

Changed in system-config-kickstart (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Vikas Kumar (vikas027) wrote :

This bug still exists even in 13.04 desktop 64 Bit release. The patch provided by PC_THE_GREAT (pcthegreat) fixed my problem too. My .py file was different than OP's.

Regards,
Vikas

Revision history for this message
Vikas Kumar (vikas027) wrote :

I am quite disappointed to say that the bug is still now fixed in 14.04 release. This patch does not fixes the issue in this release.

Please find the attached screenshot of the error. Any suggestion to resolve this ?

Regards,
Vikas

Revision history for this message
Brian Murray (brian-murray) wrote :

The error from comment #9 is actually bug 1260107.

Revision history for this message
S. (swolfe100) wrote :

I ran into this as well..

Another site suggested this from debian which works.
# apt-get remove hwdata
# wget ftp://mirror.ovh.net/mirrors/ftp.debian.org/debian/pool/main/h/hwdata/hwdata_0.234-1_all.deb
# dpkg -i hwdata_0.234-1_all.deb
# apt-get install system-config-kickstart
http://www.linuxquestions.org/questions/ubuntu-63/system-config-kickstart-not-working-in-ubuntu-14-04-a-4175502357/

Revision history for this message
Jens Elkner (jelmd) wrote :

Doesn't work. I'm still getting:

(system-config-kickstart.py:15210): libglade-WARNING **: Could not load support for `gnome': libgnome.so: cannot open shared object file: No such file or directory

on trusty.

Revision history for this message
Tony Wolf (5-iwfo-m) wrote :

@Jens Elkner:

You need to install libgnomeui-0 additionaly.

Kind regards
Tony

Revision history for this message
Jens Elkner (jelmd) wrote :

Thanx, I kicked it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers