Sysprof support suboptimal

Bug #30160 reported by Sven Herzberg on 2006-01-31
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
sysprof (Debian)
Fix Released
Unknown
sysprof (Ubuntu)
Wishlist
Unassigned

Bug Description

It would be nice if ubuntu would provide sysprof module package at least for the kernel ubuntu gets delivered with. I's very annoying for a "user" to build the module every time again, just because the ubuntu linux image got updated.

Mark Howard (mh-tildemh) wrote :

Or as a possible compromise it would be nice if the gui could inform the user how to build the package on Ubuntu or even build and install it automatically after a prompt.

Vassilis Pandis (pandisv) wrote :

I second Sven's request. It would be nice if sysprof worked out of the box.

Changed in sysprof:
status: Unconfirmed → Confirmed
Murray Cumming (murrayc) wrote :

If there's some reason that the kernel module must be supplied only as source, it would be nice to see that reason in the package description.

How to build the kernel module would be nice!

Sven Herzberg (herzi) wrote :

less /usr/share/doc/sysprof-module-source/README.Debian

Daniel Hahler (blueyed) on 2008-01-23
Changed in sysprof:
status: Confirmed → Triaged
Daniel Hahler (blueyed) wrote :

I've addressed this bug also in the debdiff for bug 46224, by making the error a lot more verbose and giving instructions to build the module.

It adds the following at the end of the current "modprobe sysprof-module" message:
++ "You may need to build and install this module first:\n"
++ " 1. Install the package sysprof-module-source\n"
++ " 2. Execute \"m-a a-i sysprof-module\" as root\n"
++ " 3. Load the module as described above\n"
++ " 4. Restart sysprof\n"
++ "See also /usr/share/doc/sysprof-module-source/README.Debian" );

Changed in sysprof:
status: Unknown → New
Changed in sysprof:
status: New → Fix Released

Thanks Daniel for those nice instructions. I think it is also a good idea to put that in the error.

Ed (e-sanville) wrote :

I've tried following thos instructions, and I can't build this kernel module. It says:

"/usr/bin/make KVERS=2.6.27-7-generic KDIR=/usr/src/linux-headers-2.6.27-7-generic/bin/sh: 2.6.27-7-generic: not found
/usr/bin/make -C /usr/src/linux-headers-2.6.27-7-generic SUBDIRS=/usr/src/modules/sysprof-module modules
..."

I really want to do some profiling, and this program looked decent. Oh well...

Ed (e-sanville) wrote :

Sorry, here's my log file.

Daniel Hahler (blueyed) wrote :

Ed, what looks wrong is "/bin/sh: 2.6.27-7-generic: not found"..
I could not reproduce it (on Ubuntu Jaunty) (but don't know where the buildlogs are, to verify it).
However, it's another problem (since the instructions should work normally). Can you please file a new bug for it (against sysprof and subscribe me)?

btw: the improved error message has been accepted by Debian and therefore is in Ubuntu now, too.

Can this bug be closed? I think what really would be nice to have the module automatically being build using DKMS (and therefore the bug should stay open)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.