Newer USB Startup Disks unbootable when created using Karmic 9.10

Bug #660061 reported by Tommy Trussell on 2010-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-creator
New
Undecided
Unassigned
syslinux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: syslinux

I had trouble making USB or SD card images of the netbook releases that would boot my Asus Eee900 netbook. It would say "unknown keyword" and hang at the "boot:" prompt.

 I found two techniques that worked, and I know there are other open bugs I'm reporting this as a separate bug because it might help people resolve the regression.

This is the same or similar behavior noted in launchpad Question #113145 and Bug #608382 and Bug #615676 maybe Bug #645818 and Bug #617779 and maybe others. I also found it in this forum post: http://ubuntuforums.org/showthread.php?p=9965992

I found two different solutions: http://www.khattam.info/solved-syslinux-unknown-keyword-in-configuration-file-2010-09-01.html and http://trentscott.com/2010/10/07/fixing-usb-install-issues-with-ubuntu-10-10-maverick-meerkat/ (In case those links are broken, the first link says to replace the stock Ubuntu syslinux with version 4.01 and the second says to mount the USB image and edit the file /syslinux/syslinux.cfg to remove the "ui" keyword from the beginning of the last line.) I tried each of the solutions, and was able to boot my ASUS using either technique.

I am running Ubuntu 9.10 (i386). This release uses syslinux 2:3.63+dfsg-2ubuntu3. I downloaded the two syslinux 4.01 .debs from http://mirrors.kernel.org/ubuntu/pool/main/s/syslinux/

When I use USB Startup Disk Creator under Ubuntu 9.10 to create netbook USB images for my Asus EeePC 900, here is what I find:

syslinux 3.63+Ubuntu 10.04 netbook: boots fine
syslinux 3.63+Ubuntu 10.10 netbook: reports unknown keyword and hangs at "boot:"
syslinux 3.63+Ubuntu 10.10 netbook+edit syslinux.cfg: boots fine
syslinux 4.01+Ubuntu 10.10 netbook: boots fine

(I just reverted my syslinux to the stock version and re-created the 10.04 netbook image to verify that this isn't something that has changed on my 9.10 system since the release of 10.04 when I originally created the netbook image. The re-installed syslinux 3.63 + 10.04 still boots fine.)

HankB (hbarta) wrote :

I'm encountering what looks like the same problem trying to install ubuntu-10.04.2-desktop-i386.iso from a USB drive created using the System -> Administration -> Startup Disk Creator (on a 10.10 host.)

I first get the "Unknown keyword in configuration file: gfxboot"
and then repeated:
=======
vesamenu.c32: not a CPOM32R image
boot:
=======
(This stuff between "======" repeated ad nauseum every 5 seconds.

Incidentally, both links above to possible solutions are 404.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers