extlinux broken in ubuntu

Bug #1579391 reported by Tong Sun on 2016-05-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
syslinux (Ubuntu)
Undecided
Unassigned

Bug Description

The extlinux under Ubuntu has been broken since Vivid, and it is still not fixed in Ubuntu 16.04 LTS Xenial.

What I got:

In Vivid, having installed extlinux, I still don't have the extlinux.conf configuration file, so I do it manually again:

% extlinux --install /boot/extlinux
/boot/extlinux is device /dev/sda7

% dir -l /boot/extlinux
total 116
-r--r--r-- 1 root root 116632 May 1 21:21 ldlinux.c32

What is expected:

According to the official doc at http://www.syslinux.org/wiki/index.php/EXTLINUX,
"extlinux --update /boot/extlinux" will
generate extlinux.conf under /boot/extlinux, and it has always been working like that before, until I'm testing it under Vivid.

In Xenial, things are still the same:

% apt-get install extlinux syslinux-common
Get:1 http://archive.ubuntu.com/ubuntu xenial/universe amd64 extlinux amd64 3:6.03+dfsg-11ubuntu1 [130 kB]
...
Get:5 http://archive.ubuntu.com/ubuntu xenial/main amd64 syslinux-common all 3:6.03+dfsg-11ubuntu1 [1,181 kB]
...
Preparing to unpack .../extlinux_3%3a6.03+dfsg-11ubuntu1_amd64.deb ...
Unpacking extlinux (3:6.03+dfsg-11ubuntu1) ...
Preparing to unpack .../syslinux-common_3%3a6.03+dfsg-11ubuntu1_all.deb ...
Unpacking syslinux-common (3:6.03+dfsg-11ubuntu1) ...
...
Setting up extlinux (3:6.03+dfsg-11ubuntu1) ...
Setting up syslinux-common (3:6.03+dfsg-11ubuntu1) ...
...

% ls -l /boot/vmlinuz* /boot/initrd* /boot/extlinux/*.conf /boot/extlinux/*.cfg
ls: cannot access '/boot/vmlinuz*': No such file or directory
ls: cannot access '/boot/extlinux/*.conf': No such file or directory
ls: cannot access '/boot/extlinux/*.cfg': No such file or directory
-rw-r--r-- 1 root root 37950863 May 7 14:58 /boot/initrd.img-4.4.0-21-generic

I had been able to workaround the problem by installing the working extlinux packages from Ubuntu in Vivid,

But since the extlinux package is reintroduced in Xenial again, I kept getting prompted to upgrade it, thus it is more of a issue now.

Tong Sun (suntong001) on 2016-05-07
description: updated
description: updated
Tong Sun (suntong001) on 2016-05-07
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in syslinux (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers