Xenial Server daily ISO boot in text mode interface isn't working - kind of loop

Bug #1537252 reported by Thiago Martins
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
syslinux (Ubuntu)
Triaged
High
Unassigned

Bug Description

Guys,

 It is not possible to use the textmode with latest Xenial ISO...

 Steps to reproduce:

 1- Download it:

 cd ~ ; wget http://cdimage.ubuntu.com/ubuntu-server/daily/current/xenial-server-amd64.iso;

 2- Boot it by running: kvm -cdrom ~/xenial-server-amd64.iso -m 1024 ;

 3- Wait for first screen, the one you choose your language, then, hit ESC;

 4- Press ESC again, to leave graphical boot menu;

 5- Hit "OK" button, to enter text interface;

 6- At "boot:" prompt, type something...

 7- Hit ENTER;

 8- BOOM! It goes back to graphical boot menu! Where it should
accepted the commands you typed on step 6...

 Ubuntu 14.04 behaves differently, it accepts the command and boot proceeds.

 This problem is specially bad for automating Ubuntu builds when using
Packer, for example, if you take a look here:

 https://github.com/thasmo/packer.templates/blob/master/template/ubuntu-14.04.json

 ...at line 27, it works like a charm but, if you update this
ubuntu-14.04.json file to, lets say, "ubuntu-16.04.json", then, it
will not work!

 Because Packer "types" commands via VNC automatically, and it "hit"
ENTER in the end (line 27), which doesn't work and it goes back to
graphical boot menu... :-/

After researching a bit on this problem, I think that it is a syslinux bug, or something around it, so, I'm opening it here...

Thanks!
Thiago

Revision history for this message
Diogo Matsubara (matsubara) wrote :

Hi Thiago,

thanks for the bug report. I was able to reproduce the issue as you described. I'm confirming the bug and asked one of the core ubuntu developers to set the importance appropriately.

Changed in syslinux (Ubuntu):
status: New → Confirmed
Robie Basak (racb)
Changed in syslinux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
milestone: none → ubuntu-16.04
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers