"boot error" due to gcc v5 transition

Bug #1507002 reported by Luis Mondesi on 2015-10-16
284
This bug affects 121 people
Affects Status Importance Assigned to Milestone
syslinux (Debian)
Fix Released
Unknown
syslinux (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

Today I upgraded to Ubuntu 15.10 (wily) from vivid and creating boot disks (USB, vfat) stopped working.

I tried my best to find what's the problem, but I couldn't identify it. It looks like it's related to LP: #398241 (or the debian bug referred there)

Essentially, I did

1. create empty USB disk
2. format as vfat (mkfs -t ... -- -F32 -n 'label')
3. syslinux --install path/to/image -t 512
4. boot a computer with it
5. SYSLINUX 6.03 ... "boot error" <-- is displayed

I then downgraded to syslinux 3:6.03+dfsg-5ubuntu1, did the same thing, and it worked again.

I believe this is related to ldlinux.sys, ldlinux.c32, linux.c32, menu.c32, or libutil.c32, since at least the machine boots to syslinux, it simply does not proceed to display my menu.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in syslinux (Ubuntu):
status: New → Confirmed
EricDHH (ericdhh) wrote :

Same result with ustudio wily amd64

Dwight Schauer (dschauer) wrote :

Same failure with Xenial amd64.

Dwight Schauer (dschauer) wrote :

Well, as a work around for now I'm using extlinux and syslinux-common 6.03+dfs-11 from debian.

They are working as expected.

http://http.us.debian.org/debian/pool/main/s/syslinux/extlinux_6.03+dfsg-11_amd64.deb
http://http.us.debian.org/debian/pool/main/s/syslinux/syslinux-common_6.03+dfsg-11_all.deb

Dwight Schauer (dschauer) wrote :

I'm using extlinux rather than syslinux, but I get "boot error" with the ubuntu packages.

TJ (tj) on 2015-11-24
Changed in syslinux (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Critical
assignee: nobody → TJ (tj)
summary: - "boot error" is back!
+ "boot error" due to gcc v5 transition
TJ (tj) wrote :

I've tested with the upstream ALIGN fix and images that previously failed with "Boot error" now boot correctly
The upstream fix is:

commit e5f2b577ded109291c9632dacb6eaa621d8a59fe
Author: Sylvain Gault <email address hidden>
Date: Tue Sep 29 02:38:25 2015 +0200

    bios: Fix alignment change with gcc 5

    The section aligment specified in the ld scripts have to be greater or
    equal to those in the .o files generated by gcc.

    Signed-off-by: Sylvain Gault <email address hidden>
    Tested-by: poma <email address hidden>
    Signed-off-by: Paulo Alcantara <email address hidden>

Changed in syslinux (Ubuntu):
assignee: TJ (tj) → nobody
status: In Progress → Triaged
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1507002

tags: added: iso-testing
TJ (tj) wrote :

The attachment "debdiff adding commit e5f2b577ded" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Ilan Tal (ilan-tal) wrote :

Working with Philip we narrowed down the problem to Startup Disk Creator

https://bugs.launchpad.net/bugs/1512811

Using dd to make the stick solved the problem. Startup disk creator isn't writing the stick correctly but just for the 32 bit version. The 64 bit version works fine. Philip marked it as a duplicate of a bug which was resolved. The problem is that the resolve worked only for 64 bit and not for 32.

Ilan Tal (ilan-tal) wrote :

There is an additional problem with the Startup disk creator. In checking for my boot error problem I considered the remote possibility that something was wrong with the 32 bit iso file. To answer the question I downloaded Xubuntu 32 bit iso file and used Startup disk creator to write it to the usb stick.

This morning I discovered that when I plugged the stick into the usb connector there was no response at all. The system didn't know that any stick was there. In /media/ilan nothing was listed. I thought the stick was damaged and I could use the guarantee, as it wasn't visible in Windows either.

Before claiming the guarantee I had to check that it was really dead. I tried Startup disk creator and that saw the stick but gave me error messages when I tried to erase it. Then I tried partition editor which also saw it. With partition editor I deleted whatever was left of the partition and created a new partition table. That fixed the problem.

So Startup disk creator did something very nasty to the stick which may well explain why it wouldn't boot.

sudodus (nio-wiklund) wrote :

The Startup Disk Creator suffers from several bugs. You have found (maybe) two of them.

dd has been mentioned in this bug report. It is cloning - a very straight-forward process, but dd does what you tell it to do without questions - even if you tell it to wipe the family pictures. I made a tool to wrap a safety belt around dd, mkusb.

There is a project, where the Startup Disk Creator will be radically changed - the intention is that it will also use dd under the hood.

sudodus (nio-wiklund) wrote :

Edit: ... or do the corresponding cloning as done by dd.

tags: added: regression-release wily xenial
TJ (tj) wrote :

I have the 15.10 syslinux package in a PPA for testing:

https://launchpad.net/~tj/+archive/ubuntu/bugfixes

Ilan Tal (ilan-tal) wrote :

TJ,
I tried your bugfixes and find no change. Startup Disk Creator continues with the boot error and dd continues to work correctly.
I don't know if your bugfixes are supposed to have a fix for Startup Disk Creator, but I see no change.

Changed in syslinux (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

yesterday , i have upgraded ubuntu 15.04 to 15.10.
and try to create a USB boot from ubuntu-15.10-server-amd64.iso

when i try to boot from that usb i got this error

attempting Boot From usb device
SYSLINUX 6.03 EDD 20150813 Copyright (C) 1994-2014 H. Peter Anvin et al Boot error

Jose Barakat (josebarakat) wrote :

The workaround described by dragon2fly at AskUbuntu (http://askubuntu.com/questions/696797/boot-error-on-live-usb-flash-drive-with-15-10) works perfect in Ubuntu 15.10. Unfortunately, the bug is still alive.

Hi Jose,
Many times I did a usb flash drive boot for 15.10, 64 bit. Only for 15.10
was there a problem. Using dd in place of startup disk creator solved the
problem. So I can't confirm what is said on Ask Ubuntu. There however
nobody seemed to try dd.

Ilan

On Sun, Dec 20, 2015 at 8:49 PM, Jose Barakat <email address hidden> wrote:

> The workaround described by dragon2fly at AskUbuntu
> (http://askubuntu.com/questions/696797/boot-error-on-live-usb-flash-
> drive-with-15-10) works perfect in Ubuntu 15.10. Unfortunately, the bug
> is still alive.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1512811).
> https://bugs.launchpad.net/bugs/1507002
>
> Title:
> "boot error" due to gcc v5 transition
>
> Status in syslinux package in Ubuntu:
> Triaged
>
> Bug description:
> Today I upgraded to Ubuntu 15.10 (wily) from vivid and creating boot
> disks (USB, vfat) stopped working.
>
> I tried my best to find what's the problem, but I couldn't identify
> it. It looks like it's related to LP: #398241 (or the debian bug
> referred there)
>
> Essentially, I did
>
> 1. create empty USB disk
> 2. format as vfat (mkfs -t ... -- -F32 -n 'label')
> 3. syslinux --install path/to/image -t 512
> 4. boot a computer with it
> 5. SYSLINUX 6.03 ... "boot error" <-- is displayed
>
> I then downgraded to syslinux 3:6.03+dfsg-5ubuntu1, did the same
> thing, and it worked again.
>
> I believe this is related to ldlinux.sys, ldlinux.c32, linux.c32,
> menu.c32, or libutil.c32, since at least the machine boots to
> syslinux, it simply does not proceed to display my menu.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1507002/+subscriptions
>

sudodus (nio-wiklund) wrote :

A new version of the Ubuntu Startup Disk Creator is released in the developing version of Ubuntu, Xenial Xerus.

That version is neither affected by this bug, nor by other old bugs, and the intention is to do some basic debugging and testing, and after that I hope it can be back-ported into previous versions of Ubuntu and the Ubuntu flavours (Kubuntu, Lubuntu ... Xubuntu).

Until then you can use some other tool to create USB boot drives, for example mkusb, which 'wraps a safety belt around dd',

https://help.ubuntu.com/community/mkusb

JoLa (josef-latt) wrote :

I installed usb-creator-gtk and usb-creator-common from xenial-packages in Ubuntu 15.10. Creating the usb boot drives is successful.

Ilan Tal (ilan-tal) wrote :

Be sure to try it both for 64 bit and for 32 bit. The original startup disk
creator worked for me on 64 bit and failed for 32 bit.

On Mon, Dec 21, 2015 at 9:54 AM, JoLa <email address hidden> wrote:

> I installed usb-creator-gtk and usb-creator-common from xenial-packages
> in Ubuntu 15.10. Creating the usb boot drives is successful.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1512811).
> https://bugs.launchpad.net/bugs/1507002
>
> Title:
> "boot error" due to gcc v5 transition
>
> Status in syslinux package in Ubuntu:
> Triaged
>
> Bug description:
> Today I upgraded to Ubuntu 15.10 (wily) from vivid and creating boot
> disks (USB, vfat) stopped working.
>
> I tried my best to find what's the problem, but I couldn't identify
> it. It looks like it's related to LP: #398241 (or the debian bug
> referred there)
>
> Essentially, I did
>
> 1. create empty USB disk
> 2. format as vfat (mkfs -t ... -- -F32 -n 'label')
> 3. syslinux --install path/to/image -t 512
> 4. boot a computer with it
> 5. SYSLINUX 6.03 ... "boot error" <-- is displayed
>
> I then downgraded to syslinux 3:6.03+dfsg-5ubuntu1, did the same
> thing, and it worked again.
>
> I believe this is related to ldlinux.sys, ldlinux.c32, linux.c32,
> menu.c32, or libutil.c32, since at least the machine boots to
> syslinux, it simply does not proceed to display my menu.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1507002/+subscriptions
>

JoLa (josef-latt) wrote :

Sorry, I forgot. My Ubuntu is 64 bit.

BTW, do you mean with original the version from ubuntu 15.10 (0.2.67). If so, this version failed.

Ilan Tal (ilan-tal) wrote :

I no longer remember the exact version. I tried it for several versions of
15.10 and none of them worked for 32 bit.
My machine is also 64 bit but I wanted to install Ubuntu on a friend's
machine with 2GB, so I downloaded the 32 iso file and burned it.
The 32 bit iso failed every time with every usb stick I tried. dd always
worked, so that is what I used to do the job.
(Likewise the Xubuntu iso failed for 32 bit.)

On Mon, Dec 21, 2015 at 11:01 AM, JoLa <email address hidden> wrote:

> Sorry, I forgot. My Ubuntu is 64 bit.
>
> BTW, do you mean with original the version from ubuntu 15.10 (0.2.67).
> If so, this version failed.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1512811).
> https://bugs.launchpad.net/bugs/1507002
>
> Title:
> "boot error" due to gcc v5 transition
>
> Status in syslinux package in Ubuntu:
> Triaged
>
> Bug description:
> Today I upgraded to Ubuntu 15.10 (wily) from vivid and creating boot
> disks (USB, vfat) stopped working.
>
> I tried my best to find what's the problem, but I couldn't identify
> it. It looks like it's related to LP: #398241 (or the debian bug
> referred there)
>
> Essentially, I did
>
> 1. create empty USB disk
> 2. format as vfat (mkfs -t ... -- -F32 -n 'label')
> 3. syslinux --install path/to/image -t 512
> 4. boot a computer with it
> 5. SYSLINUX 6.03 ... "boot error" <-- is displayed
>
> I then downgraded to syslinux 3:6.03+dfsg-5ubuntu1, did the same
> thing, and it worked again.
>
> I believe this is related to ldlinux.sys, ldlinux.c32, linux.c32,
> menu.c32, or libutil.c32, since at least the machine boots to
> syslinux, it simply does not proceed to display my menu.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1507002/+subscriptions
>

Michael Terry (mterry) wrote :

So this original bug report was about syslinux. There are also a bunch comments here about a bug with Startup Disk Creator. But which is separately fixed?

However, the original syslinux bug still exists as far as I can tell. And there's an upstream patch in comment #8. So I've merged from Debian, applied this patch on top, and uploaded to xenial. Thanks TJ for your work surfacing that patch!

Ilan Tal (ilan-tal) wrote :

The problem would come up after I would burn a 32 bit iso using Startup
Disk Creator.
The usb stick with the 32 bit iso would never boot into the state where I
could "Try Ubuntu".
With dd the problem was solved. I could "Try Ubuntu" and/or "Install
Ubuntu".
Is there perhaps a way to compare 2 usb sticks, byte by byte, to see the
difference between the output of Startup Disk Creator and dd?
(Use a 32 bit iso.)

On Tue, Dec 22, 2015 at 9:51 PM, Michael Terry <email address hidden>
wrote:

> So this original bug report was about syslinux. There are also a bunch
> comments here about a bug with Startup Disk Creator. But which is
> separately fixed?
>
> However, the original syslinux bug still exists as far as I can tell.
> And there's an upstream patch in comment #8. So I've merged from
> Debian, applied this patch on top, and uploaded to xenial. Thanks TJ
> for your work surfacing that patch!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1512811).
> https://bugs.launchpad.net/bugs/1507002
>
> Title:
> "boot error" due to gcc v5 transition
>
> Status in syslinux package in Ubuntu:
> Triaged
>
> Bug description:
> Today I upgraded to Ubuntu 15.10 (wily) from vivid and creating boot
> disks (USB, vfat) stopped working.
>
> I tried my best to find what's the problem, but I couldn't identify
> it. It looks like it's related to LP: #398241 (or the debian bug
> referred there)
>
> Essentially, I did
>
> 1. create empty USB disk
> 2. format as vfat (mkfs -t ... -- -F32 -n 'label')
> 3. syslinux --install path/to/image -t 512
> 4. boot a computer with it
> 5. SYSLINUX 6.03 ... "boot error" <-- is displayed
>
> I then downgraded to syslinux 3:6.03+dfsg-5ubuntu1, did the same
> thing, and it worked again.
>
> I believe this is related to ldlinux.sys, ldlinux.c32, linux.c32,
> menu.c32, or libutil.c32, since at least the machine boots to
> syslinux, it simply does not proceed to display my menu.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1507002/+subscriptions
>

I can confirm the bug: USB thumbdrives created by the "Startup Disk Creator" do not boot [1] but USB thumbdrives created by mkusb [2] work.

[1] https://bugs.launchpad.net/bugs/1499746

[2] https://help.ubuntu.com/community/mkusb

Ilan Tal (ilan-tal) wrote :

Thanks Arne,
Now that there is a GUI wrapper on dd, there doesn't seem to be any reason
at all to use startup disk creator.

On Mon, Feb 1, 2016 at 11:35 PM, Arne Henningsen <email address hidden>
wrote:

> I can confirm the bug: USB thumbdrives created by the "Startup Disk
> Creator" do not boot [1] but USB thumbdrives created by mkusb [2] work.
>
> [1] https://bugs.launchpad.net/bugs/1499746
>
> [2] https://help.ubuntu.com/community/mkusb
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1512811).
> https://bugs.launchpad.net/bugs/1507002
>
> Title:
> "boot error" due to gcc v5 transition
>
> Status in syslinux package in Ubuntu:
> Triaged
>
> Bug description:
> Today I upgraded to Ubuntu 15.10 (wily) from vivid and creating boot
> disks (USB, vfat) stopped working.
>
> I tried my best to find what's the problem, but I couldn't identify
> it. It looks like it's related to LP: #398241 (or the debian bug
> referred there)
>
> Essentially, I did
>
> 1. create empty USB disk
> 2. format as vfat (mkfs -t ... -- -F32 -n 'label')
> 3. syslinux --install path/to/image -t 512
> 4. boot a computer with it
> 5. SYSLINUX 6.03 ... "boot error" <-- is displayed
>
> I then downgraded to syslinux 3:6.03+dfsg-5ubuntu1, did the same
> thing, and it worked again.
>
> I believe this is related to ldlinux.sys, ldlinux.c32, linux.c32,
> menu.c32, or libutil.c32, since at least the machine boots to
> syslinux, it simply does not proceed to display my menu.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1507002/+subscriptions
>

vedavata (vedavrata) wrote :

   I had the same problem (error),
 when i tried "Startup Disk Creator" (Xubuntu 15.10).
   And 'gnome-disks' (the package 'gnome-disk-utility') helped me:
# apt-cache search gnome-disk
gnome-disk-utility - manage and configure disk drives and media
# which gnome-disks
/usr/bin/gnome-disks
 Use the "Restore Disk Image..." from a disk Menu.

JoLa (josef-latt) wrote :

Using gnome-disk-utility happens only on a stick which was formerly not used with dd and applications based on dd. In this case you must create a new partition table and a new partition with gparted. Any messages concerning sector size must be ignored.

With nautilus (Ubuntu 15.10) you open open the contect menu of the iso-File and select 'Write disc images' or so (I use a German Ubuntu) .

vedavata (vedavrata) wrote :

"""Using gnome-disk-utility happens only on a stick which was formerly not used with dd and applications based on dd. In this case you must create a new partition table and a new partition with gparted.""" -- Yes, you are right. Thank you for refinement!

"""With nautilus (Ubuntu 15.10), open the context menu of the iso-file and select 'Write disc images...'""" -- In Thunar (File Manager of Xubuntu) there is the same option in the context menu of a ISO-file . And even in krusader as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package syslinux - 3:6.03+dfsg-11ubuntu1

---------------
syslinux (3:6.03+dfsg-11ubuntu1) xenial; urgency=low

  [ Michael Terry ]
  * Merge from Debian unstable. Remaining changes:
    - debian/control: build with default gcc, not gcc-4.9

  [ TJ <email address hidden> ]
  * d/p/0008-Fix-gcc-5-ALIGN-causing-Boot-error.patch:
    - Backport fix for gcc 5 ALIGN changes. (LP: #1507002)

syslinux (3:6.03+dfsg-11) unstable; urgency=low

  * Orphaning package.

syslinux (3:6.03+dfsg-10) unstable; urgency=medium

  * Building with gcc-4.9 (Closes: #795777).

syslinux (3:6.03+dfsg-9) unstable; urgency=low

  * Adding patch from upstream to fix unbootable images in certain
    conditions, e.g. when using gcc 5 (Closes: #795596).

 -- Michael Terry <email address hidden> Tue, 22 Dec 2015 14:19:58 -0500

Changed in syslinux (Ubuntu):
status: Triaged → Fix Released
Cusiri (idavalosr) wrote :

Hi all,

I got the same problem in system Live with lubuntu 15.10 x64
systemback
1.8.201_03.10.2016_Qt5.4.2_GCC5.2.1_amd64
----------------------------

Comment #16
------------------
thaniyarasu (thaniyarasu-gmail) wrote on 2015-12-14: #16

yesterday , i have upgraded ubuntu 15.04 to 15.10.
and try to create a USB boot from ubuntu-15.10-server-amd64.iso

when i try to boot from that usb i got this error

attempting Boot From usb device
SYSLINUX 6.03 EDD 20150813 Copyright (C) 1994-2014 H. Peter Anvin et al Boot error

------------------

Lawrence Emke (lawrence-emke) wrote :

If this is fixed and released, I did not get it. I did a "sudo apt-get update" and then ran SDC again, and I received the same boot error. I have also tried uNetBootIn. It made no difference. I tried to install a previous syslinux version, per one of the suggested fixes, but the package is no longer available. I am stuck.

Kendek (nemh) wrote :

This problem is fixed in the version 6.03+dfsg-11ubuntu1, see the changelog:
http://changelogs.ubuntu.com/changelogs/pool/main/s/syslinux/syslinux_6.03+dfsg-11ubuntu1/changelog

The new version is working well on the Ubuntu 16.04 LTS, but the available version in the 15.10 (-8ubuntu2) is still broken:
http://packages.ubuntu.com/wily/syslinux

So the Syslinux on the Ubuntu 15.10 is not fixed! If you want just install the packages from here:
http://packages.ubuntu.com/xenial/syslinux
http://packages.ubuntu.com/xenial/syslinux-common

sudo dpkg -i *.deb

Lawrence Emke (lawrence-emke) wrote :

Thanks I will try it out
On Apr 14, 2016 16:46, "Kendek" <email address hidden> wrote:

> This problem is fixed in the version 6.03+dfsg-11ubuntu1, see the
> changelog:
>
> http://changelogs.ubuntu.com/changelogs/pool/main/s/syslinux/syslinux_6.03+dfsg-11ubuntu1/changelog
>
> The new version is working well on the Ubuntu 16.04 LTS, but the available
> version in the 15.10 (-8ubuntu2) is still broken:
> http://packages.ubuntu.com/wily/syslinux
>
> So the Syslinux on the Ubuntu 15.10 is not fixed! If you want just install
> the packages from here:
> http://packages.ubuntu.com/xenial/syslinux
> http://packages.ubuntu.com/xenial/syslinux-common
>
> sudo dpkg -i *.deb
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1507002
>
> Title:
> "boot error" due to gcc v5 transition
>
> Status in syslinux package in Ubuntu:
> Fix Released
>
> Bug description:
> Today I upgraded to Ubuntu 15.10 (wily) from vivid and creating boot
> disks (USB, vfat) stopped working.
>
> I tried my best to find what's the problem, but I couldn't identify
> it. It looks like it's related to LP: #398241 (or the debian bug
> referred there)
>
> Essentially, I did
>
> 1. create empty USB disk
> 2. format as vfat (mkfs -t ... -- -F32 -n 'label')
> 3. syslinux --install path/to/image -t 512
> 4. boot a computer with it
> 5. SYSLINUX 6.03 ... "boot error" <-- is displayed
>
> I then downgraded to syslinux 3:6.03+dfsg-5ubuntu1, did the same
> thing, and it worked again.
>
> I believe this is related to ldlinux.sys, ldlinux.c32, linux.c32,
> menu.c32, or libutil.c32, since at least the machine boots to
> syslinux, it simply does not proceed to display my menu.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1507002/+subscriptions
>

Changed in syslinux (Debian):
status: Unknown → New
Changed in syslinux (Debian):
status: New → Fix Released
Erik Leitner (erik-leitner) wrote :

also affected (on Kubuntu 15.10 64bit create live usb stick via usb-creator-kde/SDC for 16.04.01 64bit -> stick will only start in UEFI mode but in legacy BIOS will stop with syslinux boot error)
#34 install xenial packages on 15.10 helps
Thanks a lot !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.