extlinux-update sorts kernels in the wrong order due to not using sort -Vr, fixed upstream

Bug #1383318 reported by Carey Underwood on 2014-10-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
syslinux
Fix Released
Unknown
syslinux (Debian)
Fix Released
Unknown
syslinux (Ubuntu)
Undecided
Unassigned

Bug Description

extlinux-update contains the line _VERSIONS="$(cd /boot && ls vmlinuz-* | grep -v .dpkg-tmp | sed -e 's|vmlinuz-||g' | sort -nr)", which attempts to sort on version numbers numerically. The problem is that in kernel version numbers, 3.10 comes after 3.9, while sort -n will sort it before (as 3.10 is numerically lower than 3.90 or 3.9).

Debian has already fixed it to use the version sort (sort -Vr).

I think this is worth an SRU as it causes 3.10+ kernels to not be booted while any 3.2-3.9 kernels are installed.

Changed in syslinux (Debian):
status: Unknown → Fix Released
Changed in syslinux:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.