syslinux should be built using gcc-4.7 again

Bug #1127462 reported by Matthias Klose on 2013-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
syslinux (Ubuntu)
High
Colin Watson

Bug Description

according to http://bugs.debian.org/672520, syslinux is built using gcc-4.6 because an early miscompilation issue in gcc-4.7. Please recheck if this is still the case for raring, and if not, build-depend on gcc-4.7 or the default GCC, so that we can demote gcc-4.6.

  Matthias

Related branches

Matthias Klose (doko) on 2013-02-16
Changed in syslinux (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-13.04-beta-1
status: New → Confirmed
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Colin Watson (cjwatson) wrote :

It's still broken in the same way.

Colin Watson (cjwatson) on 2013-02-18
Changed in syslinux (Ubuntu):
assignee: Canonical Kernel Team (canonical-kernel-team) → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package syslinux - 3:4.05+dfsg-6+deb7u2ubuntu1

---------------
syslinux (3:4.05+dfsg-6+deb7u2ubuntu1) raring; urgency=low

  * Backport from upstream:
    - Handle constructors/destructors via .init_array and .fini_array, as
      generated by newer gccs.
  * Stop forcing the use of gcc-4.6, since the above backport allows the use
    of gcc-4.7 (LP: #1127462).
 -- Colin Watson <email address hidden> Mon, 18 Feb 2013 13:09:22 +0000

Changed in syslinux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers