Nodes fail to boot from local disk on raring

Bug #1092265 reported by Diogo Matsubara on 2012-12-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Andres Rodriguez
syslinux (Ubuntu)
Critical
Unassigned

Bug Description

The CI tests running on a raring VM using the latest raring package from the dailybuilds (PPA 0.1+bzr1406+dfsg-0+1406+161~ppa0~raring1) and juju (0.6-1ubuntu1) fail during juju bootstrap[1].
The bootstrapped node installs fine but when it reboots, it fails to boot[2].

[1] https://jenkins.qa.ubuntu.com/view/Maas/job/raring-adt-maas-daily/80/ARCH=amd64,label=lenovo-RD230-01/console
[2] http://people.canonical.com/~rvb/raring_error.png

Related branches

Diogo Matsubara (matsubara) wrote :
Diogo Matsubara (matsubara) wrote :
Changed in maas:
status: New → Triaged
importance: Undecided → Critical
tags: added: rarig
tags: added: raring
removed: rarig
Raphaël Badin (rvb) wrote :

Looks like the problem comes from the chain.c32 file in raring: if I replace the file chain.c32 (/var/lib/maas/tftp/chain.c32) with the one from the syslinux package on *quantal* (/usr/lib/syslinux/chain.c32), the boot seems to work.

Raphaël Badin (rvb) wrote :

Quantal contains syslinux-common version 2:4.05+dfsg-6 and Raring has the version 2:4.06+dfsg-3.
The changes between these two versions are: http://paste.ubuntu.com/1491622/

summary: - juju setup fails on raring
+ Nodes fail to boot from local disk on raring
Raphaël Badin (rvb) wrote :

Confirmed, I kicked off a test run, copied over chain.c32 from quantal onto the raring MAAS server, and got all the integration tests to pass (https://jenkins.qa.ubuntu.com/view/Maas/job/raring-adt-maas-daily/6/ARCH=amd64,label=lenovo-RD230-01/console).

Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
Raphaël Badin (rvb) wrote :

fwiw, here is the pxe config used when nodes are supposed to boot from local disk: http://paste.ubuntu.com/1491555/

Changed in syslinux (Ubuntu):
importance: Undecided → Critical
Andres Rodriguez (andreserl) wrote :

Howdy all!

So I finally was able to do some investigation and the "fix" was quite easy, however, I do not know how convenient it would be. What I had to do in order for it not to fail was add APPEND hd0, like [1], in the template.

Now, I haven't yet found out the reason why in past releases this parameter was not necessary, however, it seems to be necessary now. Doing so basically limits us from installing into any other partition rather than the first HD, howeve,r as it stands in MAAS right now, the installtion is done in the first disk, so this should not cause any major errors.

Thoughts?

[1]: http://paste.ubuntu.com/1567672/

Andres Rodriguez (andreserl) wrote :

So a little more investigation seems to suggest that chain.c32 now requires to specify a disk in order for it to localboot [1]. So it seems that we will have to add the parameter.

[1] https://kernel.googlesource.com/pub/scm/boot/syslinux/syslinux/+/9a276818187f7679cd453f5f1224202e96fc17fc%5E1..9a276818187f7679cd453f5f1224202e96fc17fc/

Changed in maas:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in syslinux (Ubuntu):
status: New → Confirmed
psamuel (persaudsamuel) wrote :

Aun sin solucion a este inconveniente?

Changed in maas:
milestone: none → 12.10-stabilization
milestone: 12.10-stabilization → none
Changed in maas:
status: Fix Committed → Fix Released

Since this bug:

- Is valid.
- Is well described.
- Is reported in the upstream project.
- Is ready to be worked on by a developer.

It's already triaged.

Changed in syslinux (Ubuntu):
status: Confirmed → Triaged
Anders (eddiedog988) on 2014-03-13
Changed in syslinux (Ubuntu):
status: Triaged → Confirmed
Changed in syslinux (Ubuntu):
status: Confirmed → Triaged
Michael (mmcauliff1453) wrote :

Lock it now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers