programs install and work, but on every installation dpkg shows some error of a previously failed installation

Bug #1047282 reported by peT on 2012-09-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
syslinux (Ubuntu)
Undecided
Unassigned

Bug Description

Facts:
12.04.1 LTS, fresh install
*don't know which package causes error, so can't provide apt-cache policy <pkgname>*

Story is:
Ubuntu Software Center. Queued multiple programs to install (about 9 or so). First was Gimp. It seems to have downloaded fine, because the USC showed "Applying changes". So I left my laptop, thinking it would just install all the programs fine.
When I came back (half an hour later) it still showed "Applying changes" (for Gimp). My pc is not slow at all, so clearly things were going wrong. I tried to close USC and it hang up. I tried to use apt-get for installing another program and it told me dpkg was blocked, as I expected. So I tried "sudo killall dpkg" which said there is no such process.
So I restared the pc, which unlocked dpkg. And now everytime I install a program I get this error which surely is applied to this report.
Fun Fact: Gimp works anyway.
Hope this helps, greets
peter

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: extlinux 2:4.05+dfsg-2
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Fri Sep 7 12:18:09 2012
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
SourcePackage: syslinux
Title: package extlinux 2:4.05+dfsg-2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

peT (pe44) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in syslinux (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers