Upgrading Dapper -> Hardy fails (due to klogd not being restarted properly)

Bug #230342 reported by Christopher Denter on 2008-05-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sysklogd (Debian)
Fix Released
Unknown
sysklogd (Ubuntu)
Undecided
Unassigned

Bug Description

Hi.
I got a VPS (!!) which has a minimal Dapper system freshly installed.
All I did to it was:
   a) update & upgrade (affected only one or two packages)
   b) add dapper-updates repo
   c) install update-manager-core
   d) run "update-manager-core -d"

Unfortunately that *fails* at least partially. I tried this two times. The kernel log daemon, klogd, is NOT able to restart itself properly. It will shut down but will FAIL to start again.
In consequence, this will not let you reboot your system properly!

(Please keep in mind that you are not allowed to update the kernel on VPS systems, so this is likely to be the cause of the problems.)

Is there anything we can do about it?
If you need anything, just tell me.

regards

Marco Rodrigues (gothicx) wrote :

I can also confirm this bug.

Changed in update-manager-core (Ubuntu):
status: New → Confirmed
Marco Rodrigues (gothicx) wrote :

FULL LOG:
+ echo * Starting kernel log daemon...
 * Starting kernel log daemon...
+ COL=
+ mkdir -p /var/run/klogd
+ chown klog:klog /var/run/klogd
+ mkfifo -m 700 /var/run/klogd/kmsg
+ chown klog:klog /var/run/klogd/kmsg
+ start-stop-daemon --start --pidfile /var/run/klogd/kmsgpipe.pid --exec /bin/dd -b -m -- bs=1 if=/proc/kmsg of=/var/run/klogd/kmsg
+ start-stop-daemon --start --quiet --chuid klog --exec /sbin/klogd -- -P /var/run/klogd/kmsg
+ log_end_msg 1
+ [ -z 1 ]
+ log_use_usplash
+ [ n = y ]
+ type usplash_write
+ log_to_console log_end_msg 1
+ [ n != y ]
+ [ no != yes ]
+ readlink /proc/self/fd/0
+ stdin=/dev/pts/2
+ [ /dev/pts/2 != /dev/pts/2 ]
+ return 0
+ [ ]
+ [ 1 -eq 0 ]
+ echo ...fail!
   ...fail!
+ return 1
+ exit 0

$ uname -a
Linux localhost 2.6.22.18-vs2.2.0.6-ocelot #2 SMP Mon Feb 25 00:53:29 WET 2008 x86_64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.04.3 LTS
Release: 8.04
Codename: hardy

affects: update-manager-core (Ubuntu) → sysklogd (Ubuntu)
Changed in sysklogd (Debian):
status: Unknown → New
Changed in sysklogd (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.