sysdig 0.8.0-1 ADT test failure with linux-hwe 4.10.0-27.30~16.04.2

Bug #1704283 reported by Andy Whitcroft on 2017-07-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sysdig (Ubuntu)
Medium
Colin Ian King
Xenial
Undecided
Unassigned

Bug Description

SRU REQUEST [Xenial]

[Impact]

With Xenial HWE 4.10 kernels we see sysdig dkms package build failures because we are missing compat fixes for 4.10 with the Xenial sysdig dkms modules.

The fix is a minimal backport of missing compat changes to the driver, namely sysdig upstream commits:

    - [39ac26] Fix compilation issues with kernel 4.9 (#684)
    - [68823f] Ifdef __access_remote_vm since the function was made
               publicly accessible (#711)
    - [bf396c] Support for updated cpu hotplug API in 4.10
               kernel (#744)

[Test Case]

Install sysdig and sysdig-dkms. This should build the dkms modules correctly without failure. Next, one should be able to run the following command and gather sysdig events without problem:

sudo sysdig

[Regression Potential]
This could possibly break kernel combinations that we have not tested between 4.8 and 4.10. I have tested this with 4.4.0-83, 4.8.0-58 and also 4.10.0-26. The failure to build will mean that sysdig won't work on kernels we may not support.

==

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/sysdig/20170710_033817_952c5@/log.gz
    armhf: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/armhf/s/sysdig/20170710_033125_952c5@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/s/sysdig/20170710_033944_952c5@/log.gz

Andy Whitcroft (apw) wrote :
tags: added: kernel-adt-failure kernel-adt-failure-lts-trusty
Changed in sysdig (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Colin Ian King (colin-king)
status: New → In Progress
description: updated

Hello Andy, or anyone else affected,

Accepted sysdig into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sysdig/0.8.0-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in sysdig (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Colin Ian King (colin-king) wrote :

Installed Xenial, tested updated sysdig with 4.4.0-72 - works OK. Installed HWE kernel 4.10.0-27, tested with updated systed - works OK too.

Marking as validated.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sysdig - 0.8.0-1ubuntu1

---------------
sysdig (0.8.0-1ubuntu1) xenial; urgency=medium

  * Fix build issues with 4.10 HWE kernel headers (LP: #1704283)
    backports of upstream sysdig commits:
    - [39ac26] Fix compilation issues with kernel 4.9 (#684)
    - [68823f] Ifdef __access_remote_vm since the function was made
               publicly accessible (#711)
    - [bf396c] Support for updated cpu hotplug API in 4.10
               kernel (#744)

 -- Colin Ian King <email address hidden> Mon, 17 Jul 2017 14:57:52 +0100

Changed in sysdig (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for sysdig has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments