left and down arrow key won't repeat

Bug #281546 reported by phisher1 on 2008-10-11
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
synergy (Ubuntu)
Undecided
Unassigned

Bug Description

It seems every other key will repeat except for the left and down arrow keys
Ive tested every letter, number, symbol, using shift, not using shift..
only the left and down arrow will not repeat.

I do not have anything bound specifically to 'left arrow' or 'down arrow' either. This started after Intrepid upgrade... not exactly sure when though.

WORKAROUND (hardy, intrepid): xset r 113; xset r 116
JAUNTY: seems to be fixed

phisher1 (phisher1) on 2008-10-11
description: updated
tycen (tycen) wrote :

I have the exact same issue, but only when using Synergy. The down/left arrow repeats work fine on the Synergy server, but not on the client. When I use a locally attached keyboard on the Synergy client the down/left arrow keys repeat fine.

Also, if I turn off Num Lock, the down/left arrows repeat fine on the Synergy client.

The issue has persisted across a number of synergy restarts (on both client and server) and across reboots. Both client and server are running Ubuntu 8.10 final release and the issue started after the upgrade.

phisher1 (phisher1) wrote :

I should have been more verbose with my bug report. We have the exact same problem.
My Synergy server is a Windows machine, so I don't have a problem with the host, but the down/left arrows do not work the client machine.
Also, I checked with a locally attached keyboard, and the client machine's down/left arrows work properly, but only when the Synergy server's mouse was not focused on the machine.

So this is either an issue with Synergy as a client, or the way something with Intrepid is interpreting keys sent by the synergy client. I found a similar problem where keys were not mapped correctly during a FreeNX session, and the work around was to change the Model of the keyboard to an Ev-dev managed keyboard.. so I suspect this may have something to do with key mapping.

Also, this problem did not happen until my upgrade to Intrepid, while it was still Beta.

tycen (tycen) wrote :

Another bit of info: in my Synergy Client machine, I have a Red Hat virtual machine running inside of Virutal Box. The left/down arrows repeat correctly INSIDE of the Red Hat instance. So, it seems that Synergy is passing the key repeats correctly - Ubuntu just isn't listening.

to be removed (liw) wrote :

I have this problem too. I note that the numeric keypad's left and down arrows do work normally, even though the ones in the cursor key section (between the numeric keypad and the qwerty portion of the keyboard) do not.

celer (celer) wrote :

You can fix this problem by a simple workaround.

1. Enable DEBUG2 on synergy

synergy -d DEBUG2 -f YOURSERVER

2. Press the key that is not autorepeating

Look for the debug line that says 'discard autorepeat"

Find the keycode for the key that is not autorepeating, in my case it was the down and left arrows

0x74 and 0x71 respectively

Convert these to decimal values

116 and 113

Then run

`xset r 116`
`xset r 113`

restart synergy ...

I have no idea how to make this change permenent to X

Prashant (prashant-is-here) wrote :

Thanks for the workaround - works for me. Weird thing is, it is the exact same keys for me that needed repeating too (left and down).

I have made a shell script with the 2 lines and set it up to run on startup (System->Preferences->Sessions).

However, when synergy is running, the keyboard repeat doesn't work at all on the client itself (eg if I use the actual keyboard, it doesn't repeat), although it repeats through the synergy host..

Ktron (kevin-hamer) wrote :

The workaround works for me; I've made a script which I run as follow to startup up synergy on Xubuntu 8.10 to connect to another Xubuntu 8.10--

#!/bin/sh
xset r 116
xset r 113
synergyc <HOST'S IP>

Termo (termopeten) wrote :

Thanks a million!!!

I didn't bother to look for a solution until now - but this was very easy and works great. And thanks for the script Ktron!!

to be removed (liw) wrote :

I've been testing this a bit.

I have a 64-bit intrepid machine running synergys.

a) With a 32-bit intrepid machine running synergyc I get the problem. Xev does not see repeated keypresses.

b) With a 64-bit hardy machine running synergyc I don't get the problem.

c) If I upgrade synergy to the intrepid version on the machine in b), I still don't get the problem.

d) If I upgrade the whole machine in b) to intrepid, I get the problem. Thus, it seems it's not synergy itself that triggers the problem, but some library.

to be removed (liw) wrote :

A further test: I managed to finally install jaunty on my desktop machine (the
machine in b) in my previous message). Now everything seems to work fine, at least when the synergy server is running on intrepid.

I suspect this bug may be fixed in jaunty, therefore. I have no idea what the fix is, though.

description: updated

I don't use Synergy, however I hit the same problem (left and down arrow don't repeat) yesterday after upgrade from intrepid to jaunty.

This is dual-seat amd-64 machine, but the problem remains after disconnecting second keyboard and starting only the fist X server.

Maybe it's related to the keyboard (A4 Tech slim keyboard without numeric keypad - http://a4tech.com/ennew/product.asp?cid=2&scid=101&id=425).

to be removed (liw) wrote :

Zbigniew Chyla, if you're not using Synergy, you're almost certainly experiencing another bug. Please file it separately, this will help the developers keep track of it and get it fixed.

Noccy (noccy) wrote :

Works for me after upgrade to 9.04 :)

Paulo J. S. Silva (pjssilva) wrote :

Zbigniew Chyla,

I am hitting the same bug as you are and I have just opened a new bug specifically for it. See bug <a href="https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/366041">#366041</a>.

to be removed (liw) wrote :

I noticed that my script to start synergyc still had the xset workarounds. I removed them, and re-tested, and it's still fixed. This is with both client and server running jaunty.

Thus I declare this as fixed. If anyone still has this problem in jaunty, please re-open!

Changed in synergy (Ubuntu):
status: Confirmed → Fix Released

This bug appeared again in Natty.
Running KDE on 64-bit Ubuntu upgraded all the way from 9.04.

This bug has not appeared before on this machine.

Using xset r 113; xset r 116 fixes this.

I suggest re-opening the bug.

St Weiss (stweiss) wrote :

Seconded. I have a similar setup as spazzm (#16):

- server is running Kubuntu Natty 64-bit (Thinkpad T510)
- client is running Kubuntu Intrepid 32-bit (Sony Vaio)

xset r 113; xset r 116; fixes the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers