synergy-1.3.1-4ubuntu1 (intrepid) fails to connect

Bug #250869 reported by Joseph Fannin
42
Affects Status Importance Assigned to Milestone
synergy (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Geoffrey Pursell

Bug Description

Binary package hint: synergy

A synergy_1.3.1-4ubuntu1 client (the current in intrepid) fails to connect to a server running gutsy (synergy_1.3.1-2ubuntu2). Synergy works fine if I install the gutsy package on the intrepid client. It also works if I install the 1.3.1-4 package from Debian unstable -- and in the case of the latter, it does not exhibit the lags described in bug #194029 -- yay!

A dump with Wireshark shows that the -4ubuntu1 client fails to complete the synergy handshake with the server. I'll attach a .pcap file showing the failed connection attempt. I've looked at the traffic from both sides, and it's identical, i.e. the server sees what the client sends, and vice versa. The last two packets in the dump are sent after sending the client SIGQUIT (with Ctrl-\) and the two before it are from occur after the connection times out. Before hitting Ctrl-\, netstat(8) on the client shows the connection in CLOSE_WAIT.

The Ubuntu-specific changes to the upstream 1.3.1-4 package seem pretty innocuous, so this is strange. I tried to rebuild the Debian source package against intrepid, but the build failed due to Werror stuff -- I need to hunker down and try to make it build, but it's not gonna happen today. If anyone can provide any information on why the same source builds on Debian, and not on Ubuntu, that would be useful.

I'll also attach the output of `synergyc -f -d DEBUG2 {server.name} and an strace of the client when it fails to connect. The strace and top(1)'s WCHAN field agree that the client is stuck in futex_wait.

So, lots of info; hopefully some of it's useful. What can I do to help get this fixed?

Thanks.

Related branches

Revision history for this message
Joseph Fannin (jfannin) wrote :
Revision history for this message
Joseph Fannin (jfannin) wrote :
Revision history for this message
Joseph Fannin (jfannin) wrote :
Revision history for this message
Joseph Fannin (jfannin) wrote :

Okay, it looks like the .pcap I attached doesn't include the last two packets I described in the original report -- i.e. the last two packets are from the connection timing out, and the two packets I once saw after Ctrl-\'ing the client aren't in there. Maybe they weren't sent this time (though I saw them before) and maybe it's PEBKAC on my part.

The last two packets *not* here, IIRC, are a packet from the client with FIN set, and a response from the server that has ACK or RST set, depending on how long it had been since the server tried to close the connection.

Sorry about that.

Revision history for this message
Joseph Fannin (jfannin) wrote :

...and I should have said hardy, not gutsy, in all instances above.

I'm walking away from the keyboard now. ;-)

Revision history for this message
Marty (marty-supine) wrote :

Confirming this bug report although both client and server are Intrepid.

The connection attempt from the client seems to trigger high CPU usage in the server.

Revision history for this message
Marty (marty-supine) wrote :

Installing the Debian unstable version on the server side fixes both the connection issue and the performance issues from bug #194029.

Revision history for this message
Arthur (arthurb) wrote :

hardy package on the client side (hardy server) fixes this as well

Revision history for this message
Eugene San (eugenesan) wrote :

Confirming with WindowsXP as client and Intrepid as server.
Server notifies of client connection and that's it. Once after vey long time (minutes) there was message about timeout.
Rolling back to hardy's version solves the problem.

Jorge Castro (jorge)
Changed in synergy:
status: New → Confirmed
Revision history for this message
Nick Barcet (nijaba) wrote :

Confirming this bug with intrepid as a client. Attaching the DEBUG2 level log from synergyc.

Revision history for this message
IC Raibow (icrbow) wrote :

Have this issue too -- connection accepted, then timout.

Synergy is becoming more and more broken with each release ):

Revision history for this message
Sean Dague (sdague) wrote :

I'm seeing this same issue with intrepid client / hardy server.

Revision history for this message
Sean Dague (sdague) wrote :

I can also confirm that if you use the hardy package, it all works again. Whatever changes happened between hardy and intrepid for this package cause it to be completely busted.

Revision history for this message
Tim Lunn (darkxst) wrote :

I can also confirm that synergy server in the intrepid package seem to be completely broken. debian unstable package works fine.

Revision history for this message
addingnumbers (addingnumbers) wrote :

I am seeing this bug with an Intrepid client (synergy_1.3.1-4ubuntu1) and XP server running synergy 1.3.1. Everything operates normally after downgrading the Intrepid client to Hardy's synergy 1.3.1-2ubuntu2

Revision history for this message
Wouter Stomp (wouterstomp-deactivatedaccount) wrote :

Subscribed Kees Cook to this bug as he made the only changes present between debian and ubuntu versions which seem to cause the bug.

Revision history for this message
Kees Cook (kees) wrote :

There are compiler differences[1] between Debian and Ubuntu as well. I will try to isolate the root cause of the problems.

[1] https://wiki.ubuntu.com/CompilerFlags

Revision history for this message
James Snyder (jbsnyder-fanplastic) wrote :

Just writing in to confirm that I've been experiencing this same problem with Intrepid acting as the server and a Mac OS X Leopard client. Everything worked fine with hardy.

Revision history for this message
James Snyder (jbsnyder-fanplastic) wrote :

One additional note: I'm running AMD64 version of Intrepid.

As with others the 1.3.1-5 package from debian unstable works for me (debian AMD64 version).

Conan (richard-connon)
Changed in synergy:
assignee: nobody → richard-connon
Conan (richard-connon)
Changed in synergy:
assignee: richard-connon → nobody
Revision history for this message
HJRocha (hjrocha) wrote :

It happens also in Intrepid(client) and windows server 2k8 (server). It fails to connect and it forks a lot...

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synergy - 1.3.1-4ubuntu2

---------------
synergy (1.3.1-4ubuntu2) intrepid; urgency=low

  * Revert fortify warning cleanups from prior upload.
  * debian/control: Add missing XInput build dep (see LP 273386).
  * debian/rules: disable FORTIFY, as this is the major difference
    between Debian and Ubuntu (LP: #250869).

 -- Kees Cook <email address hidden> Mon, 22 Sep 2008 09:58:11 -0700

Changed in synergy:
status: Confirmed → Fix Released
Revision history for this message
Wouter Stomp (wouterstomp-deactivatedaccount) wrote :

Thanks Kees! It works perfectly again now!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers