syncevolution fails to build in maverick

Bug #644546 reported by Matthias Klose on 2010-09-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
syncevolution (Ubuntu)
Medium
Chris Coulson
Maverick
Medium
Chris Coulson

Bug Description

Binary package hint: syncevolution

build failures at
https://launchpad.net/ubuntu/+source/syncevolution/1.0+ds1~beta2a-1build1

no, please don't ask to sync the new upstream. fails to build the same way.

after fixing the first failure

--- syncevolution-1.0+ds1~beta2a.orig/src/gtk-ui/sync-ui.c
+++ syncevolution-1.0+ds1~beta2a/src/gtk-ui/sync-ui.c
@@ -2597,7 +2597,7 @@ save_config (app_data *data, SyncevoSess
 }

 static void
-sync (operation_data *op_data, SyncevoSession *session)
+syncevo_sync (operation_data *op_data, SyncevoSession *session)
 {
     GHashTable *source_modes;
     GHashTableIter iter;
@@ -2667,7 +2667,7 @@ set_config_for_sync_cb (SyncevoSession *
         return;
     }

- sync (op_data, session);
+ syncevo_sync (op_data, session);
 }

 static void

you'll see:

g++ -DHAVE_CONFIG_H -I. -I.. -DHAVE_CONFIG_H -I./gdbus -I./gdbus -I./dbus -I./syncevo -I./backends/addressbook -I./backends/evolution -I./ba
ckends/file -I./backends/maemo -I./backends/sqlite -I./backends/xmlrpc -I./gtk-ui -I./../test -I.. -I/usr/include -DORBIT2=1 -pthread -I/usr
/include/evolution-data-server-2.30 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gconf/2 -I/usr/
include/libsoup-2.4 -I/usr/include/orbit-2.0 -DORBIT2=1 -pthread -I/usr/include/evolution-data-server-2.30 -I/usr/include/ -I/usr/include/d
bus-1.0 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/libsoup-2.4 -I/usr/i
nclude/orbit-2.0 -I/usr/lib/dbus-1.0/include -DORBIT2=1 -pthread -I/usr/include/evolution-data-server-2.30 -I/usr/include/dbus-1.0 -I/usr/i
nclude/libxml2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/libsoup-2.4 -I/usr/include/orbit-2.0
 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0
/include -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/inc
lude/dbus-1.0 -I/usr/lib/dbus-1.0/include -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib/gli
b-2.0/include -I/usr/include/gnome-keyring-1 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -g -O2 -MT syncevo_dbus_server-syncevo-d
bus-server.o -MD -MP -MF .deps/syncevo_dbus_server-syncevo-dbus-server.Tpo -c -o syncevo_dbus_server-syncevo-dbus-server.o `test -f 'syncevo-
dbus-server.cpp' || echo './'`syncevo-dbus-server.cpp
In file included from ./gdbus/gdbus-cxx-bridge.h:60,
                 from syncevo-dbus-server.cpp:63:
./gdbus/gdbus.h:148: error: conflicting declaration 'typedef enum GDBusSignalFlags GDBusSignalFlags'
/usr/include/glib-2.0/gio/gioenums.h:1168: error: 'GDBusSignalFlags' has a previous declaration as 'typedef enum GDBusSignalFlags GDBusSignal
Flags'

not spending time on this

Matthias Klose (doko) on 2010-09-21
Changed in syncevolution (Ubuntu Maverick):
importance: Undecided → Medium
milestone: none → ubuntu-10.10
status: New → Confirmed
Changed in syncevolution (Ubuntu Maverick):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Oliver Joos (oliver-joos) wrote :

I will try to build this myself and will give feedback. Please note that SyncEvolution is quite important after loosing OpenSync with Lucid (https://launchpad.net/bugs/524938). SyncEvolution is the only solution left to sync mobile phones with Ubuntu directly (through Bluetooth). So please do spend some time on this.

As workaround we can add the package source of syncevolution.org itself under menu "System - Administration - Software Sources - Other Software - Add..." with the APT line:

deb http://downloads.syncevolution.org/apt stable main #SyncEvolution

IMPORTANT: backup your mobile phone and all *.ics files under ~/.evolution/ before your first sync!!! I was quite happy about my backup after a still empty Evolution of a Live-CD wiped out my phone completely because of http://bugs.meego.com/show_bug.cgi?id=7091 ;-)

Oliver Joos (oliver-joos) wrote :

The bug mentioned at the end of last comment has been fixed in less than 24 hours after I reported it. Another hint for quality in this great project. Thank you Patrick Ohly!

Changed in syncevolution (Ubuntu Maverick):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Coulson (chrisccoulson)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package syncevolution - 1.0+ds1~beta2a-1ubuntu1

---------------
syncevolution (1.0+ds1~beta2a-1ubuntu1) maverick; urgency=low

  * Fix LP: #644546 - syncevolution fails to build in Maverick. Rename
    some symbols which now conflict with GDBus
    - add debian/patches/01_fix_duplicated_symbols.patch
    - add debian/patches/series
 -- Chris Coulson <email address hidden> Fri, 01 Oct 2010 14:19:59 +0100

Changed in syncevolution (Ubuntu Maverick):
status: Fix Committed → Fix Released
Oliver Joos (oliver-joos) wrote :

@Chris: Thank you for fixing this! I was only able to compile the newer 1.0.99.6 (beta of 1.1). Nice to hear that syncevolution now won't be left out of Maverick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.