unable to start sync-ui - terminated with message Segmentation fault (core dumped)

Bug #447150 reported by max
This bug affects 11 people
Affects Status Importance Assigned to Milestone
syncevolution (Ubuntu)

Bug Description

Binary package hint: syncevolution

I tried to install and setup sync-ui.
when I run it is first time I was able to choose service (myFunambol), inter account and password.
After this I choose remove all data on server.
and now when I try to start sync-ui It is open for second and close.
In terminal I received message:
Segmentation fault (core dumped)

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 9 07:20:07 2009
DistroRelease: Ubuntu 9.10
Package: sync-ui 0.9+ds1-2
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
SourcePackage: syncevolution
Uname: Linux 2.6.31-12-generic x86_64
 (gnome-settings-daemon:2014): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2147): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2112): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:2111): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.2/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

Revision history for this message
max (mikhmv) wrote :
Revision history for this message
Paulino (paulino) wrote :

If delete folder: $HOME/.cache/.syncevolution the program run only once. The next time crashed

Revision history for this message
Steven Redlich (sredlich) wrote :

I'm getting a segmentation on AMD64 as well.

I had successfully synced evolution with myfunambol server, and days later after making updates on my mobile device am unable to sync with evolution again.

I've captured the output of

$ strace sync-ui

and will provide upon request.

I did not find a core file.

steve@lenny:~$ uname -a
Linux lenny 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux
steve@lenny:~$ cat /etc/issue
Ubuntu 9.10 \n \l

steve@lenny:~$ dpkg -l sync-ui
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
ii sync-ui 0.9+ds1-2 Evolution data synchronization program using

Please let me know if I can provide other info.


Revision history for this message
Steven Redlich (sredlich) wrote :

running under gdb provides more detail about the segmentation fault:

Starting program: /usr/bin/sync-ui
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff458b73b in IA__g_type_name (type=<value optimized out>)
    at /build/buildd/glib2.0-2.22.2/gobject/gtype.c:3054
3054 /build/buildd/glib2.0-2.22.2/gobject/gtype.c: No such file or directory.
 in /build/buildd/glib2.0-2.22.2/gobject/gtype.c

Changed in syncevolution (Ubuntu):
status: New → Confirmed
Revision history for this message
MichaelE (michael-eitelwein) wrote :

Have the same problem here with AMD64 under 9.10. It first worked well and suddenly sync-ui crashes immediately with a segfault. The log shows

montreal kernel: [ 79.032405] sync-ui[3556]: segfault at 490 ip 00007f202380073b sp 00007fff50b80b00 error 4 in libgobject-2.0.so.0.2200.2[7f20237db000+44000]

I also replicate with a funambol server.

Revision history for this message
joostvanderwulp@gmail.com (joostvanderwulp) wrote :

same problem here

Only way to get it work again: go to /home/username/.cache/syncevolution and delete all its content.
than delete all your appointments, tasks, notes and contacts in evolution

Than it works again.. not really an already usable application... pitty...

I also noticed that all post-adresses are gone

I sync with funambol server

Hope we/you/they can work it out, i would like to switch from thunderbird to evolution...

Changed in syncevolution (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Laurent Bigonville (bigon) wrote :

Full trace

#0 0x00007ffff44fefcd in IA__g_type_name (type=<value optimized out>) at /build/buildd/glib2.0-2.23.3/gobject/gtype.c:3254
#1 0x00007ffff4d9c40d in build_specialization_name (container=<value optimized out>, num_types=14, types=0x69d690) at dbus-gtype-specialized.c:248
#2 lookup_or_register_specialized (container=<value optimized out>, num_types=14, types=0x69d690) at dbus-gtype-specialized.c:459
#3 0x00007ffff4d9c63c in dbus_g_type_get_struct (container=0x413303 "GValueArray", first_type=140737488346168) at dbus-gtype-specialized.c:561
#4 0x000000000040df62 in syncevo_report_array_free (array=0x77ec40) at syncevo-dbus-types.c:319
#5 0x00007ffff421f1bb in IA__g_ptr_array_foreach (array=0x77eec0, func=0x40deb0 <syncevo_report_array_free>, user_data=0x0) at /build/buildd/glib2.0-2.23.3/glib/garray.c:1310
#6 0x000000000040a618 in get_sync_reports_cb (service=<value optimized out>, reports=0x77eec0, error=<value optimized out>, data=<value optimized out>) at sync-ui.c:1385
#7 0x000000000040f10e in get_sync_reports_async_callback (proxy=<value optimized out>, reports=0x6bcd53, error=0x69d7c0, data=0x77e200) at syncevo-dbus.c:902
#8 0x000000000040f2fa in org_Moblin_SyncEvolution_get_sync_reports_async_callback (proxy=0x6bb570, call=0x2, user_data=0x7868c0) at interfaces/syncevo-bindings.h:344
#9 0x00007ffff4b53eba in complete_pending_call_and_unlock (connection=0x6bd640, pending=0x7a75b0, message=<value optimized out>) at dbus-connection.c:2227
#10 0x00007ffff4b560ff in dbus_connection_dispatch (connection=0x6bd640) at dbus-connection.c:4390
#11 0x00007ffff4d8eca5 in message_queue_dispatch (source=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at dbus-gmain.c:101
#12 0x00007ffff4245ef0 in g_main_dispatch (context=0x65ec60) at /build/buildd/glib2.0-2.23.3/glib/gmain.c:1960
#13 IA__g_main_context_dispatch (context=0x65ec60) at /build/buildd/glib2.0-2.23.3/glib/gmain.c:2513
#14 0x00007ffff4249d28 in g_main_context_iterate (context=0x65ec60, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.23.3/glib/gmain.c:2591
#15 0x00007ffff424a26d in IA__g_main_loop_run (loop=0x7a73f0) at /build/buildd/glib2.0-2.23.3/glib/gmain.c:2799
#16 0x00007ffff76ab677 in IA__gtk_main () at /build/buildd/gtk+2.0-2.19.5/gtk/gtkmain.c:1219
#17 0x0000000000406120 in main (argc=1, argv=0x7fffffffe178) at main.c:125

Revision history for this message
Dunkirk (david-davidkrider) wrote :

I've had the same problem. (GDB bt shows the failure in gobject.) I also tried using the latest version of the software from http://syncevolution.org/documentation/installation, but I still have problems.

Revision history for this message
MichaelE (michael-eitelwein) wrote :

Problem seems to be gone on Meerkat beta (AMD64) with sync-ui 1.0+ds1~beta2a-1. Had no segfault since I upgraded to the beta.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.