Synce-trayicon fails to start synce-engine

Bug #469048 reported by Justas on 2009-11-01
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
synce-sync-engine (Debian)
Fix Released
Unknown
synce-sync-engine (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Glenn Louttit
Nominated for Lucid by Paede

Bug Description

Binary package hint: synce-trayicon

I have installed all synce packages in karmic. When I click on "View device status" I get message:
"Failed to retrieve partnership information: Failed to execute program /usr/bin/sync-engine: Success"
There are two problems:
1) The correct path is "/usr/bin/synce-sync-engine" and not "/usr/bin/sync-engine".
2) There is no logic in error message, it can't be success if it failed to start a sync engine"

Packages versions:
synce-hal 0.13.1-2
synce-sync-eng 0.13-2ubuntu1
synce-trayicon 0.13-2

justas@Zaibukas:~$ uname -a
Linux Zaibukas 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

justas@Zaibukas:~$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

Justas (justas+) wrote :

Error message screen attached.

Mark Ellis (mark-mpellis) wrote :

The dbus activation file in the synce-sync-engine package (probably /usr/share/dbus-1/services/org.synce.SyncEngine.service but I don't know for certain because I only deal with the synce ppa packages) has the wrong path in it, it should be /usr/bin/synce-sync-engine. This bug has nothing at all to do with synce-trayicon.

eval- (eval-) wrote :

I have the same bug, and editing /usr/share/dbus-1/services/org.synce.SyncEngine.service to the proper path fixed it. Wonder where the ":success" message is from?

jcfp (jcfp) wrote :

Bug #423965 is about the same issue, but from a different angle.

affects: synce-trayicon (Ubuntu) → synce-sync-engine (Ubuntu)
Changed in synce-sync-engine (Ubuntu):
status: New → Confirmed
Changed in synce-sync-engine (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.